www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik mspgcc und F2132


Autor: Odic (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

ich benötige eure Unterstützung bzgl. des mspgcc. Zwar habe ich den 
Compiler seit Jahren im Einsatz, möchte nun aber das erste Mal mit einem 
F2132 arbeiten. Allerdings scheint der Typ für meine Installation zu neu 
zu sein.

Nach einer kompletten Neuinstallation (nach 
http://sourceforge.net/apps/mediawiki/mspgcc/index...) 
habe ich zwar nun die notwendigen Header und den Startup-Code, der 
msp430-gcc kennt das Derivat aber immernoch nicht.

cc1: MCU msp430x2132 not supported


Hat mir jemand einen Tip, wo ich mit der Fehlersuche beginnen könnte?


Beste Grüße,
Odic

Autor: Odic (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Niemand eine clevere Idee für mich???

Arbeitet jemand erfolgreich mit einem F21x2?

Beste Grüße,
Odic

Autor: Dennis (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich krieg den MSP garnicht mit Eclipse und gcc zum laufen...

Autor: Odic (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Naja, Konsole wäre auch schon mal ein Anfang... ;-)

Autor: Dennis (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Na gut, in der Konsole erkennt er meinen F2418 wenigstens..

Autor: Peter Diener (pdiener) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Man kann doch als Target auch angeben, dass es ein unbekannter F2xxx 
ist, nur die zugehörigen Headerfiles muss man selber erstellen.

In den aktuellen Quellcodes (version 20100726) hab ich grad mal 
nachgesehen, wird der F2132 unterstützt.
http://sourceforge.net/projects/mspgcc4/files/

Grüße,

Peter

Autor: Pothead (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mit dem 3er-gcc hatte ich bei diesem Derivat keine Probleme. Ich würde 
sagen: Einfach deinstallieren und neu draufbraten - hilft wohl manchmal.

Autor: Odic (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ist das eine Kugelfuhr...

Nach mehrfachem De- und Neuinstallieren funktioniert jetzt alles.

Erst hatte ich zwei msp430-gcc drauf, dann hat der verbleibenden gcc die 
falschen binutils (den as für x86) verwendet, dann stimmten die Pfade zu 
libc und den Headerdateien nicht...


Beste Grüße,
odic

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.