www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik MCP25055 antwortet nicht


Autor: Holm Sommer (Gast)
Datum:
Angehängte Dateien:
  • my.dvs (465 Bytes, 121 Downloads)

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich versuche verzweifelt einen MCP25055 (CAN I/O Expander von
microchip) zum laufen zu bekommen. Nachdem ich diesen chip erfolgreich
programmiert habe, tut sich leider gar nichts.
Ich habe "sheduled tx" auf ca 200ms eingestellt, aber auf dem bus
sind absolut keine daten zu sehn. Auf Anfragen (z.B AD-Register
auslesen) reagiert er auch nicht.
Beim Auslesen der Programmierdaten stimmen diese mit den programmierten
Daten überein. -> Programmer IO.

Als Software zum Programmieren nutze ich den "MCP250xx Programmer
V1.1" von microchip. Meine Programmierdaten als Dateianhang.

Hat jemand eine Idee an was das liegen könnte ???
Giebt es noch Register die ich übersehen hab ???

Danke Holm

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.