www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Liion Pack (4S2P) mit PWM laden?


Autor: Martin K. (martin_k)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
ich möchte ein Liion Akkupack mit 8 Zellen (4 in serie, 2 parallel) 
Laden.
realisiert habe ich das ganze im Moment mit PWM.
Den Ausgang habe ich mit einer Induktivität 47mH und einem Kondensator 
470µF geglättet. Die PWM Frequenz beträgt 16kHz. Soweit so gut, die 
Akkus lassen sich auch laden.

Ich habe mir nun mal die ausgangsspannung mit einem Oszi genauer 
angesehen, und musste leider feststellen, dass da unschöne 
spannungspeaks zu erkennen sind. Ich bekomme die nicht weg! egal welche 
zusätzlichen glättungsmaßnahmen ich versuche...

Meine Fragen nun an euch:

Woher kommen diese "nadeln" auf meinem Oszi?
Wie bekomme ich die weg?
Schaden sie dem Akku?

vielen Dank!

Autor: Markus Müller (mmvisual)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich glaube, dass bei Q2, R41 10 Ohm und D4 12V irgend was kaputt geht, 
wenn die Eingangsspannung tatsächlich 19V sein sollte.
Die Mosfets halten in der Regel +/-20V an G aus daher die D4 weg lassen.
Lösche C6
Lösche D6
Mache anstatt C6 lieber eine Diode rein, Richtung wie D6.

Das mit R13 soll eine Strommessung werden?
Wird nicht klappen, erwärme mal die Schaltung mit einem Föhn, dann weißt 
Du warum. Nimm lieber anstatt den Dioden D2/3 einen AD628.

Anstatt dem LM324 einen LM393. Dann kannst Du die D1 löschen.

R35 könnte eher 2,2K sein.

Autor: Andreas Lang (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Moin,

wenn du eine Zenerdiode vor die Treiberstufe setzt, kannst du die 
Gatespannung gleich begrenzen, ohne dass da direkt am FET die volle 
Treiberleistung an der Diode anliegt.

Gruß
Andi

Autor: Martin K. (martin_k)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Danke! ich werde mal heute Abend den aufbau gemäß deiner Anregungen 
ändern.

Mit der Strommessung klappt es auf die weise sogar relativ gut.
ist nicht sonderlich genau aber so auf ca. 50 mA klappt es schon.
Hab allerdings viel mit Software tricksen müssen...
Mit einem AD628 ist es aber viel eleganter, da gebe ich dir recht. 
kannte dieses bauteil noch nicht. die nächste Platine wird sicherlich 
damit bestückt!

Was ich mir noch überlegt habe, ist den R41 gegen was hochohmiges 
auszutauschen 5-10kOhm. Dann würde ich doch von PWM in einen Linearen 
bereich kommen? der MOSFET würde dann halt recht warm...

Autor: Martin K. (martin_k)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hab grad jemanden mit einem ähnlichem problem gefunden:

Beitrag "Re: Richtiger Kondensator für Schaltregler"

werde also erstmal meine Messtechnik überprüfen und eine kurze 
tastspitze verwenden...

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.