www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik EA DIP180-5 an Atmega8 in Bascom - Debugging fehler


Autor: Andy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo alle miteinander,

Möchte ein EA DIP180-5 Grafik LCD Display an den Atmega8 anschließen.

Habe folgenden Quellcode in Bascom:

 $regfile = "m8def.dat"
 $framesize = 32
 $swstack = 32
 $hwstack = 32
 $crystal = 1000000

 $baud = 9600


 $lib "glcdEADIP180.lbx"
 Config Graphlcd = Sed180 * 32 , Dataport = Portb , Controlport = Portc 
, Ce = 0 , Ce2 = 1 , Ce3 = 2 , Cd = 3 , Rd = 4 , Reset = 5
 Config Pind.7 = Output

 Cls

 Cursor Off

 Wait 1

 Locate 1 , 1

 Lcd "Test"


  Do

     Portd.7 = 1
     Pset 1 , 1 , 1

     Waitms 500

     Portd.7 = 0
     Pset 1 , 1 , 0

     Waitms 500

  Loop

Wenn ich nun das Programm "Compilieren" will, kommt folgender Bascom 
fehler: Unknown CONFIG parameter [SED180*32]

Aber Bascom unterstüzt dieses Display von Haus aus, so stehts in der 
Hilfe. Das Display besitzt den Controller: SED1520 daraus schließe ich 
das ich es schon richtig ansteuere. Weis nicht was ich an den Parametern 
ändern soll, da in der Hilfe genau dieser text steht das ich es so 
eintragen soll...habe das Programm auch einfach mal in den uC 
übertragen...aber das Programm läuft nicht an, das sehe ich an der 
Angeschlossenen LED an PortD.7. Sie blinkt nicht. Das LCD selber zeigt 
auch nichts an.
Habe Ce, Ce2 und Ce3 mit den E1, E2 und E3 (Enable Spalte) des Displays 
verbunden. Cd mit A0 (Umschlatung Befehl / Daten) des Displays 
verbunden. Rd mit R/W (H = Read, L = Write) des Displays verunden.

Weis mir nicht mehr zu Helfen, da in Google nur immer dieser Code 
auffindbar war (180*32sed) dies müsste eigentlich stimmen, aber Bascom 
meckert und ich weis nicht warum =(
Hoffe auf Vorschläge und Hilfestellungen von euch =)
MfG Andy
Danke.

Autor: Stefan B. (stefan) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Welche BASCOM Version?
Mindestens 1.11.9.0 erforderlich

Autor: Andy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
oh es ist 1.11.8.7
aber die Library ist schon vorhanden nur meckert der Compiler muss ich 
wohl updaten?

MfG

Autor: Andy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sry Compiler Version 1.11.8.7
IDE Version: 1.11.9.8

Welche Version ist gemeint?

MfG

Autor: Andy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
an der Version kann es also nicht liegen denke ich ist ziemlich neu..

Autor: Ha jo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vermutlich wird die Compiler-Version gemeint sein, denn mit dem Compiler 
werden ja auch die Librarys installiert. Die IDE ist ja nur das Frontend 
für den Benutzer, die alle einzelnen Tools schön für dich zusammenfasst.

Autor: Andy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hab jetzt die Compiler Version 1.11.9.0
-> immer noch der gleiche Fehler =(
MfG

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.