www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik MSP430 - erstes Debuggen - valid setup


Autor: B. S. (mimir)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Einen schönen Wochenstart wünsch ich Euch erst einmal!

Möchte eine LED mit dem im CCS mitgelieferten Programm msp430x5xx.c 
blinken lassen und scheitere beim Debuggen. Denke das Problem ist, daß 
ich nicht weiß, wie man ein neues Projekt im CCS so startet, daß der 
Compiler das vorherige vergisst.

uC: MSP430F5529
USB-Debug-Interface: MSP-FET430UIF mit MSP-TS340PN80USB
Software: Code Composer Studio


Was ich bisher gemacht habe:
- Das Debug-Interface wird vom PC erkannt.
- "Hello World" per Simulation vorher ausprobiert, ok.
- Habe ein neues Projekt ("Hello_LED.c") gestartet, jedoch das alte ist 
auch erhalten geblieben.
- Habe dann das alte Projekt ("Hello World") gelöscht, auch im Ordner 
"Workspace" und auch das alte .xxxml-file im Ornder 
...user\CCSTargetConfigurations".
- Bin dann der Beschreibung im Dokument slau1570CCS.pdf (s.Anhang) von 
TI, Kapitel 1.2 "Flashing the LED" weiter gefolgt.
- Fehlermeldung:

"...Reason:
The target configuration
C:/Users/mimir/Documents/TI_workspace/Workspace/Hello_LED/Hello_LED_targ 
et2.ccxml
is not compatible with the current target configuration
C:\Users\mimir\Documents\TI_workspace\Workspace\hello2\64xsim.ccxml"

Anmerkungen zur Fehlermeldung:
- Das genannte File 64xsim.ccxml ist das File von der Simulation vorher 
("Hello_World").
- Komisch finde ich auch, daß bei der Fehlermeldung einmal / und einmal 
\ in den jeweiligen Pfaden verwendet werden.

Anmerkung zur Targetkonfiguration:
Habe die Connection TI MSP430 USB1 oder ...USB2 oder ...USB3 mit dem 
Device MSP430F5529 ausprobiert.


Frage 1:
Kann mir jemand verraten kann, wie man auf ordentliche Weise ein neues 
Projekt starten kann, so daß sich der Compiler die alten Zustände nicht 
merkt?

Frage 2:
Seht Ihr das Problem woanders?

Frage 2:
Hat das mit den / und den \ etwas zu sagen?


Vielen Dank im Vorraus!

Autor: B. S. (mimir)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

Habe jetzt einen komplett neuen Workspace angelegt, da CCS scheinbar 
nach jedem Löschen des Ordners Workspace von Hand (über Windows) 
automatisch wieder irgendwelche Files in den vorherigen Workspace legt.

Nun funktioniert es!
Die Frage hat sich also erledigt.

Entschuldigt bitte mein schnelles Fragen.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.