www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Verwirrung!!! Atmel162 und AVR Studio zeigt nur 1/2 SRAM an


Autor: andreas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Jetzt weiß ich nicht mehr weiter. Ich wollte ein Programm testen,
welches Daten aus der oberen Hälfte des SRAM´s ausließt und in ein
Schieberegister schiebt. Um nicht immer Einzen zu schieben wollte ich
die Daten verändern (in der Memoryanzeige "Daten"). Nun zeigt er mir
aber nur 512k an, also bis Adresse $25F. Und der Rest? In der
"m162def.inc" und dem Datenblatt steht das RamEnd bei Adresse $4FF.

Muss ich im Programm außer der "m162def.inc" noch andere Sachen
vereinbaren um den gesamten Speicher nutzen zu können?

Kann sich dies jemand erklären? Oder besser mir vielleicht auch. ;)

Dank und Gruß an alle

Andreas

Autor: Sebastian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hast du in "DEBUG/SIMULATOR OPTIONS" auch den m162 ausgewählt... weil
bei mir zeig er alles an.

Autor: andreas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Sebastian,

vielen, vielen Dank, das war genau der richtige Hinweis!!!


Grüße Andreas

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.