www.mikrocontroller.net

Forum: Platinen KiCAD: 3D mit Wings3D geht nicht.


Autor: Simon S. (-schumi-)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich hab ein (hoffentlich kleines) Problem mit KiCAD auf Ubuntu. (eig. 
Lubuntu, weil mit LXDE als Fenstermanager)

Installiert hab ich KiCAD wenn ich mich richig erinnere mit
>sudo apt-get install kicad
Dann erstmal damit rumgespielt, und später dann mit
>sudo apt-get install wings3d
wings3d installiert um meine Layouts auch in 3D angucken zu können.

Habs mal unter Windows probiert und dort funktionierts problemlos. Wenn 
ich aber unter Linux irgendetwas in 3D anschauen möchte (z.B. im Layout 
mit PCBnew -> "3D Darstellung") schließt sich das Programm (z.B. PCBnew) 
einfach und nix weiter. Kein leeres Fenster, keine Fehlermeldung, kein 
garnix...

Woran liegts???

Schon mal Danke
-schumi-

PS: Ich weis dass meine Frage in irgendeinem KiCAD Forum besser 
aufgehoben währe, aber bevor ich mich dort anmelde probier ichs doch 
erst hier

Autor: Simon S. (-schumi-)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
PROBLEM GELÖST!!

Woran hats gelegen? -> ich weis es nicht xD

Aber abhilfe hat folgendes geschaffen:
KiCAD mit
>sudo apt-get autoremove kicad
deinstalliert und nach nach der Anleitung auf 
http://kicad.sourceforge.net/wiki/index.php/DE:KiC... 
heruntergeladen und wieder installiert -> funktioniert einwandfrei!

So, damit ist der Thread wohl mehr oder weniger sinnlos und darf auch 
gerne gelöscht werden.

MfG und vielen Dank an mich selbst xD
-schumi-

Autor: Mike4 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Starte mal KiCad über die Konsole und schau ob dort ein Fehler 
ausgegeben wird.


Ich häge die Vermutung das du keinen vernünftigen Grafikkarten treiber 
hast aber ich kann mich natürlich auch täuschen.


lg mike

Autor: Bernd Wiebus (berndwiebus) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Simon.

> PROBLEM GELÖST!!
>
> Woran hats gelegen? -> ich weis es nicht xD
>
> Aber abhilfe hat folgendes geschaffen:
> KiCAD mit
>>sudo apt-get autoremove kicad
> deinstalliert und nach nach der Anleitung auf
>
> http://kicad.sourceforge.net/wiki/index.php/DE:KiC...
> Installation heruntergeladen und wieder installiert -> funktioniert
> einwandfrei!

Es ist mir schon aufgefallen, das die Packete in den verschiedensten 
Distributionen um einige Versionsnummern hinter der aktuellen stabilen
KiCAD Version hinterherhinken.

Vermutlich hast Du jetzt eine aktuellere, und davor Altversionen von 
typischerweise 2006 oder 2008.

Die aktuellen Versionen findest Du jetzt bei Launchpad, nicht mehr bei 
Sourceforge....darum hast Du jetzt immer noch eine ältere Version: vom 
14.03.2010. Die aktuell stabile ist vom 05.05.2010.

Für eine aktuelle stabile Version sollte auch 
http://iut-tice.ujf-grenoble.fr/kicad/ auch eine gute Adresse sein.

Mit freundlichem Gruß: Bernd Wiebus alias dl1eic

http://www.dl0dg.de

Autor: Simon Huwyler (simi)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe mit Ubuntu 10.10 und Kicad 05052010 das selbe Problem.

Mit der 10.04 ging's super. Dann habe ich auf 10.10 updated, und - bevor 
ich Kicad einmal ausprobierte - einen Snapshot geladen (alle executables 
überschrieben). Diese Konfiguration zeigte dann eben das oben 
beschriebene Verhalten.
Nun habe ich wieder 05052010 drauf, und es funktioniert immernoch nicht.
Ging da jetzt irgendwas durch den Snapshot kaputt oder liegt's an Ubuntu 
10.10???

Deshalb meine Frage an Euch (vor allem an Simon): Läuft Kicad 3D mit 
Ubuntu 10.10?

Gruss
Simon

Autor: Bernd Wiebus (berndwiebus) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Simon.

> Nun habe ich wieder 05052010 drauf, und es funktioniert immernoch nicht.
> Ging da jetzt irgendwas durch den Snapshot kaputt oder liegt's an Ubuntu
> 10.10???

So aus dem Bauch heraus würde ich sagen, es liegt eher an Ubuntu. 
Irgendwas
ist da scheinbar nicht richtig entfernt worden.


>
> Deshalb meine Frage an Euch (vor allem an Simon): Läuft Kicad 3D mit
> Ubuntu 10.10?

Dazu kann ich nicht wirklich etwas sagen, weil ich Debian Lenny verwende 
und nix mit 3D mache. Ein kurzer Test zeigt mir aber, das unter Debian 
Lenny und der KiCAD Version vom 05.05.2010 für Ubuntu 8.10 das 3D vom 
Beispielprojekt aus dem Package funktioniert.....was auch ein Indiz 
dafür wäre, das es eher an Ubuntu liegt. Ob es aber auch in der Tiefe in 
jedem Detail funktioniert, weiss ich auch nicht.

Dafür funktioniert bei mir der GerbVie rexport in PCBnew hinein nicht 
mehr richtig: Die Blinks werden nicht übernommen. :-(
Das lief mal besser.......:-(

Mit freundlichem Gruß: Bernd Wiebus alias dl1eic

http://www.dl0dg.de

Autor: Simon S. (-schumi-) (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi nochmal, dann war der Thread ja doch nicht so sinnlos ;-)

>Deshalb meine Frage an Euch (vor allem an Simon): Läuft Kicad 3D mit
>Ubuntu 10.10?
Das kann ich dir im Moment nicht beantworten (bin nicht zu hause)
Installiert hab ich 10.04, aber ob der Kernel via apt-get upgrade schon 
geupdatet wurde weis ich nicht, müsste mal nachschauen...

@Bernd:
Danke für den Hinweis! Werde heute nachmittag/abend warscheinlich noch 
mal updaten, dauert ja nicht lange... (ob man die alte Version wohl 
einfach überschreiben kann? Ohne vorher deinstallieren?)
Das mit dem Grafiktreiber müsste ich mal überprüfen, denn bei dem Paket 
aus den Repositorys ging alles wuderbar schnell, jetzt stockt es 
immer... (CPU: 700 Mhz, kann es vielleicht sein dass das normal ist und 
sonst noch keinem aufgrund eines schnelleren Computers augefallen ist?)

MfG
Simon

Autor: Simon Huwyler (simi)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich bin nicht der einzige mit dem Problem.

Ubuntu 10.10 beisst sich mit dem Kicac-3D-Viewer. Bug-Report ist schon 
gemacht.

Gruäss
Simon

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.