www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik ATtiny13 mit 128kHz ausgesperrt


Autor: Stefan P. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

ich hab heute einen tiny13 dummer weise auf 128kHz Takt runter gefused. 
Nun komme ich mit meinem avrispv2 / avrispmkII (USBprog) nicht mehr 
drauf. Grund ist mir bekannt -> Programmierfrequenz muss kleiner als 
1/4-CPU-Takt sein. Sollten dann bei mir weniger als 32kHz sein.
Ich nutze zum proggen den avrdude. Eigentlich sollte ich doch mit der 
Einstellung -i N (z. B. -i 32) den Takt soweit runter setzen können das 
ich die Fuses wieder umstellen kann. Funktioniert leider nicht.
D:\Elektronik\Programme\Avrdude>avrdude -c avrispv2 -P usb -i32 -pt13 -t

avrdude: stk500v2_command(): command failed
avrdude: stk500v2_recv_mk2: error in USB receive
avrdude: stk500v2_program_enable(): bad STK600 connection status: Unknown (0x64)

avrdude: initialization failed, rc=-1
         Double check connections and try again, or use -F to override
         this check.


avrdude done.  Thank you.

Habe auch schon Werte für -i vergrößert und verkleinert (10, 20, 30, 50, 
100, 1000,..)
Hilft leider alles nichts. Hat jemand die Lösung?

Vielen Dank
Stefan

Autor: G a s t (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

du kannst versuchen den Bitclock mit der Kommandozeilenoption -B 
heruntersetzen:
-B <bitclock>              Specify JTAG/STK500v2 bit clock period (us).
Beispielsweise -B32 für f=32.25 kHz. Habe ich schonmal erfolgreich mit 
einem AVR ISPmkII eingesetzt.

Gast

Autor: Stefan P. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für den Tipp, werd ich heut Abend gleich mal ausprobieren.

Ich habe auch noch einen nagel neuen AVRDragon zuhause. Normalerweise 
müsste ich den dann doch auch mittels HV wieder fitt bekommen? Hab den 
Dragon allerdings noch nie eingesetzt und hab auch keine Ahnung wie das 
funktioniert. Eine kurze Anleitung oder ein Link wäre durchaus 
hilfreich. Hab auch schon gegoogled aber noch nix wirklich gutes 
gefunden.

Gruß
Stefan

Autor: Klaus Wachtler (mfgkw)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Fehlt dir zufällig die Doku zum Dragon?
http://support.atmel.no/knowledgebase/avrstudiohel...

Autor: Stefan P. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja sowas in der Richtung hab ich gesucht, danke Klaus. Da hab ich wohl 
nicht gut genug gesucht ;-)

Gruß
Stefan

Autor: Stefan P. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

ich habs gestern Abend noch ausprobiert. -B32 funktioniert super, gleich 
beim ersten Versuch. Nun läuft er wieder auf 4,8MHz ;-)

Thx
Stefan

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.