www.mikrocontroller.net

Forum: FPGA, VHDL & Co. Coolrunner Starter Kit funktioniert nicht


Autor: Johann Tanzer (yaoshu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hey Leute,
bitte helft mir, ich versuch seit 2 tagen das zum laufen zu bringen und 
es geht einfach nicht...

ich hab das hier:
http://shop.trenz-electronic.de/catalog/product_in...
das Xilinx CoolRunner-II CPLD Starter Kit

Es gibt dieses Coolrunner Utility Window nur für Windows, deshalb hab 
ich es in meiner Windows XP - Virtual Machine unter Mac installiert 
zusammen mit dem Xillinx ISE 12.3

dann hab ich das teil angesteckt und es wurde als Digilent USB Device 
erkannt aber das Utility Window konnte sich nicht damit verbinden...

dann hab ich ISE 12.3 deinstalliert, den treiber deinstalliert, ISE 10.1 
(war bei der platine dabei) installiert - angesteckt - wieder 
automatisch als Digilent USB Device erkannt und installiert - und es 
geht genauso wenig.
es erscheint im Geräte-Manager als Digilent USB Device aber das Utility 
Window kann sich nicht damit verbinden...

auf den Xillinx Seiten finde ich nichts hilfreiches.
kann mir bitte irgendjemand helfen?

Autor: Duke Scarring (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Klingt nach einem Problem mit der Virtuellen Maschine und USB. Kannst Du 
das evtl. mal nativ (sprich direkt unter Windows) testen?

Duke

Autor: schneetiger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Helfen kann ich derzeit auch nicht, aber auch ich bin an einer Lösung 
interessiert.
Habe auch Mac OS und verschiedene Versionen von VirtualBox sowie 
Parallels Desktop probiert - Niente!

Das Gerät wird erkannt, aber die spätere Kommunikation stolpert.
Ich stecke nicht in der Software von Xilinx drin, aber ich vermute ein 
Timing-Problem.
Ich kenne niemanden, der den Coolrunner in einer VM zum Laufen gebracht 
hätte, sei es Linux oder Mac OS als Host-OS, wogegen einige Programmer 
jedoch wohl laufen sollen. Die sind allerdings auch teurer und hier 
übernimmt möglicherweise die HW das Timing.

Mich ärgert das auch.

Grüße.

Autor: Duke Scarring (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Problem mit den USB-Programmern in der Virtuellen Maschine liegt 
darin, das sie beim Anmelden verschiedene USB-IDs haben. Die müssen dann 
ggf. alle an die Virtuelle Maschine durchgereicht werden. Vielleicht 
hilft der Blog-Eintrag unter [1].
Mit dem Digilent-Spartan3E-Board (Xilinx-Programmer integriert) hatte 
ich Erfolg unter VirtualBox.

Duke

[1] 
http://peeters-noppe.net/alcaic/2009/09/virtualbox...

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [vhdl]VHDL-Code[/vhdl]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.