www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik LED-Treiber Iout ändern?


Autor: Aike T. (biertrinker)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

ich habe mir folgenden Led-Treiber bei DX gekauft:

http://www.dealextreme.com/details.dx/sku.13556

Da ich diesen Treiber für andere Led-Module verwenden will, die zwischen 
120 und 200 mA vertragen, versuche ich den Treiber um zu bauen.

Ich habe jetzt als erstes einmal versucht den Schaltplan aufzunehmen, 
diesen habe ich angehängt.

Der Verwendete IC ist ein AP3706, das Datenblatt dazu findet man z.B. 
hier:

http://pdf1.alldatasheet.com/datasheet-pdf/view/22...

Im moment versuche ich noch zu ermitteln, in wie weit die Schaltung mit 
der im Datenblatt hinterlegten Standardbeschaltung übereinstimmt.

Leider ist es mir bisher durch Datenblatt lesen noch nicht gelungen zu 
ermitteln, was ich ändern muss um die Iout zu beeinflussen.

ich würde mich echt freuen, wenn mit jemand dabei helfen würde!

vielen Dank und viele Grüße

Aike

Autor: ArnoR (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du müsstest den Widerstand R2 entsprechend ändern. Halber Wert > 
doppelter Strom.

Autor: GB (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: Aike T. (biertrinker)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Das mit R2 scheint mir halbwegs logisch. Bei aktuell 2r und ca 300mA 
müsste es also eigentlich passen. Leider ist es mir bisher nicht 
gelungen aus den Datenblatt zu entnehmen wie man das berechnet?

Viele Grüße

Aike

Autor: Pete K. (pete77)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
www.duden.de

Autor: Aike T. (biertrinker)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo nochmal,

habe da doch noch ein Problem, welches ich erst lösen muss, bevor ich 
mich daran machen kann den LED-Treiber zu verändern.
Ich habe eben mal den Treiber zur Probe mit einer Powerled verbunden und 
angeschlossen.
Ergebnis ist, das die Led nicht konstant leuchtet, sondern flackert.
Dabei wird die Led nur mit ca. 1,9V Versorgt, es fließen dabei ca. 
30-40mA.

Wenn ich nun ein Multimeter zwischen Treiber und Led hänge mit 
Messbereich 200mA, dann leuchtet die Led plötzlich konstant. Dabei zeigt 
das Multimeter dann nichts an, da Messbereich überschritten.

Hat jemand eine Idee, was das sein könnte?

viele Grüße

Aike

Autor: BMK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Laut Produktbeschreibung ist der Treiber für 3 x 1W LED deklariert.

Also wird er mit 3 LED à 3,3V Vf = 10V seine 300...320mA liefern.
Oder mit 5 roten LED à 1,9V Vf ergibt ebenfalls um die 10V.

Könnte gut sein, dass er mit 1 LED nicht klarkommt

'Richtige' Konstantstromquellen haben nämlich eine Strommessung
auf der Ausgangsseite per Shunt, die dann über einen Optokoppler
auf die primäre Regelung zurück geführt wird.

Autor: Aike T. (biertrinker)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Oh man, ja, das könnte gut das Problem sein.

Da habe ich garnicht drüber nach gedacht. Werde ich heute Abend testen.

Dabei hatte ich mir sogar etwas dabei gedacht das so auszuwählen, da das 
COB-Modul, welches ich damit betreiben will aus 6 x 3 Leds besteht, 
typische Spannung 9-14V, 120-200mA. Da passte der Treiber für 3x1W 
besser als einer für 1x3W.

Das mit dem Shunt kenn ich, so hatte ich es eigentlich auch erwartet bei 
dieser Schaltung anzutreffen.

vielen Dank und viele Grüße

Aike

Autor: Aike T. (biertrinker)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nabend,

kurze Erfolgsmeldung: COB-Modul mit 6x3 Leds, R2 auf 3,3 Ohm geändert 
läuft prima bei 190mA und etwa 7,9V.

Genau wie ich es brauche.

vielen Dank für die Hilfe!

Aike

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.