www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Probleme mit Sinusgenerator


Autor: Sven (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

es ist vielleicht nicht unbedingt die richtige Schaltung für dieses 
Board,aber sicherlich könnt ihr mir trotzdem weiterhelfen.
Diese Schaltung sollte eigentlich eine sinusspannung mit ca. 1000 Hz 
liefern,sie bringt mir aber ca. 4000 Hz.
Somit kommt aus dem Trafo nix raus.
Das ganze soll eigentlich für die EL-Beleuchtung eines Displays 
dienen,und zwar rückwirkungsfrei auf das PC-Netzteil.
Derjenige der die Schaltung entworfen hat bekam sie ohne Probleme zum 
Laufen,bei mir geht es einfach nicht.
An Drossel und Kondensator kann es nicht liegen,habe ich mir noch mal 
neu besorgt-ohne Erfolg.
Woran kann es noch liegen,bzw. welcher Fehler könnte die Schaltung dazu 
veranlassen 4x schneller als normal zu schwingen?

Autor: Günter König (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Sven,

Ursache könnte eine Verpolung von L1 sein. Kontrolliere das doch nochmal 
(auf die Punkte achten!!).

Gruß,
Günter

Autor: Sven (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hmm,

ich weiß jetzt nicht so richtig was Du mit "auf die Punkte achten" 
meinst,aber theoretisch kann ich dort nix verpolt haben.
Ich habe 2 Anschlüsse welche diagonal gegenüberligen miteinander 
verbunden,dadurch entsteht aus den 2 spulen "eine" spule mit gleichem 
Wicklungssinn.An diese Verbindung lege ich die +5V.

Die anderen beiden Anschlüsse gehen zu den Anschlüssen des Kondensators.
Kann da was verkehrt sein?

Autor: Günter König (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Sven,

die Punkte geben meist den Wicklungsanfang an. In der HF-Technik nennt 
man das auch "kaltes Ende". In deiner Schaltung sind an den Pins 1 und 2 
die Punkte auch eingezeichnet.

Wenn du jetzt die Schaltung genau betrachtest, gehen deine 5V einmal zum 
kalten Ende (Spannung für Q2) und einmal zum heißen Ende (Spannung für 
Q1).

Es entsteht daher keine Spule aus zwei Wicklungen mit gleichem 
Wicklungsinn. Es ist vielmehr ein Spule mit Mittenanzapfung (Speisung 
5V) und den Ausgängen für Q1 und Q2.Wechselspannungsmäßig gesehen sind 
die Spulen gegensinnig geschaltet. Dies muss auch so sein, damit die 
Rückkopplungsbedingung erfüllt ist und eine Schwingung überhaupt 
entstehen kann (kannst ja mal googeln -> Rückkopplungsbedingung). So auf 
die Schnelle ist das Thema nämlich nicht so leicht abzuhandeln.
Versuch doch einfach mal, eine Wicklung umzupolen. Du wirst sehen, es 
wird funktionieren.

Gruß,
Günter

P.S.  Bitte berichte weiter

Autor: Günter König (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nachtrag: Bitte für C2 keinen Elko nehmen!!!!!!!

Günter

Autor: SvenGWK (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hmm,das lässt sich wirklich schlecht erklären,verstehe aber was du 
meinst.
Im Moment ist das so angeschlossen wie auf dem Bild hier 
dargestellt,habe so eine Drossel mal gescannt und die Pins 
rangeschrieben wie ich sie angeschlossen habe.
Das sollte doch normalerweise stimmen,oder?

Autor: Günter König (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Sven,

dein Bildchen zeigt eine Stromkompensierte Drossel. Es ist gut zu sehen, 
das die Wicklungen gegensinnig verlaufen wie für den typischen 
Anwendungsfall auch erforderlich.
Du solltest es wirklich mal versuchen, eine Wicklung umzupolen z. B. 3 + 
2 vertauschen.
In der Regel baut man die Spule etwas anders auf......

Gruß,
Günter

Autor: Günter König (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Oh Sven,

entschuldige, Asche auf mein Haupt, ich habe nur blödsinn erzählt!!!
Ich habe irgendwie dein Problem überhaupt nicht erkannt. Ist wohl der 
Stress auf der Maloche.

Also: vergrössere mal deinen Kondensator C2 auf einen Wert von 47µF. 
Dies ist der Normwert.
Wenn die Frequenz dann zu niedrig ist, musst du dir einen Kondensator 
aus mehreren anderen zusammenbasteln. Hier gilt: Reihenschaltung von 
Kondensatoren

Cgesamt = (Ca * Cb) / (Ca + Cb)

Der Gesamtwert wird kleiner als der kleinste Einzelwert.

Parallelschalten von Kondensatoren

Cgesamt = Ca + Cb + ..... Cn

Dann solltest du auf deine 1KHz kommen.


Sorry nochmals,
Günter

Autor: SvenGWK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
An den Kondensator dachte ich ja auch schon,allerdings funktioniert das 
nicht so richtig.
Die Frequenz verringert sich wenn ich z.b. noch einen 10mikroF 
kondensator parrallel schalte,dann habe ich ja theoretisch 20mikro.
Allerdings bricht die ganze Sache dann zusammen wenn ich den Trafo 
anschließe.
Dann lassen sich nur noch sehr spannungsarme Schwingungen messen,da ich 
kein "echtes" Oszi zur Verfügung habe kann ich nur vermuten das es so um 
die 800 Hz sein könnten.
Der Schwingkreis der Schaltung ist mit dem eingesetzten 10mikroFarad 
Kondensator und der 1,2 mH Spule eigentlich richtig berechnet und sollte 
normalerweise funktionieren.
Kann ich eventuell noch was anderes falsch gemacht haben?
Habe zwar alles schon zig-mal kontrolliert aber man weiß ja nie...
Hat jemand die Möglichkeit und Lust das mal aufzubauen und damit zu 
experimentieren?

Autor: Günter König (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Sven,

ich könnte das mal am Wochenende probieren. Allerdings habe ich nicht 
diese FET`s zur Verfügung.
Die Fehlfunktion liegt aber vermutlich am Kernmaterial deiner Kreisspule 
L1.
Welche Leistung brauchst du denn auf der 230V Seite

Gruß,
Günter

Autor: SvenGWK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hmm,

die Leistung kann man in Watt leider nicht richtig bestimmen.
Eine EL-Folie mit den Maßen ca. 17x3,5 cm sollte vernünftig daran 
betrieben werden können.
Das klappt eigentlich auch,derjenige der die Schaltung getestet hatte 
schrieb das die Folie gut leuchtet.
Ich habe in einem anderen Forum jetzt noch einen anderen Vorschlag 
bekommen,darin wird ein IC SG3525 als "Taktgeber" für die Mosfets 
verwendet.
Diese Methode würde die Fehlerquelle Drossel also gänzlich ausschließen.
Allerdings ist der Bauteileaufwand mit 30 ein wenig hoch gegriffen,da 
ich das ganze leider nur auf Lochrasterplatine zusammenbauen kann.
Das Kabelwirwarr wäre wahrscheinlioch unglaublich...
Ehe ich das probiere würde ich lieber mit Deiner Hilfe noch mal an der 
anderen Schaltung herumexperimentieren.

Autor: SvenGWK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mir kam da gerade eine Idee...
Da ich das ganze sowiso am Computer betreiben möchte könnte ich doch 
auch diesen für die Erzeugung ddr Frequenz "missbrauchen".
Die 5v für die Mosfets ließen sich doch sicherlich auch mittels Rechner 
mit 1khz erzeugen,richtig?
Ideal dafür wäre sicherlich die parallele Schnittstelle,allerdings ist 
diese schon durch den Stecker des LCD´s besetzt.
Die COM1 ist schon mit einem Infrarotempfänger belegt,und der Gameport 
liefert die Betriebsspannung für das LCD.
Bliebe also noch der Com2.
Ist das prnzipiell ohne größeren Aufwand möglich,mal abgsehen vom VBasic 
Programm?

Autor: Günter König (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Im Prinzip schon aber......
Du müsstest immer noch eine möglichst sinusförmige Wechselspannung 
erzeugen um diese auf den Wert von 230V zu bekommen. Leider mögen Trafos 
nur ungern eine Rechteckspannung. Das heisst also: Tiefpassfilter und 
all diesen Blödsinn. Die Schaltung ist daher schon ganz gut und in der 
Einfachheit nicht zu überbieten. Und das Problem mit der Spule ist 
eigentlich keins. Und diese paar Windungen wird man doch wohl noch 
selbst auf einen entsprechenden Kern bringen, oder?
Die Lösung mit dem PC ist daher eigentlich schon als verbrecherisch zu 
bezeichnen.

Trotzalledem müsste ich wissen, wieviel Ampere auf der 230V-Seite 
fließen müssen.

Gruß,
Günter

Autor: SvenGWK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Habe gerade mal beim Suchen nach einer etwas genaueren Beschribung 
solcher Folien eine Seite gefunden:

http://www.weber-innovation.de/html/expertenforum.htm

Dort wird beschrieben das bei Seiko-folien (das Display ist von Seiko) 
die optimalen Betriebsbedingungen ~100V und 400 Hz sind.
Bei 200 Hz verdoppelt sich die Lebensdauer sogar.
Demzufolge sind die 1khz wahrscheinlich doch sehr hoch gegriffen gewesen 
die ich da vorgeschlagen bekommen hatte,und ich kann von daher sogar 
noch froh sein das es nicht funktioniert hat...
Bei geringerer Frequenz sinkt auch die Helligkeit.
Die Schaltung sollte also ~100 V 300 Hz bringen und muss deshalb 
wahrscheinlich nochmal überdacht werden...

        1
f=--------------
  2Pi*[Wurzel]CL

müsste doch die richtige Formel sein?
Habe leider überhaupt keine Ahnung wie ich die Formel umstellen muss,bin 
in dieser hinsicht nicht so ein Profi. :-[

Autor: SvenGWK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ach so,

die genaue Stromaufnahme weiß ich immer noch nicht.
Allerdings sollte der Trafo 1,8VA Trafo den ich habe völlig ausreichend 
sein.
Die Stromaufnahme im Leerlauf sollte nach den Angaben des Zeichners in 
etwa 200mA betragen.

Autor: SvenGWK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast Du vielleicht schon herausgefunden wie es klappen könnte?
Wie gesagt,die Schaltung sollte am besten ~100V 300Hz Sinus bringen.
Was brauche ich da für einen Kondensator?

Autor: Günter König (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Sven,

machen wir noch mal etwas Grundlagenforschung: Du hast einen Oszillator 
gebaut (einen sogenannten Gegentaktoszillator) der dir eine Sinusförmige 
Schwingung erzeugt. Das macht die Schaltung auch. Die Frequenz mit der 
der Oszillator schwingt errechnet sich aus

1 / ( 2  pi  SQR(L * C)   (Hz, H, F)

oder

f = 159 / sqr(L * C)    (MHz, µH, pF)

Hieraus kannst du nun deinen Kondensator für die gewünschte Frequenz 
errechnen:

C = 1 / ((2  pi  f)^2 * L)

Bei deiner Spule mit 2,4 mH sind das also 263µF.
Im übrigen braucht man zur Umstellung von Formeln keine Kenntnisse in 
der Elektronik sondern einfachste mathematische Grundlagen (Algebra).

So, das wäre das eine. Jetzt zu deinen Spulen (Trafos) in deiner 
Schaltung: Um eine Wechselspannung übertragen zu können, muss ein 
wechselndes magnetisches Feld vorhanden sein. Dieses hast du mit L1 und 
C2 sowie der Beschaltung hierfür erzeugt und es wird im Trafo TR1 
wirksam. Das magnetische Feld wird den im Trafo vorhandenen Eisenkern 
magnetisieren und zwar mit wechselnder Polarität (theoretisch). Leider 
gelingt dies nicht, wenn der Eisenkern nicht will.
In deiner Schaltung will der Trafo TR1 nämlich nicht, er ist für eine 
Frequenz von 50 Hz ausgelegt und eine Frequenz von 1KHz und höher wird 
der nicht mehr zur Kenntniss nehmen. Er wird im schlimmsten Fall warm 
weil nur noch der ohmsche Widerstand der Kupferwicklung wirksam ist. 
Daher ist auch die Kreisspule L1 im Prinzip überlastet und eine 
sinnvolle Spannung wird nicht mehr wirksam.

Abhilfe:
1. C2 auf einen Wert um 220µF erhöhen, hier kannst du zwei Elkos von 
470µF nehmen die gegenpolig verschaltet sind.

2. Tr1 für eine Frequenz von 200Hz besorgen oder selber wickeln.

Ich habe die Schaltung heute morgen mal aufgebaut allerdings mit 
normalen Transistoren (BD543), und es traten die gleichen Probleme wie 
von dir beschrieben auf. Dann habe ich einen Schalenkern für 
Tonfrequenzanwendungen genommen, ein paar Windungen rauf und getestet. 
Es funktioniert, allerdings kann ich keine Leistung entnehmen weil Draht 
zu dünn und Kern zu klein.
Bei einer Frequenz von 150 - 200Hz ging aber auch ein normaler kleiner 
Netztrafo recht ordentlich. Ich bekam ca. 160V Wechselspannung heraus 
und konnte mit 5mA belasten. Das entspricht einer Leistung von 0,8VA.

Versuche es also nochmal, vergrössere C2 und messe. Um ein bisschen 
experimentieren wirst du nicht herumkommen.

Gruß und Glückauf,
Günter

Autor: SvenGWK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

das mit dem Spulenkern hatte ich auch schon mal probiert,
daß funzt auch bei 4khz,stimmt.
Da hatte sogar die Folie daran aufgeleuchtet,aber mit dieser Frequenz 
wäre es Mord. :-)
Ich werde mal ein wenig mit der Kondensatorgröße experimentieren und 
meine "Erfolge" posten.

Dankeschön übrigens für Deine Bemühungungen. :-)

Autor: SvenGWK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So,
habe jetzt mal ein wenig experimentiert.
Habe als Kondensator 2 Elkos mit jeweils 220µF  genommen,erhielt so also 
einen 110µF Kondensator.
Die Drossel hat übrigens 2x 1,2mH (Weiß nicht ob sich der Kondensator 
halbieren müsste?).
Auch wenn es eventuell nicht der richtige Wert ist sollte die Schaltung 
eigentlich anschwingen,das tut sie aber nicht.
Habe irgendwie das Gefühl das es mit Elkos nicht klappen will,denn als 
ich versuchsweise 2x100µF verwendete ging auch rein gar nix.

Autor: SvenGWK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Oder sollte ich die Schaltung mit normalen Transistoren aufbauen?
Die Mosfets brauchen ganze 5V,nicht wahr?

Autor: Günter König (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast du denn möglicherweise noch zwei Transistoren 2N3055 zur Hand?

Günter

Autor: SvenGWK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nein,leider nicht.
Ich habe allerdings zwei Leuchtstofflampen Wandler hier mit Transistoren 
H1061.
Leider kann ich nirgends ein Datenblatt finden.
Ob die auch funktionieren?

Autor: Günter König (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Na gut,

ich schicke dir mal ein Bildchen so wie ich es aufgebaut habe. Als Trafo 
habe ich einen mit sekundär 5 V / primär 230 V  2,5VA  genommen. 
Aufgebaut auf Lochrasterplatte.

Die ganze Sache haut astrein hin. Mit den BD 543 haut es sehr gut hin, 
aber sie müssen gekühlt werden. Ein BD 239 macht es auch.

Als Kreiskondensator empfehle ich dringend einen bipolaren Typ 
(Lautsprecher haben meist solche Teile drin). Elkos haben einen zu hohen 
Leckstrom. Möglicherweise geht es mit gegenpolig geschalteten 
Tantal-Elkos.

Und wenn es mal nicht auf Anhieb funktioniert, kontrollieren und eine 
Wicklung vom Trafo umpolen!!!!

Gruß,
Günter

Autor: SvenGWK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hmm,

da werde ich mir mal Montag so einen Trafo und die Transistoren 
organisieren gehen.
Dankeschön für den Schaltungsvorschlag!

Autor: Günter König (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn du dir einen Trafo besorgst, dann nimm bitte auch den Richtigen! 
Auch dieser Schaltungsvorschlag stellt nur eine Notlösung da weil der 
Trafo auch nur für 50Hz ausgelegt ist. Der Wirkungsgrad ist 
grottenschlecht, die Transistoren werden ziemlich heiss und es kommt 
kaum Leistung raus.

Bevor du das Geld ausgeben willst bedenke aber, das es auch fertige 
Lösungen gibt. Musst mal im Internet suchen.

Sodenn,
Günter

Autor: Günter König (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Sven,

hier ist was fertiges, musst mal schauen.

http://www.andilcd.d/seiten/inverter.php

Günter

Autor: Günter König (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Sven nochmal,

Mist, link falsch. Jetzt aber richtig:

http://www.andilcd.de/seiten/inverter.php

Günter

Autor: SvenGWK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hmm,
ja ich weiß das es diese Inverter auch zu kaufen gibt.
Sie sind aber für meine Zwecke völlig ungeeignet,da sie durch ihre 
rechteckspannung zu viele Störungen verursachen und einen gemeinsamen 
Ein- und Ausgang für die Masse benutzen.
Es geht also zu viel "Unfug" zurück in die Spannungsquelle,in meinem 
Falle ein PC-Netzteil,die nach einer Weile den Geist aufgeben wird.
Zum Trafo,leider kann ich nirgendwo einen Trafo mit 2x5V finden.
Wo hast Du das Ding gekauft?

Autor: Günter König (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Siehste Sven, da gehts schon los. Den Trafo habe ich aus Restbeständen 
unserer Firma vor vielen Jahren mal entnommen, da brauchten wir mal 
sowas. Zur Info, Es gibt aber Trafos mit 2 * 6 Volt. Allerdings auch nur 
für 50 Hz.
Mal so ganz überschlägig: du bräuchtest einen Trafo mit 2 * 2,5 Volt, 
Sekundärstrom bis 4 A bei 50Hz. Oder wenn du findest 2 * 2,5 Volt / 1 A 
für 200Hz. Den 50Hz Typ wirst du wahrscheinlich nach einer gewissen Zeit 
in die Grütze fahren........

Wie kommst du in Gottes Namen eigentlich darauf, das du dir mit den 
käuflichen Invertern das PC-Netzteil killst? Und es gibt sehr wohl 
Wandler mit galvanischer Trennung! Lass mal Googeln ("CFL Inverter"), du 
findest alles mögliche.

Eigentlich dachte ich ja, das Ganze sollte eine Wissenserweiterung 
darstellen, eben nur mal so :-). Na gut, denn man viel Spass..........


Gruß,
Günter


Na denn mal los und viel Freude

Autor: SvenGWK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hmm,
ich werde mal versuchen ein wenig mit der Sache zu experimentieren bis 
es so funzt wie es soll.
Die sache mit den PC-Netzteilen ist schon einigen Leuten passiert die 
Conrad-Inverter verwendet hatten.
Diese Inverter haben einen gemeinsamen Masseanschluß für die Ein- und 
Ausgangsspannung und erzeugen derart heftige Störungen das die Netzteile 
nach 1-2 Monaten einfach den Geist aufgeben.
Außerdem erzeugen  diese Inverter kein Sinus-signal und stören heftig im 
Radio.
Da ich ein Bedienteil für einen im Kofferraum untergebrachten PC 
bastele,will ich den Inverter quasi in einem Gerät verbauen welches sich 
unter meinem autoradio befindet.
Deshalb der ganze Aufwand.
Leider habe ich keinen wirklich geeigneten Wandler finden können.
Es steht leider nirgends dazu mit welcher Wellenform die Hochspannung 
ausgegeben wird.
Sinus stört nun mal am wenigsten.
Naja,ich werde es wie gesagt noch mal ausgiebig probieren,wird schon 
schiefgehen. ;-)

Autor: Günter König (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du solltest dir mal die Seite von "LCD-Module" ansehen. Da gibts Wandler 
so wie du sie brauchst.

Günter

Autor: SvenGWK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Leider nicht,
ich habe da gerade angerufen.
Die liefern erstmal nur an firmen,desweiteren haben sie wohl keine 
Wandler die wirklich eine Sinusspannung bringen und galvanische Trennung 
besitzen.
Ein Bekannter will mir einen kaputten Laptop für 15€ verkaufen,ob mich 
der wandler des Displays weiterbringt?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.