www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik nicht geht mehr


Autor: Clemens (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe folgendes Problem und vielleicht kann mir jemand helfen (Ich
bin noch neu in der Materie).

Ich habe ein AVR CTRL V1.0 Board mit einem ATMEGA32. Ich habe alles
zusammen gebaut und an meinen Rechner über den LPT1 angeschlossen. Die
Pinbelegung ist PIN2 -> MO; PIN4 -> RE; PIN5 -> SCK; PIN11 -> MISO;
PIN20 -> GND.
AVR Studio sowie BASCOM erkennt keinen Chip (ATMEGA32 ist in der lib
vorhanden). Ich kann nichts auslesen oder programmieren, es leuchtet
nur eine LED auf dem Board und das LCD-Display zeigt schwarze Balken.
Ich benutze XP mit ServicePack2. Liegt es vielleicht daran?
Ich habe keine Ahnung was ich machen muss.

mfg Clemens

Autor: Sebastian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
winxp hat wohl probleme mit programmern am lpt

Autor: Clemens (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
sollte ich das ganze über die serielle schnittstelle probieren?

Autor: Rufus T. Firefly (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mit Bascom kann man auch unter XP problemlos mit STK200-kompatiblen
Parallelportprogrammierern* arbeiten.

Allerdings hat Bascom Probleme, die parallele Schnittstelle anzufassen,
wenn kein Druckertreiber installiert ist, der die parallele
Schnittstelle nutzt.
Benutzen muss man den Treiber nicht, er muss nur installiert sein.



*) in der Bascom-Dokumentation ist auch ein Schaltplan für so einen
angegeben, der funktioniert völlig problemlos.
Der Schaltplan wurde von mir in Threads gepostet, in denen es um die
Programmierung des AT89S53 gibt - mal' danach suchen.

Autor: Sebastian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
das es ein programmer für die paralelle schnittstelle ist wird das nicht
gehen. teste mal ob es funzt wenn du im gerätemanger den lpt öffnest und
die irg option auf "immer irq benutzen" oder so stellst.

Autor: ChrisB (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Für das paralelle Kabel versuch am besten mal PonyProg.
http://www.lancos.com/prog.html
Die aktuelle Beta !!

Das funktioniert bei mir in verbindung mit AVR-CTRL und 2000 sowie XP
super auf meinen Notebooks. Wichtig ist das die Kabellänge kurz
gehalten wird.

Autor: ChrisB (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Achzoo, hier stehen auch die Einstellungen beschrieben :

http://mikrocontroller.cco-ev.de/de/isp.htm

DT-006 parallel

Autor: ChrisB (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sorry ich nochmal, der direkte Link funzt nit :(
Also die Einstellungen auf www.mikrocontroller.com und dann im Menü auf
ISP dort der Abschnitt DT-006

Autor: Clemens (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
vielen dank...

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.