www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Problem mit BASCOM und ATmega8


Autor: NO_MA_AM (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
ich habe das Buch von Roland Walter "AVR Mikrocontroller Lehrbuch"
mit CD
gekauft. Wenn ich die Original ***.hex mit TwinAVR auf den ATmega8
brenne funktioniert alles
wie im Buch beschrieben, aber wenn ich denn Basis-Code zu der ***.hex
mit BASCOM-AVR neu compiliere hat
die ***.hex eine andere Größe und der ATmega8 läuft nicht.
Und auch alles andere was ich mit BASCOM-AVR compiliere läuft nicht.
Was mache ich denn falsch??
Ich bin schon eine Woche am rumprobieren, ohne Erfolg.

mfg
NO_MA_AM

Autor: formtapez (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast Du denn bei Options/Compiler/Chip den richtigen µC ausgewählt?

MfG
formtapez

Autor: cdg (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
das gleiche Problem hatte ich auch.

Lag irgendwie an meinem WinXP.

Das Programm unter Win98 kompiliert lief dann einwandfrei.

Angeblich beim Hersteller und Distri solls aber keine Probs geben.

Darum mein Tip, versuche es mal mit Win98
und gib eine Rückmeldung.

MfG cdg

Autor: Rufus T. Firefly (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
BASCOM-AVR kann auch unter XP SP2 korrekt übersetzen. Auch die
integrierte Unterstützung für Parallelportprogrammieradapter
(STK200-kompatibel) funktioniert unter XP SP2 problemlos, sofern ein
Druckertreiber installiert ist, der die Schnittstelle verwendet.

Daran sollte es also nicht liegen; in den trüben Tümpel Win98 muss man
daher nicht springen.

Autor: NO_MA_AM (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielen Dank für euere Tipp erstmal.

Denn richten µC für den Compiler habe ich schon gewählt.

Ich habe XP SP2 als OS, aber ich Werde es mal mit
Win98 als zweites OS probieren.
Hatte sowieso schon seit landen von mir ein stabiles und
zuverlässiges System für meine Entwicklungsumgebung zu schaffen.

Ich meld mich dann noch mal ob es was gebracht hat.

mfg
NO_MA_AM

Autor: NO_MA_AM (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe den Fehler gefunden, in Menü Options--->Compiler--->Output war
ein hacken bei "Swap words", die hat die ***.hex so verändert das der
ATmega8 nicht mehr anlief.

mfg
NO_MA_AM

Autor: Rufus T. Firefly (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
"Ich habe XP SP2 als OS, aber ich Werde es mal mit
Win98 als zweites OS probieren.
Hatte sowieso schon seit landen von mir ein stabiles und
zuverlässiges System für meine Entwicklungsumgebung zu schaffen."

Sorry, aber das ist Satire, oder?

Autor: faust (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sorry OT:

NO_MA_AM, hast du vor einiger Zeit mal GR gezockt. Ich kannte da mal
jemanden: [+]NO_MAAM

OT Ende.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.