www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik DS18S20 Taktrate


Autor: Matthias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

ich hab hier erstmals einen OneWire Temperatursensor (DS18S20) in
Betrieb genommen.

Wenn ich mich an die Zeiten für das OneWire-Protokoll aus dem
Datenblatt halte kann ich den Sensor nur bei etwa 50% der Lesevorgänge
auslesen. In meiner Verzweiflung hab ich den Bus dann mal um etwa 1/3
beschleunigt (sprich alle Zeiten verkürzt) und seitdem kommt kein
falscher Lesevorgang (z.Z. 3.2*10e5)  mehr zustande. Kann sich das
jemand erklären bzw. sogar bestätigen?

Matthias

Autor: Uwe Nagel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich nehme an, du hast irgendeine als 'MAX' definierte Zeit voll
ausgenutzt.
Zum DS18S20 gibts genug Programmbeispiele, zB. hier in der
Codesammlung. Vergleiche mal das Timing.

Uwe

Autor: Matthias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

ich kann Timingdiagramme lesen und verstehen. Alles komplett gegen
Oszibild verglichen und keine Abweichung festgestellt. Alle INT's
waren im System deaktiviert. Das kanns also auch nicht sein.

Der Master Reset-Puls hat aktuell 300µs. Das ist laut Spezifikation 40%
zu kurz. Ebenso fallen ein paar andere Zeiten jetzt nach unten aus dem
Raster.

Matthias

Autor: Stefan May (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie groß ist denn Dein Pullup-Widerstand und hast Du auch direkt am
Sensor gemessen? Eventuell verfälscht das dazwischenliegende Kabel. Und
wie lang ist das?

ciao, Stefan.

Autor: Matthias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

der Tastkopf hängt direkt am Sensor. Der Widerstand hat 3,3k.
Anschlußkabel hat 4cm.

Matthias

Autor: Stefan May (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hmmm, verstehe ich nicht ganz. Passiert Dir das auch mit anderen
DS18S20?

Also entweder machst Du beim Ablesen was verkehrt, was ich nicht denke,
oder bei Dir passiert was Magisches. Kannst Du mir mal den Quellcode
schicken, dann probiere ich das mal aus. Ich habe hier mehrere DS1820
und einen Mega8 oder Mega128 zum testen. Ich könnte dann verifizieren,
ob es an der Hardware liegt.

ciao, Stefan.

Autor: peter dannegger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Spontan würde ich auf falsche Quarzfrequenz oder falschen Oszillatortyp
tippen.

Ich habe mich jedenfalls exakt an die Angaben im Datenblatt gehalten
und  es funktioniert.

Am kritischsten ist die Lesezeit <15µs, die darf auf keinen Fall
überschritten werden.


Hier mal mein Beispielcode:

http://www.mikrocontroller.net/forum/read-4-84831.html#new


Peter

Autor: Matthias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

falsche Oszillatoreinstellungen würden ich jetzt mal ausschließen. Die
Zeiten stimmen ja laut DSO. Und ich denke das kann ich bediehnen :-)

Das Timing beim Lesen (insbesondere wohl beim Lesen einer "0") ist
wirklich nicht unkritisch. Muß ich mir morgen nochmal anschauen.
Gefällt mir garnicht das ich da für ~10µs die INT's dicht machen muß.

Matthias

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.