www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Dimmer flimmert


Autor: MIke (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!
Habe mittels uc einen digitalen Dimmer gebaut.
Kann den Dimmer von voller Beleuchtung bis mittlerer Beleuchtung gut
dimmen nur ungefähr ab der Hälfte beginnt der Dimmer zu flackern. Was
kann da sein. Ungefähr wenn ich den Sinus erst am Spitzenwert
Anschneide beginnt er zu flackern.
Hatte schon jemand mal ein solches Problem oder weiß was da los sein
kann?
mfg MIke

Autor: Stefan May (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was dimmst Du denn genau? Glühbirne? Halogentrafo?

ciao, Stefan.

Autor: MIke (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Glühbirne

Nullpunkterkennung ist okay!

Kann auch von 100% - 0 dimmen doch ab 50 flimmert

mfg MIke

Autor: Stefan May (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast Du die Nullpunkterkennung auf dem Oszi gesehen? Vorsicht beim
Messen an Netzspannung. Dazu ist ein dafür geeigneter Tastkopf
notwendig!

ciao, Stefan.

Autor: MIke (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie gesagt Nullpunkt ist gemessen und in ordnung!

Kann das  flimmern von der fehlenden schutzbeschaltung komen?

Autor: Stefan May (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
könnte schon sein. Sollte doch aber bei einer Glühbirne (ohmscher
Verbraucher) nicht auftreten. Du könntest aber mal eine Glübirne
kleinerer Leistung probieren.

ciao, Stefan.

Autor: Peter Dannegger (peda)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
"Kann auch von 100% - 0 dimmen doch ab 50 flimmert"

Klingt so, als ob du nur auf einen Nulldurchgang triggerst.

Dann fehlt Dir bei <50% eine komplette Halbwelle.

Du must mit 100Hz triggern, d.h. beide Halbwellen.


Peter

Autor: MIke (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nein Triggere bei jedem NULLdurchgang! 100Hz

Autor: Kurt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Mike,

Triac's haben ev. unterschiedliche Schaltschwellempfindlichkeiten
in den Pos/Neg Halbwellen.
Könntest ja mal einen Brückengleichrichter dazwischenschalten.

Gruss Kurt

Autor: Ralf (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

wie lange zündest Du? Evt. ist die Last zu klein und der min.
Haltestrom wird unterschritten, d.h. der Triac geht vor Ende der
Halbwelle schon zu.

Gruß    R A L F

Autor: Sven (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Noch'n Vorschlag: Wenn Du den Triac in beiden Halbwellen mit einem
positiven Puls zündest, arbeitest Du im 1. und 4. Quadranten*. Im 4.
Quadranten ist der erforderliche Zündstrom meist doppelt so hoch wie in
1..3. Kann sein, dass Du gerade an Schwelle bist und bei zu geringer
Spannung über dem Triac (0..50%) die Zündung in jeder 2. Halbwelle
nicht klappt. Also Zündstrom erhöhen (100..150mA). Einige Triacs zünden
im 4. Quadranten gar nicht (Snubberless und manche LogikLevel), aber das
scheint bei Dir ja nicht der Fall zu sein.

Sven

*) Was das heißt, steht in verschiedenen Datenblättern

Autor: josef (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was noch in Frage kommt: Rundsteueranlagen irritieren den
Nulldurchgangsdedektor. Ausserdem wurde hier noch nichts von einer
Phasenverschiebung gesagt(Strom-Spannung). Da kann es passieren, dass
der Dedektor mehrmals schaltet.

SG Josef

Autor: holektron (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das flimmern der Lampe ist fast normal. Das flimmern ist ein
"Thermisches Zittern" der Lampe. Hinter einem Lampenschirm sieht man
das nicht. Sieh mal mit dem Scope die Spannung an der Glühlampe an: Ab
einem bestimmten zündwinkel sieht man das flckern! Der Effekt ist also
nicht neu. Bei starkem flackern kann natürlich auch eine halbwelle
fehlen. dann sieh die anderen Tips.
Gruß Jörg

Autor: Sebastian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hatte genau das gleiche Problem wie Du. Ein paar Denkansätze:

1.) Du sagst, Du triggerst jeden Nulldurchgang. Wie machst Du das? Wenn
Du in Deiner Nulldurchgangskennung keinen Gleichrichter hast und sowohl
auf die steigende als auch auf die fallende Flanke triggerst, musst Du
Dir bewusst machen, dass das ungenau ist. Lieber nur auf die fallende
Flanke triggern und dann mittels Timer den 2. Nulldurchgang
"simulieren". Das ist genauer. Wenn Du einen Gleichrichter vor dem OK
hast, ist dias nicht Dein Problem. Wie ich gleich widerholen werde,
Deine Nullpunkterkennung MUSS noch im Mikrosekundenbereich genau sein
(oder zumindest in steigender und fallender Flanke gleich ungenau).

2.) Dein Problem ist mit Sicherheit, dass Deine Zündzeitpunkte in neg.
und pos. Halbwelle unterschiedlich sind. Dann sieht man gerade bei
halber Leistung sehr deutliches flimmern, auch wenn die Abweichung der
Zündzeitpunkte nur 10us(!) beträgt. Guckst Du hier:
http://www.mikrocontroller.net/forum/read-1-140727.html
Bei fast voll oder fast Null ist dann kein Flimmern sichtbar.

3.) Entgegen einer Behauptung hier im Thread: Phasenverschiebung bei
ohmschen Lasten, wie z.B. Glühbirnen gibt es nicht! Also ist das nicht
Dein Problem.

4.) Entgegen einiger Behauptungen in diesem Forum: Dimmer flimmern
nicht automatisch (zumindest nicht im sichtbaren Bereich). Ich habe
beruflich mit Licht zu tun und sehe flimmern recht schnell. Mein Dimmer
flimmert definitiv nicht. Richtig ist, dass viele Dimmer tatsächlich
flimmern, aber das liegt daran, dass diese Dimmer unsauber arbeiten,
nicht an einem Grundsatzproblem.

5.) Glühlampen sind zwar träge, aber nicht soooo doll.
Leistungsstärkere Glühbirnen (2kW, 5kW) sind aufgrund der Dicke der
Wendel deutlich träger als 25W-Lampen. Ich nehme zum testen, ob ein
Dimmer flimmert eine 25W o. 40W-Lampe, weil die sehr dünne Wendeln
haben, die nur wenig Wärme speichern. Ein 10%-Flimmern (in 2. Halbwelle
1ms später gezündet als in 1. HW) mit 50Hz ist deutlich sichtbar! Bei
einem 5kW-Brenner sieht man 100%-Flimmern (jede 2. Halbwelle gezündet)
nicht mehr. Dimmt man Leuchtstofflampen (ja, das geht, googelt mal nach
VIP90), sieht man jedes Flimmern sofort.

6.) Snubber sollte nie fehlen. Guck Dir mal ein paar Dimmer an, ein
einfacher Snubber besteht aus 3 billigen Bauteilen (Drossel,
Kondensator (X2) und Widerstand. Und Du schützt sowohl Deinen Triac als
auch das Netz.

7.) Wird Deine Glühlampe bei 100% genau so hell wie eine (gleiche)
Glühlampe direkt am Netz (ohne Dimmer) Wenn nicht, liegt der Verdacht
nahe, dass Du wirklich nur jede 2. HW zündest.

8.) Zündest Du Deinen Triac über einen MOC? Dann zündest Du immer im 1.
und 3. Quadranten (das ist gut), daran liegt es also nicht.

Genaueres zu Deinem Problem kann ich Dir nur sagen, wenn ich Schaltung
u./o. Software kenne.

Gruß,
Sebastian

Autor: Grilka (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Auch wenn das jetzt hier eigentlich schon fast sieben Jahre ruht:

Sebastian, du hast mir grade den Tag gerettet! Ich wurstel seit 
Ewigkeiten an meinem Dimmer rum, weil die Lampe flimmert und alles was 
ich mache hilft nichts. Und dann wühl ich mich hier (mit den Nerven am 
Ende und voller Verzweiflung) im Forum durch sämtliche Beiträge, in 
denen die Worte "Dimmer" und "flackern" vorkommen und stoße irgendwann 
auf deinen super ausführlichen Beitrag zu diesem Thema... und finde 
meinen Fehler!

Ich hatte um Strom zu sparen meinen ATtiny13 auf 16kHz runtergetaktet. 
Und dadurch wurde die Erkennung und Bearbeitung des 
"Nulldurchgangs-Interrupts" zeitlich so schwammig, dass die Lampe 
sichtbar geflackert hat.
Lösung: Takt auf 128kHz hochgeschraubt, Timer-Prescaler um Faktor 8 
erhöht, Impulslänge für den Triac dementsprechend angepasst, sonst nix 
weiter verändert...

==> Wunderschönstes, flackerfreies Licht an der 15W Birne!

Wenn ich dir irgendwo irgendwann mal über den Weg laufe, geb ich dir ein 
Eis aus! ;-)

Lg,
Grilka

PS: Ich hab auch keinen Gleichrichter vor der Nulldurchgangserkennung, 
d.h. die Erkennung läuft natürlich nicht ganz synchron in beiden 
Halbwellen ab. Die Abweichung beträgt allerdings "nur" ca 1,4V 
(Darlingtonschaltung zweier BC338) und liegt somit bei deutlich weniger 
als 1%. Und das sieht man anscheinend dann doch nicht mehr ;-)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.