www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik AVR geht aus wenn Motor läuft


Autor: Marius (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hi
ich hab die schaltung wie im tutorial beschrieben
+ die für den Spannungsregler für 5V. mein avr lässt ne led blinken.
wenn ich aber nen motor über nen transistor direkt an meine 12V
Spannungsversorgung anschliesse und die basis mit meinen 5V +
vorwiderstand verbinde so dass er durschaltet, scheint der AVR ständig
neuzustarten/anzuhalten.
woran kann das liegen? brauch ich da nen kondensator als puffer? wenn
ja, wie groß muss der sein?

thx

Autor: tex (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast Du daran gedacht in Sperrichtung zur Motorspannung ein Diode zu
schalten, die die Induktionsspannung beim abschalten kurzschließt?

Kann Deine Stromversorgung den hohen Anlaufstrom des Motors liefern,
oder bricht sie beim einschalten zusammen und mit ihr die Versorgung
für Deinen µC?

Verursacht Dein Motor so viele Störungen, dass er den µC beeinflusst?

Ein paar Kondesatoren können nicht schaden, wenn Induktivitäten im
Spiel sind und ein paar davon sollten ehr klein (100nF) sein, um
Spannungsspitzen und hohe Frequenzen rauszufischen.

Autor: Marius (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
dioden hab ich jetzt nich eingebaut, aber die led hört auf zu blinken
sobald der transistor durchsteuert. erst wenn ich die basis wieder
trenne, startet der MC wieder.

Autor: dorftepp (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ist es eine gelbe oder eine grüne LED?

Autor: Marius (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
eine grüne, aber mittlerweile weiss ich (oder bin mir SEHR sicher), dass
der motor den kompletten strom saugt und nichts mehr für den MC da ist.
Als Spannungsquelle hab ich son billig-universalnetzteil wo man über
son kleinen Schalter die Volt zahl einstellt. Dadrauf steht
"300mA3.6VA(max)". Also bedeutet das, dass es maximal 300mA zur
Verfügung stellen kann oder?
Der Motor den ich zum Testen benutze is son kleines Teil aus nem
Solarbaukasten. Aber irgendwie kann ich mir kaum vorstellen, dass der
300mA zieht. Was meint ihr dazu?

Autor: Thorsten (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Also bedeutet das, dass es maximal 300mA zur Verfügung stellen
> kann oder ?

Nicht mehr als 300mA und nicht mehr als 3.6VA ("Watt"), d. h. bei
höheren Spannungen eher weniger Strom.

> Aber irgendwie kann ich mir kaum vorstellen, dass der 300mA zieht.

Häng den Motor alleine ans Netzteil und benutze ein Multimeter um Strom
und Spannung zu messen. Wenn die Spannung deutlich einbricht, dann
braucht der Motor ordentlich Strom oder er ist kaputt.

Gruß
Thorsten

Autor: Marius (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
anfangsspannung ca 16V
also wenn ich den motor anschliesse sinkt die spannung für ne sec auf
ca 5V oder so. gleich danach sinkt sie auf 14V. is das jetzt ein
einbruch ? :>

Autor: Matthias H. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
wenn der AVR an einem 7805 hängt, dann reicht die eine Sekunde aus, um
dem AVR die Spannung zu nehmen. Man könnte es mit einem dicken Elko
hinter dem 7805 probieren.

Autor: Marius (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
was für einer sollte das denn dann sein?
komisch is aber auch, der avr is solange still wie der motor läuft.
sobald die verbindung vom motor weg ist, startet er wieder.

Autor: Matthias H. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Elko sollte so groß sein, dass die eine Sekunde überbrückt wird.
Wieso der aber danach nicht weiterläuft??????? Wieso läuft der Motor
eigentlich noch, wenn der AVR auf Reset geht? Ist der 7805 ordentlich
beschaltet? So ein Motor produziert schon ganz schönen Müll auf der
Spannung.

Autor: ...HanneS... (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Spannungsregler wie 7805 mögen aber keine "dicken Elko"s am Ausgang.
Hänge den Elko lieber an den Eingang und entkoppele den mit einer Diode
damit ein Spannungseinbruch auf der Hochvoltseite den Elko nicht
entladen kann.

...

Autor: Peter Zimmer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Marius,
versteh ich das richtig das der Solarmotor an den 16V hängt? Wenn ja
dann mach ihn mal an eine etwas niedrigere Spannungen. (Eine Solarzelle
hat nämlich nur 0,7V) Ich denke mal das du mit weniger Spannung am Motor
mehr erfolg hast (5V oder gar noch weniger).
Gruß
Peter

Autor: tex (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also ich schlage Dir vor, Du stellt gerade Motor und uC noch mal für ein
paar Tage beiseite und beschäftigst Dich erst mal mit dem Aufbau eines
kleinen, stabiliesierten Netzteils. Zum Beispiel eine Festspannung von
5V und sagen wir mal 100mA für Deine uCs und eine einstellbare 2-20V /
1A. Optiional kannst Du noch eine Überstromanzeige der ein Amperemeter
einbauen, ...
Alternativ kannst Du sowas natürlich auch kaufen, aber das mindert den
Lernerfolg erheblich.

Autor: Thomas O. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

man kann auch einen niedrigen Wiederstand zw. Ausgang LM7805 und Elko
reinmachen damit der LM7805 nicht so stark belastet wird wenn der Elko
sich grad aufläd.

Die Frage ist halt was für eine Spannung und Dauerstrom benötigt dein
Motor, wenn dein Netztteil das nicht schaft dann fällt die Spannung
einfach ab, da hilft auch kein großer Elko, den irgendwann geht der
auch leer. Und ein Low-Drop Typ eines LM7805 z.b LM2905 wäre nicht
schlecht da dieser nur 5,5V braucht um hinten noch 5Volt auszugeben.
Aber wenn wirklich nur der Anlaufstrom zu hoch ist könnte ja ein Elko
diesen Anlaufstrom des Motor liefern.

Kann es sein das du dem Solarmotor zuviel Spannung gibts? Dann zieht
der nämlch klar mehr Strom, Solarmotoren begnügen sich eigentlich mit
einer sehr geringen Spannung, da wie schon gesagt eine Solarzelle nicht
viel hergibt.

Autor: ...HanneS... (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Warum wollt ihr eigentlich immer dicke Elkos hinter den Spannungs-
regler schalten??? Wie soll der dann noch regeln können???

Entkoppelt den Elko vor dem Spannungsregler mit einer Diode vom Rest
der Stromversorgung.

Dicker Elko (Speicher) hinter dem Regler kann man damit vergleichen,
dass man in einer geregelten Öl-Heizungsanlage zwischen Dosierventil
(Regelung) und Brennerdüse einen großen Öltank dazwischen baut...

...

Autor: Marius (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
also auch wenn ich auf das teil an zb 5V anschliesse, passiert genau das
selbe. auch der avrisp-programmer kriegt auch probleme, seh ich an der
led. da ich eigentlich nen anderen motor für 12V benutzen will, der
grad bei nem kumpel liegt und 210mA zieht, wollt ich fragen ob ich für
den auch so nen spannungsregler für 12V holen kann. der bräuchte dann
ja auch so ne schaltung mit kondesatoren oder? wo findet man sowas?

tjo dann werd ich mir wohl ein hochwertigers netzteil besorgen/bauen
müssen. könntet ihr mir da auch empfehlungen geben?

thx für die vielen antworten :>

Autor: Marius (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
wär sowas hier geeigenet?
http://www.elv.de/Shopping/ArtikelDetail.asp?Refer...
(hab eigentlich nicht vor mir da was selber zu bauen, weil ich schon
was hochwertigeres haben will für später)

Autor: Markus_8051 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hey Leute,

wenn die Spannung von 16V auf 5V zusammenbricht, und der µC sich erst
dann wieder meldet, wenn der Motor aus ist, und nicht wenn die Spannung
sich wieder etwas erholt hat, dann ist ja wohl das Netzteil zu schwach.

Also könnten wir jetzt mal das Rätselraten beenden und mal die
Anschlußwerte von Motor und Netzteil vergleichen?

Ansonsten gehört ein Elko auf jeden Fall vor den 7805, nicht dahinter.
Damit der Motor sich nicht den Strom aus dem Elko zieht, kann man da
noch ´ne Diode vorschalten.

Um den Motor zu Entstören würde ich ein RC-Glied vorschlagen: Elko über
die Versorgungsspannung und von da einen niederohmigen Widerstand zum
Motor (etwa der gleiche Wert, wie der Innenwiderstand der
Motorwicklung, schätze ca. 0.1-5 Ohm)

Und hört bitte auf, Elkos irgendwo "reinzumachen", wo sie wirklich
nicht hingehören.

Markus_8051

Autor: Marius (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
jo alles klar, aber kannste mir was zu meinen beiden obigen posts sagen
im bezug auf ein gescheites netzteil, wär das bei dem link was
ordentlich bzw. geeigenetes?

Autor: Fritz Ganter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mein Kollege und ich haben uns grad am Boden gewälzt:

dorftepp schrieb:
Ist es eine gelbe oder eine grüne LED?

marius antwortete:
eine grüne, ...



:-)

Autor: Marius (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
check ich jetzt nich, was is dadran jetzt so lustig ?

Autor: Fritz Ganter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Weil es für das Problem absolut egal ist welche Farbe die LED hat.

Wäre so wie wenn man beim ADAC anruft und sagt, mein Motor springt
nicht an, und die fragen nach der Farbe des Autos.

Autor: Fritz Ganter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Anderseits: Witzig wäre ja, wenn du beim ADAC anrufst, und ihnen sagst,
dass deine LED ausgeht wenn der Motor läuft...

SCNR

Autor: Marius (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ne so ganz abwegig find ich das nich, je nach farbe sind doch die
Voltzahlen bei LEDs verschieden. Es hätte ja was mit der Spannung sein
können. tut mir jetzt echt leid, dass ich jetzt ned sonen plan von
elektronik habe um gleich selber auf alles zu kommen...

Autor: Thomas O. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

@HanneS: Also wenn man dahinter einen dicken Elko hat dann muss der
Regler viel weniger regeln da sich die Spannung am Ausgang nicht so
ändert da der Elko die Spitzenbelastung ja abfängt. Diode vor den
Regler und Elko kann man ja zusätzlich davor setzen.

Autor: Kurt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der "dicke" Elko am Ausgang wird dann zur Gefahr wenn die
Eingangsspannung schnell unter die 5V abfällt weil dann Inversstrom
durch den Längsreglertransistor fliest.
Also das mit der Reihendiode vor dem Eingang sollte immer sein.
Ansonsten wird er wohl nicht schaden (glaub ich zumindest).

Kurt

Autor: Thomas O. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

in vielen Bücher sieht man dann so ne Diode damit sich der Elko nicht
über den Regler entlädt also vom Reglerausgang zum Reglereingang.

Autor: Kurt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das mit der Inversdiode ist richtig.
Wenn eine Diode am Eingang sitzt kann auch nichts passieren (ausser bei
Elkoschluss oder noch anderen von hier mitversorgten Verbrauchern) und
man erhält zugleich einen Entladeschutz bei "weicher" Versorgung.


Kurt

Autor: Michael (ein anderer) (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Thomas O.:

Der dicke Elko hinter dem Spannungsregler hat noch ganz andere
Gefahren:

Er kann zum Schwingen des Spannungsregler führen.

Das hängt mit den Polen und den daraus resultierenden
Phasenverschiebungen und Frequenzgang des Spannungsreglers zusammen.

Die Spannungsregler sind für eine bestimmte minimale und maximale
Lastkapazität ausgelegt. Zu wenig Kapazität am Spannungsregler-Ausgang
ist genauso wie zuviel Kapazität schlecht für das Regelverhalten.

Genaue Information dazu stehen in den Datenblätter der Regler.

Autor: AxelR. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sind die Polen jetzt nicht auch in der EU?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.