www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Amplitude vom externen Quarz


Autor: Rahul (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mahlzeit!
Ich messe an den XTAL-Pins meines ATmega162 eine relativ schöne
Sinus-Spannung mit 0,783V (laut HP-Oszi).
Da die ganze Schaltung nicht so wie ich will (sie streikt), vermute ich
da den Fehler. Desegen meine Frage:
Soll die so niedrig sein? (Habe im Datenblatt nichts gefunden)
Woran kann es liegen, dass die so niedrig ist?

Vielen Dank im Vorraus


Rahul

Autor: Olaf (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
10:1 Tastkopf?

Ausserdem sollte es doch einfach sein ein kleines Programm zu schreiben
das nur einen Port hochzaehlt und dann dort mal den Ossi dran zu
halten.

Olaf

Autor: Matthias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

standardmäßig ist die CKOPT Fuse nicht programmed. Damit läuft der
Quarz mit kleiner Amplitude was der EMV zugute kommt. Bis 8MHz
funktionert das hervorragend.

Matthias

Autor: Rufus T. Firefly (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich nehme an, daß Du einen passiven Quarz und keinen integrierten
Quarzoszillator verwendest. Die Amplitude ist IMHO in Ordnung - es
gibt, wenn ich mich recht erinnere, einige Fuses, mit der die
Oszillatorschaltung des AVRs beeinflusst werden kann.

Sieh Dir mal die Seiten 34 und 35 des Datenblatts des Mega162 näher an;
in Tabelle 7 und Tabelle 8 steht vielleicht hilfreiches.

Autor: Michael (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Amplitude ist in Ordnung, egal ob RMS oder Vpp. Falls Du 16MHz
verwendest sollte CKOPT programmiert sein, sonst können Probleme
auftreten.

Autor: Benedikt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe CKOPT nie programmiert, und lasse die uC mit bis zu 24MHz
laufen. Ich hatte noch nie Probleme damit. CKOPT braucht nur eine Menge
Strom...

Autor: Thorsten (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Meint ihr wirklich, daß 0.7V ausreichen? Ich messe immer so ca. 4V an
AVRs.

Autor: Benedikt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
0,7V sind definitv OK.
Die 4V sind dann das gesetzte CKOPT Bit.

Autor: Michael (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Benedikt:
"" Ich hatte noch nie Probleme damit. ""

Das ist ja das Gemeine; die Probleme sagen ja nicht: "Hallo hier bin
ich !"
 In einem Fall hatte bei mir eine UART Aussetzer. Zum Glück konnte ich
das mit CKOPT schnell beheben. Aber wenn an anderer Stelle Aussetzer
auftreten, ist 'Hängen im Schacht'.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.