www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Probleme mit PB5 @ATMEGA8


Autor: Andi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Leute,

ich stehe gerade vor einem Rätsel.
Ich habe eine Motorsteuerung gebastelt, die unter bestimmten Konditionen 
ein Warnsignal ausgeben muss (Controller: ATMEGA8). An PB5 hängt zu 
diesem zweck ein PNP, der mit Signalebern verbunden ist.

Um das ganze zu testen, sind die ersten 5 Zeilen der main Folgende:

int main()
{
  DDRB |= (1<<PB5);
  PORTB &= ~(1 <<PB5);
  long_delay(500);


Es wird kein SPI oder sonstiges verwendet.
Dennoch bleibt PB5 auf High.

Gibt es irgendeine Sonderregel für PB5 die ich übersehen habe?



Gruß
Andi

Autor: Andi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Verzeihung hat sich erledigt...

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.