www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Atmega Keine Funktion


Autor: Daniel P. (pirndi)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hy!

Hab ein Problem mit meinem Atmega32. Ich habe gestern ein Programm 
geflasht und seitdem startet er nicht mehr. Danach hatte ich all meine 
funktionierenden Programme versucht nur leider ohne erfolg. Es läuft 
kein einziges Programm mehr. Ich habe ihn auf einem Pollinboard.

Die Fuses habe ich nicht verstellt und auch sonst Hardware seitig nichts 
verändert. der µc merkt sich auch den Flashspeicher und läst sich auch 
immernoch programmieren nur startet er die Programme nicht. Hatte jemand 
schon mal das Problem?

mfg Pirndi

Autor: Axel Düsendieb (axel_jeromin) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie merkst Du, dass er die Programme nicht startet?

Nimm mal einen anderen Port zu ausprobieren.

Autor: Daniel P. (pirndi)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mein Grafik Lcd zeigt nur mehr streifen an und der uart schreibt auch 
nichts mehr. Hat alles bestens funktioniert bis das ich ihn erneut 
geflasht habe. auch andere programme die den uart benutzen oder das LCD 
machen nichts.

Autor: Michael (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was sagt denn ein andere Atmega? Versuche doch mal was einfaches, 
einfach gezielt Ports einstellen und nachmessen ob die richtig 
eingestellt wurden.

Autor: Daniel P. (pirndi)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ok hatt sich erledigt bzw der sram vom glcd :(
atmega läuft ohne probleme
sry für denn unnützen beitrag in diesem forum

pirndi

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.