www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik 7-Segment-Anzeige funkioniert nicht am uC


Autor: Stephan W. (carpeursus)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi, da ich fuer ne Modellbahn nach einem einfachen Zaehler gesucht habe,
habe ich mir einfach diesen Bausatz bei EDV bestellt:
http://www.elv.de/Ganganzeige-fuuml;r-Motorrauml;d...

Hier das Datenblatt dazu:
http://www.elv-downloads.de/service/manuals/47587_...

JEdenfalls hab ich alles sorgfaeltig zusammengeloetet und angeschlossen,
die Anzeige zeigt jedoch sobald Spannung anliegt (12V) dauerhaft eine 8 
an (Dezimalpunkt leuchtet nicht).
Um nem Kurzschluss vorzubeugen hab ich auch das Anschlusskabel noch mal 
abgetrennt, weiter gekuerzt und wieder angeloetet, jedoch ohne Erfolg.

Koennte hier irgendein behebbarer Fehler vorliegen?

Danke

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> dauerhaft eine 8 an

Auch wen du mit den Eingängen rumspielst und sie wechselseitig mit Masse 
verbindest ?

> Koennte hier irgendein behebbarer Fehler vorliegen?

Ja.

Autor: Ben S. (theben)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast du schon alle Taster angeschlossen? Vielleicht hast du die Öffner 
und Schließer verwechelt. So das alle drei Taster gleichzeitig signal 
geben.

P.S. Sehe grade es könnte nur ma Neutral Taster liegen die anderen 
werden per flanke ausgewertet.

Autor: Stephan W. (carpeursus)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,
ich hatte jetzt zum Testen
an auf und ab jeweils nen Drucktaster,
und an Neutral einen Kippschalter angeschlossen.
Die schalten alle auf Masse.

Autor: Ben S. (theben)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
na wenn du den Neutral dauerhaft auf masse schaltest dann is logisch das 
ne 8 raus kommt

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> na wenn du den Neutral dauerhaft auf masse schaltest
> dann is logisch das ne 8 raus kommt

Ich halte es eher für logisch wenn eine 0 rauskommt :-)

Keine Ahnung, welcher Logik du folgst.

Autor: Stephan W. (carpeursus)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es spielt keine Rolle ob der Neutral schalter schliesst oder nicht,
es ist halt trotzdem immer ne 8 da....

Autor: Stephan W. (carpeursus)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Keiner ne Idee weiter?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.