www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Stimmt etwas mit meinem Programmer nicht?


Autor: Hagen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Servus. Ich habe mein Steckbrett nach dem Tutorial aufgebaut und auch 
eine LED zum leuchten gebracht, allerdings kommt mir da doch etwas 
seltsam vor. Ich benutze den Programmer von Atmel(AVRISPmkII). 
Normalerweise stellt dieser kein Storm für den uC zur Verfügung d.h. 
wenn ich den Strom von der gesamten Schaltung wegschalte, dann müsste 
bei meinen Programmer wenn er am PC UND an der Zielhardware(Mega8) 
angeschlossen eine rote LED dauerhaft leuchten, die signalisiert, dass 
kein Strom vorhanden ist.

Schliest man dann den Strom an, dann sollte diese LED grün zeigen d.h. 
dass alles bereit zum Programmieren ist.

Bei mir ist das aber so, mein Programmer nur dann eine rote LED zeigt, 
wenn ich den ISP-Stecker komplett vom Steckbrett entfernt habe. Sobald 
ich ihn aber anschließe leuchtet die LED grün und zeigt, dass alles ok 
ist - obwohl kein Strom angeschlossen ist!!! Ich habe mal mit nem 
Multimeter an Vcc und GND bei der ISP-Stiftleiste angelegt und ca, 2,5V 
gemessen. Ich versteh das nicht, ist das normal? Spinnt mein Programmer?

Programmieren konnte ich damit schon, aber warum verhält er sich so 
komisch? Hat jemand zufällig den gleichen Programmer und kann mir seine 
Erfahrung mitteilen?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.