www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik AvrDragon kommuniziert nicht mit uC


Autor: Raphael F. (erdbewohner)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!
Nach dem ich gestern es nun endlich geschafft habe, dass mein Mac mit 
virtueller Maschine und darin Windows 7 64 bit mit AvrStudio 4.18 SP2 
mit meinem neuen AvrDragon kommuniziert (erkennt) stehe ich jetzt vor 
dem nächsten Problem und bin fast am verzweifeln: Ich habe schon eine 
platine mit atmega16 die ich mit meinem avrisp mkII-clon schon x-mal 
programmiert habe. Mit dem AvrDragon habe ich es schon mit oder ohne 
externe stromversorgung ausprobiert (vcc-kabel abgetrennt, wenn nötig). 
Ich habe alle verbindungen vom isp-stecker am avrDragon bis zu den pins 
am uC kontrolliert. Aber er will einfach die signatur nicht auslesen 
(immer kommt dieses fenster: a problem occured...). Ausserdem, wenn ich 
die programmier-geschwindigkeit verstellen will, steht unten immer: 
Getting isp frequencity parameters.. failed!
Beim schreiben das gleiche.
Ich habe es eben auch noch an meinem alten windows vista 32-bit 
versucht: das gleiche.
Ich habe es auch schon mit avrStudio 4.17 versucht 
(Beitrag "AVR Dragon - ISP funktioniert seit Firmware Update nicht mehr :-/" beim mac stürtzt das 
programm ab, sobald ich auf connect klicke und bei meinem alten windows 
ist es nach dem downgrade auch nicht anders als vorher.
Ich bin absolut ratlos!

Viele Grüsse
Erdbewohner

Autor: Raphael F. (erdbewohner)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
weiss niemand etwas?
Oder ist mein board schon kaputt (statische ladung... )? [das wäre 
:-{{{{{]

Autor: Thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hatte das selbe Problem, bei mir lag es am USB-Kabel. Habe einige Kabel 
ausprobiert und ein paar Kabel "funktionieren" einfach nicht mit meinem 
Dragon (aber sehr wohl mit meinen externen Platten).
Ein anderer Grund kann schwache Stromversorgung sein, probier es mal mit 
einem selfpowered Hub.
Ich benutze AVRStudio (neueste Version) auf einem MBP von 2005 per 
VMware und winXP home.

Autor: Raphael F. (erdbewohner)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielen Dank!
Ich habe schon einen selfpowered hub. Mal schauen, wo ich andere 
usb-kabel herbekomme.
Gruss Erdbewohner

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.