www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Lötbrücke auf der Platine suchen


Autor: Stefan May (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Da baut man eine Platine mit sehr viel SMD auf und stellt dann fest,
daß irgendwo eine Zinnbrücke sein muß. Da fängt man dann an zu gucken
und guckt und guckt und die Freundin fragt schon, ob man über der
Platine vielleicht meditiert.

Gibt es also irgendeine sinnvolle Möglichkeit so einer Lötbrücke auf
die Schliche zu kommen? Versucht habe ich es mit einem Ohmmeter (kein
sehr genaues), auch wildes Nachlöten aller Pins habe ich versucht. Vom
Gucken ganz zu schweigen, mir ist schon ganz schwindelig.

Eine Idee ist mir gekommen, als ich an Netzwerkkabel dachte. Kann man
einen Strom da durchjagen und dann eventuell eine Reflexion messen?
Oder einfacher ein empfindlicheres Ohmmeter?

ciao, Stefan.

P.S. Bitte keinen Kommentar, ich hätte lieber während des Bestückens
prüfen sollen. Den vertrage ich jetzt nicht. :-)

Autor: Christof Krüger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also ich würde da einfach mit Entlötlitze rangehen und überschüssiges
Lötzinn absaugen. Da in der Litze auch Flussmittel dabei ist, sollten
sich so alle Lötbrücken wie von selbst zurückziehen.

Autor: Stefan May (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Och wie untechnisch. :-)

Werd ich morgen aber mal probieren.

Du weißt ja sicher um welche Platine es geht. Die Sicherung war
jedenfalls nicht Schuld. :-)

ciao, Stefan.

Autor: Michael (ein anderer) (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Woher weisst Du, dass es eine Lötbrücke ist und kein anderer Fehler?

Bist Du Dir wirklich sicher?

Autor: Stefan May (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn ich in die Schaltung Strom gebe über ein Strombegrenztes Netzteil,
dann stellt sich der maximale Strom ein. Messen tue ich mit meinem
Ohmmeter (nicht sehr genau, hab ich ja schon gesagt) 2,8 Ohm. Was soll
es denn anderes sein?

Ich könnte mir vorstellen, einen Widerstand statt eines
Koppelkondensator eingelötet zu haben. Ist mir passiert, habe ich
entdeckt. Ist aber auf der Platine nicht der Fall.

Ein verkehrt herum eingebauter Chip? Hab ich geprüft (hab ja
stundenlang draufgeguckt) und ist nicht der Fall.

Ein gebruzelter Chip? Glaube nicht, daß ich dann einen Kurzschluß
hätte.  Oder täusche ich mich da?

Also für mich kommt eigentlich nur das in Frage. Zumal die Platine
ziemlich schwierig ist, alles SMD, das Feinste ist TQFP-100.

ciao, Stefan.

Autor: geloescht (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dieser Beitrag wurde auf Wunsch des Autors geloescht.

Autor: Stefan May (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
AAAHHHHH, das wollte ich doch nicht hören. :-)

Der Schluß ist im 5V-Teil. Leider. Wäre er davor, dann würde das die
Suche schon sehr stark eingrenzen. Bei einer Platine hatte ich einen
Schluß direkt am Sicherungshalter, der kaum zu sehen war. Den habe ich
erst mit einer starken Lupe entdeckt.

Na ich werde morgen mal mit Entlötlitze an die Platine rangehen.
Irgendwo muß da was sein!

ciao, Stefan.

Autor: Martin S. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Rein INteressehalber: Um welche Platine geht es überhaupt, oder ist das
irgendwie vertraulich?

Autor: Stefan May (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Total super streng vertraulich. Ich sag das nicht, sonst lachen wieder
alle über mich. ;-)






http://www.mikrocontroller.net/forum/read-1-138024.html
http://ispf.de/modules.php?name=News&file=article&...

ciao, Stefan.

P.S. Ups, das sind ja mehr als 10 Zeilen.

Autor: edi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Stefan,
weisst Du ob der Hersteller die Platine auch geprueft hat(in Bezug auf
Schluesse) ?
Ed
meditiere..

Autor: Holger Menges (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn eingehende optische Überprüfung nichts gebracht hat:
Den verdächtigen Zweig etwa in der Mitte auftrennen (VIA durchbohren,
Leiterbahn durchtrennen) und nachsenen, auf welcher Hälfte der Fehler
liegt. Dann den fehlerhaften Teil nochmal genau betrachten. Falls
nichts zu sehen ist: Wieder halbieren...
So hat man den Fehler ziemlich schnell.
Später nicht vergessen, die durchtrennten Stellen wieder zu verbinden
:-)

Autor: Alexander (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich hatte mal einen Kurzschluss an einem 44-Pin SMD-Chip, der hat sich
ganz blöd unter den Chip gezogen. War kaum zu sehen. Aber es waren zum
Glück zwei I/O-Pins, da wusste ich dann wenigstens in welchem Teil das
sein musste.

Gruss
  Alexander

Autor: Stefan May (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

@edi: Die Platine ist wahrscheinlich nicht geprüft. Kann mir aber kaum
vorstellen, daß es an der Platine liegt. Wie sagt man so schön: Im
Zweifel in den Spiegel schauen, da sitzt der Schuldige. :-)

@Holger: Deine Methode gefällt mir zwar nicht so gut, ich kann mir aber
gut vorstellen, den Fehler damit schnell zu finden. Das behalte ich mir
als allerallerletzte Option vor.

ciao, Stefan.

Autor: geloescht (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dieser Beitrag wurde auf Wunsch des Autors geloescht.

Autor: Stefan May (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Na die sehe ich ja nicht mehr, wo die Platine doch vollständig bestückt
ist. ;-)

ciao, Stefan.

Autor: womisa (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

@Stefan wolltest Du nicht dankenswerter Weise Platinen für Andere
bestücken? Wie sieht es da jetzt aus? Du scheinst mir auch noch nicht
soviel Erfahurng zu haben. Ich wollte Dich schon ansprechen, da ich
auch das Board habe und keinerlei SMD Erfahrung....
Siehe
auch==>http://www.mikrocontroller.net/forum/read-1-173519.html#new

Ich habe vor dem Einlöten und nach dem Einlöten jedesmal mit dem
OHMmeter (Piepser) nachgeprüft und so meine gemachten Schlüsse gleich
beseitigt.
Ich meinte auch einen Schluß zwischen AGND GND nach dem Einlöten des
128er zu haben, aber die sind intern im Prozessor mit 1 Ohm verbunden.

Ich hoffe DU findest Deinen Schluß. Viel Erfolg..

Viele Grüße
Achim

Autor: tex (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
wenn zu Zugriff auf eine Thermographiekamera hättest, wäre es denkbar
einfach. Es gibt aber einen einfachen Weg, jedoch nicht ganz
unproblematisch. Man nehme mehrere Ampere und beglücke damit die
Platine  (aber nur ein bis 2 Volt bitte!!) Wenn Du den Strom regeln
kannst, kannst Du irreversieble Schäden sogar vermeiden. Dann wird
irgendetwas warm ...  wärmer ... sehr warm ....
So findet man auch falsch eingelötete Bauteile ganz leicht, ... Das ist
kein Joke! Das geht wirklich.

Autor: Stefan May (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Naja, ich habe 5 Platinen zu bestücken gehabt. Um Zeit zu sparen habe
ich halt das Testen nicht gemacht. Leider habe ich da am falschen Ende
gespart.

Wegen meiner Erfahrung: Ist nicht mein erstes Projekt mit SMD, ich habe
auch schon viele andere Platinen gelötet. Dieser Fehler ist einfach nur
auf Schusseligkeit zurückzuführen. Bisher ging es immer gut und glaube
mir, den Fehler mache ich nicht nochmal.

Auf einer Platine habe ich den Fehler gefunden. Die Zinnbrücke war nur
mit einer Lupe zu erkennen und befand sich direkt am TQFP-Gehäuse des
Realtek Chip. Wie die da hinkommt, keine Ahnung. Löten tue ich da
normalerweise nicht. Könnte eventuell beim Auslöten passiert sein.

Auf der anderen suche ich noch. Werd mich aber erst mal erholen vom
vielen Gucken. :-)

ciao, Stefan.

Autor: edi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
lass doch mal Deine Freundin dran...

Autor: Jochen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
He Stefan,

falls es dir ein kleiner Trost ist, so einen Fehler suche ich
inzwischen auch, hatte aber noch nicht viel Zeit dazu. Kurzschluss
zwischen VCC und GND ist es keiner, das habe ich dauernd überprüft.
Zieht aber zu viel Strom. Mich würde mal kurz interessieren
- welche Module hast du bestückt?
- auf welchen Wert begrenzt du den Strom?
- Welche Resetvariante hast du drauf (Diode+R+C oder Max)?
- Hast du das ext. EEPROM bestückt?

Gruß,
Jochen

Autor: Jochen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe natürlich auch nichts dagegen, von anderen ein paar Werte zur
Stromaufnahme bei def. Bestückung zu hören:o)

Nachdem ich nun das Flash ausgelötet habe, bleibt die Stromaufnahme bei
220mA stehen. Bestückt ist alles ausser CAN, Flash und MMC Karte (also
yC, CPLD, Realtek, Max3232CWE, SRAM, USB, Ethernut Komp. R, Max809L)

Die 220mA scheinen mir ein bischen viel, andererseits habe ich keine
Vergleichswerte. Ein anderes Board hier läuft mit yC,
Realtek,MAX3232CWE und CPLD mit 75mA.

Gruß Jochen

Autor: Webber (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo

Prozessor, CPLD, RAM, MAX3232CWE (Ohne RTL) ca. 90-100mA

Autor: holm (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Für solche Zwecke hatte ich früher mal eine Mimik gebaut. Ich hatte eine
5V
Stromversorgung mit einem 2N3055 getaktet (1Khz mit 555) und hatte
einen
Kurzschlußsucher, der im Wesentlichen aus einem Kope eines alten
Magnet-
trommelspeichers und einem Empfindlichen Verstärker bestand. Kopf von
Magnettrommel deswegen, weil der vorne nur rd 3,5mm Durchmesser hatte,
aber ein normaler Kassettentonkopf sollte es auch tun. Mann konnte
damit die
Lieterzüge abfahren und höhrte wo der meißte Strom floß, Siebelkos
muste man
aber totlegen..

Gruß,

Holm

Autor: Der Elektrsche Reiter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Zwei Tipps:
1. Wenn Dein PCB ein oder zweisitig ist: Man kann das PCB mit einer
straken Lampe, z.B. 100Watt Strahler "durchleuchten". Dabei erkennt
man die Leiterbahnen als scharfe Linien. Lötbrücken fallen störend auf.
Funktioniert leider nicht bei Multilayer.
2. Checke die Polarität diener Tantal-Elkos. Die nehmene's extrem
krumme, wenn sie falschrum drinnen sitzen. Das gilt ähnlich für
Logik-ICs.


@holm: Prima Idee. Hält denn Sie Schaltung das gepulse aus? Gerade bei
EEPROMs vermute ich da eine starke Belastung.

alt-f4

Autor: Uwe (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi!
Kurzschlüsse suchen? Na mit Strom und der erzeugten Spannung an R's.
Jeder Leiterzug ist ein R. Da wo viel Strom fließt entsteht ein hoher
Spannungsabfall. Das Voltmeter sollte aber recht empfindlich
sein(Auflösung <0,1mV). Kommt auf deiner Platte überhaupt Spannung
an?(auch 1mV ist Spannung) Wenn nein Strom rauf bis es raucht, wenn ja

U > 0,7V? Bei nein->wirklich Kurzschluss, bei ja Bauteilfehler.

Viel Erfolg, Uwe

Autor: Ratber (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Stefan

Yo,nen Kurzer ohne echte Messmöglichkeit ist natürlich käse.

Auufer arbeit hab ich Digitaltester die mir das entsprechende Netz
anzeigen und auch die Soft hilft da recht gut.

Allerdings habe ich bei Kurzen in der 5V Versorgung nach dem
Spannungsregler dann das gleiche Problem wie du weil gerade dieser
Zweig natürlich überall vorhanden ist.

Da gibt es nicht viele Möglichkleiten den Fehler zu finden.

Die Primitivste ist alle in Frage kommenden Bauteile nacheinander zu
entfernen.
Anfangen tu ich natürlich mit Der Polaritätskontrolle der elkos und
Halbleiter.
Danach schaue ich mir bei viel Licht die ganze Platine an und suche
nach Brücken.
Eine gute Lupe mit 8x oder mehr ist da dringend angeraten denn mit
bloßem auge wirst du Mikrobrücken kaum finden können.(Im Anhang mal ein
Beispiel)

Mit Fets und Elkos gehts dnn weiter da die recht oft Quelle für Kurze
sind.
Da hilft nur ausbauen und schauen.

Eine weitere Möglichkeit sind Kerkos (Keramikkondensatoren.Ja die
kleinen gelblichen Klötzchen dort).
Sind die Feucht gelötet dann gibts nen internene Popcorneffekt den man
nicht so leicht sehen kann.
auch eine Mechanische Beschädigung sieht man nicht gleich.

Das ist die Lange Methode.


Ich bevorzuge bei größeren Problemen mit Kurzen im Versorgungskreis
aber auch gerne die Methode von Holm.
Ein entsprechendes Gerät ist schnell mit einigen Amps und nem passenden
Kopf gestrickt.

Meist ist es aber ne simple Brücke die man einfach immerwieder
übersieht.
Passiert mir auch manchmal obwohl ich den ganzen Tag auf Fehlersuche
bin.
Da kann es sein das mir sogar ne Brücke am Stecker entgeht obwohl die
verhältnismäßig Gigantisch ist.(Wald vor Bäume effekt)

Hast du nen Scanner ?

Wenn ja dann mach nen Scan mit 600dpi und wir können alle mitsuchen um
wenigstens das auszuschließen.

Bei Problemen mit dem Webspace kann ich aushelfen.(Hier auffem
Forenserver geht das nicht weil zu groß).

Autor: Ratber (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Öhm,ja.

Bild Vergessen.

Der hier ist dabei noch recht gut zu sehen.
Ich hatte auch schon feinere aber die entstehen selten bei
Handlötungen.

Autor: Ratber (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Und noch ne Info vergessen.

Das Gehäuse dort ist ein SOT363.

6 Polig ,ca. 2mm Breit.
Pitch 0.65

Damit man sich bei dem Bild auch was vorstellen kann.

Autor: Stefan May (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo allerseits,

Die Methode von Holm finde ich auch sympatisch. Das werde ich glatt mal
ausprobieren auf einem Testboard. Könnte ich für meine Versuche nicht
einen Kopf von einer Festplatte benutzen? Ich habe hier noch ein paar
120MB-Modelle, die zu nix mehr zu gebrauchen sind. Da kommt der Kopf
doch gerade recht. :-)

Eignet sich für die Taktung der Schaltung auch ein FET? Habe hier noch
ein paar IRF540 rumliegen. Ein Signalgenerator und ein empfindliches
Osziloskop (bis 50mV) sind auch vorhanden. Kann ich da nicht den
Magnetkopf direkt an das Oszi klemmen?

Wie hoch sollte ich dann die Spannung wählen? Ich hätte eine kleine
Spannung (<1V) aber einen hohen Strom (3A) für die Messungen benutzt.
Tut das den Schaltkreisen was?

ciao, Stefan.

Autor: Alexander (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich kenne mich nicht sooo toll damit aus, aber um einen irf540 zum
takten zu bringen, muss der ganz schön Strom am Gate haben. Die
Schaltzeiten im Datenlatt machen die mit 10 Ohm am Gate, also 1A!

Gruss
  Alexander

Autor: Ratber (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Stefan

Welchen Kopf du nimmst ist egal.

Vom alten Kassettenrekorderkopf bis zum Festplattenkopf funktioniert
alles.

Die Größe des Kopfes bestimmt nur wie genau du das Signal lokalisieren
kannst und wo du damit noch alles zwischen kommst.

du kannst ihn auch direkt am oskar anschalten.
Wenn das Signal dennoch zu schwach sein sollte dann bastelst du eben
noch nen kleinen Op als Messverstärker davor.
Die Schaltung muß nicht ausgefeilt sein.
Signal da und fertig.


Zum Takten :

Nimm was du willst.
Du brauchst auch keine große Leistung (Die Schaltung soll ja noch heile
bleiben)

Eine Einfache getaktete Stromquelle reicht da völlig aus.

so um die 200mA reichen da schon.

Autor: Stefan May (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Na ich probier das mal und berichte dann. Die Festplatte ist schon
geschlachtet. :-)

ciao, Stefan.

Autor: Jochen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
vier Wochen später:

Kam schon was dabei raus?

Gruß,
Jochen

PS: Mich würde auch immer noch interessieren, ob jemand das ext. EEPROM
oder den Reset-Max erfolgreich bestückt hat.

Autor: Stefan May (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ach sorry. Hab den Thread ganz vergessen.

Also ich hab das mal versucht mit dem HDD-Kopf. Das war eine ziemliche
Fummelei, weil die Anschlüsse am Kopf sehr fein waren. Ich hab dann mal
ein uraltes Modell geschlachtet, bei denen die Anschlüsse etwas
handlicher waren. Das funktionierte wirklich gut, hat mir bei der Suche
aber gar nicht geholfen.

Gefunden habe ich die Lötbrücke klassisch mit einem Mikroskop am
Realtek. Mit der Lupe war das fast gar nicht zu erkennen und ich hätte
mich da wahrscheinlich dumm und dämlich gesucht. Naja, nu gehen beide.

Den MAX809 habe ich auf zwei Platinen bestückt. Der funktionierte auch
wirklich gut, ist aber sehr empfindlich bei Spannungseinbrüchen. Ich
habe nach einem Fehler gesucht, der keiner war, weil ich die
Strombegrenzung etwas zu niedrig eingestellt hatte. Er tut halt das,
wofür er gedacht ist.

ciao, Stefan.

Autor: PeterL (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich verwende zur Fehlersuche einen riesigen Elko (100000µ) den ich auf
5V auflade, mit dem geladenen Elko kurz an die Print - PUFF und weg ist
der Kurzschluss,

Peter

Autor: Ratber (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>mit dem geladenen Elko kurz an die Print - PUFF und weg ist
>der Kurzschluss


.......und oft auch einge Leiterbahnen.


Die Holzhammermethode ist nicht gerade was für SMD bestückte platten.


Dann lieber einzelne Leiterbahnzweige mit einer Klinge auftrennen und
später wieder mit Leitsilber und schutzlack zuflicken.

Autor: PeterL (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
natürlich ist meine Holzhammermethode der letzte Ausweg, wenn man
die Print vorher peinlichst genau auf Schlüsse untersucht hat

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.