www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Pony Prog Error


Autor: David (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
HAllo!

Ich habe ein Problem mit dem beschteiben meines avr at90s2313.
Ich habe mein selbst gebauten (Anleitung aus dem WWW als nicht selbst 
entworfen) programmer an mein Compiuter angeschlossen und dan versucht 
ihm mit Pony Prog zu Lesen, zu beschreiben und zu löschen aber immer kam 
folgende fehlermeldung:

            *******************************************
                                                     
            *  Device missing or unknow devince (-24) *
                                                     
            *******************************************

Könt ihr mir sagen was ich falschgemacht habe?

MFG David

Autor: Thanh Tam (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast du mit parallel oder serie programmiert? Wenn Serie, dann:

- Ist Reset-Anschluss dauernd am GND?
- Schwingt der Takt?
- Bei PonyProg: ob du richtige AVR ausgewählt?
- Hast du Strom für Programmieradapter?

Autor: David (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Thanh Tam

Das mit dam Reset es soweit ich das sagen kan nicht der Fall.

Leider weis ich nicht wie ich herausfinde ob der Tackt schwingt

Bei Pony Prog habe ich sowol AVR micro Auto als auch AVr micro At90s2313 
ausprobiert beides ist eigentlich richtig

Auch mit dem strom habe ich zwei sachen ausprobiert sowol die 
stromversorgung über den Compiuter als auch über eine Externe 
stromzufur.

Habe leider keine ahnung was ich falch gemacht habe.
Kan es sei das ich auch ein baustei falsch eingebaut habe. Ich habe es 
zwar kontroliert aber mir ist nichts aufgefallen oder das eien der 
Kondensatoren kaput ist?

MFG David

Autor: Fritz 7 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hatte einmal ein ähnliches Problem. Ich hab mir den Elektor 
Programmer aufgebaut und wollte dann mit Ponny Prog proggen. Leider 
funktioniert ponny prog nicht mit jedem Programmer da das Taktsignal SCK 
an einem anderen Pin ausgegeben wird. Es hat nur eine Weile gedauert bis 
ich das herausgefunden habe!     Vergleich mal deine Schaltung mit dem 
LaNcos Programmer, (irgenwo auf der Pony Prog seite). Gibt doch mal den 
Link deiner Schaltung durch!

Programmierst du seriell oder par.?

MFG: Fritz 7

Autor: Michael (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo, ich bekomme genau die selbe Fehlermeldung.
Mein Resert liegt defininitif auf 5V+ und mein Oszilator schwingt mit 
4MHz (Mit Oszi gemessen!!)
Meine Schaltung des ISP Programiradapters habe ich über einen Link in 
dieser anwendung.(http://rumil.de/Hardwarw/avrisp.html)
Der sub-Stecker ist nach plan angelötet und 1:1 mit dem Paralellport 
verbunden.
Ich hab auch mal auf der Pony prog seite nachgeschaut, dieser Schaltpan 
unterscheidet sich jedoch wesentlich.
David hat diese Lösung bei dir funktionirt?
Mit freundlichen Gruß Michael

Autor: Michael (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Leute,
habe das selbe Problem mit dem Atmega163.
Allerdings hat der AtMega ein paar Lock-Bits die ich ausversehen
gesetz habe. Dadurch läßt er sich nicht mehr betreiben, und PonyProg 
meldet die oben genannte Fehlermeldung.
Mit einem anderen Prozessor klappt dann alles wieder.

Vielleicht hilft euch das weiter

Gruss Michael

Autor: Thanh Tam (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Liest du Lock bit von 163, wo funktioniert und schreibt auf 163, wo 
nicht läuft. Am besten schau du im Datasheet von 163 nach.

Autor: David (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

Ich habe genau den Programmer wie auf der Pony Prog Seite 
(www.lancos.com/siprogsch.html#baseboard) nachgebaut nur habe ich ihn 
von einer anderen Seite (irgend wo auf www.qsl.net/dg5dbz/ (ich glaube 
dan auf Deutsch und dan auf Programmer.))

Ich programiere seriell Fritz 7

Michael Da ich das zum allerersten ams mache und ich noch keinerlei 
erfahrung mit MC habe wüst nicht das ich ihrgend etwas gesetzt habe 
geschweige den wie ich es wieder rüggängig machen könnte.

MFG David

Autor: David (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

Die genaue adresse ist www.qsl.net/dg5dbz/ponyprog/ponypror.html
Da wurde Gestan etwas gebaut darum konte sie nicht aufgerufen werden.

MFG David

Autor: Frankl (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Pony Progger 2000 mit der normalen ponyprog2000.ini (Beta Version) 
ist nur für Atmel's ohne Reset Kondensator. Die Resetpulse und das Delay 
after reset, verändert sich durch den Kondensator (steht in der Hilfe). 
Kann aber im Ponyprog2000.ini angepaßt werden. Ausprobieren. Aber auch 
mit dem seriellen Programmer mit der normalen ponyprog2000.ini und MC 
AT90S1200 (ohne Reset Kondensator)mit 8 MHz in der Applikation, meckert 
der Ponyprogger manchmal. Vielleicht ist es ein Software-Timingproblem. 
Abhängig von der Anzahl der aktiven Programmen. Auch hängt sich die 
Ponyprog-Software auf, wenn ein MOSI, MISO oder SCK als Output mit High 
in der Applikation programmiert wurde (W98SI). Noch nicht mal mit dem 
Affengriff kommt der PC aus dem Deadlock nur mit Power off.

Autor: miwitt001 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe das selbe Problem mit einem AT90S4433. Ich programmiere das 
Teil  parallel mit dem Programmer, der auf dieser Seite hier im Tutorial 
angegeben ist. Die Schaltung und das alles scheint OK zu sein. Wäre um 
Hilfe dankbar
mfg Michael

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.