www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik STK500 wird nicht gefunden


Autor: Michael Borrmann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
habe mein stk500 lange nicht mehr benutzt, und mittlerweile einen neuen
computer, jetzt findet das avrstudio das stk500 nicht wenn ich flashen
will...

da ich kaum glaube dass der com port nicht geht (werde ich aber mal an
einem anderen computer gegenchecken), kann es sein dass ich was noch
einstellen muss damit der comport gefunden wird? war bislang nicht so,
bin etwas verwirrt...
hoffe das stk500 ist nicht kaputt...

Autor: andi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
isp kabel RICHTIG gesteckt?
controller richtig im sockel?
versorgungsspannung richtig?
wird das stk erkannt? einfach unter board im programmiertool des avr
nachschaun...
welchen controller benutzt du?
leuchten die leds am stk?
hast du high voltage programming versucht?


also ohne einige infos mehr werden wir hier nicht weit kommen!

mfg andi

Autor: Michael Borrmann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
kein problem...

also:

isp kabel RICHTIG gesteckt? yep
controller richtig im sockel? schaut okay aus (siehe unten)
versorgungsspannung richtig? ja
wird das stk erkannt? einfach unter board im programmiertool des avr
nachschaun...  das ist ein guter tip
welchen controller benutzt du? atmega16
leuchten die leds am stk? ja, alles ganz normal, der atmega fuehrt auch
das programm was er "drinhat" ganz normal aus...es ist wirklich nur
so, dass winavr das stk500 nicht findet...

hast du high voltage programming versucht? noch nicht...auch ein guter
rat, danke...

Autor: Hauke Sattler (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
kleiner tip am rande

Um zu schauen ob die COM-Schnittstelle mit dem MAX202 vom STK
zusammenarbeitet gibt es einen kleinen Trick.
Dazu schließt man das Serielle Kabel vom Rechner an die
RS232SPARE-Buchse an.
Dann nimmt man einen Jumper und brückt damit RX und TX vom RS232SPARE
Pinheader.
Als letztes startet man noch ein Terminalprogramm (Bray Terminal kann
ich nur empfehlen) und sendet etwas über die COM Schnittstelle.
Es MUß sofort ein Echo kommen. Wenn nicht hat man entweder die falsche
COM-Schnittstelle gewählt, oder die Verbindung funktioniert wirklich
nicht.

Der letztere Fall kann zwei Ursachen haben.
Entweder einer der Treiberbausteine (STK500 oder PC) ist hin.
Oder die PC-Seite ist nicht empfindlich genug.
Der MAX202 auf dem STK500 ist nämlich recht "schwach auf der Brust"
Die Pegel die er üblicherweise erzeugt sind -5V bis +7V.
(Ein gut bemessener MAX202 oder MAX232 kommt mindestens auf -8V bis
+9V)
Das ist für manche PC Schnittstellen zu wenig Signalhub.

Bevor man an seinem STK500 herumbrutzelt sollte man dieses Problem
erstmal ausschließen.

bis dann
Hauke

Autor: andi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Hauke Sattler: wer hat denn was von rumbrutzeln gesagt? ;-)

@threateröffner: liefert die versorgung auch genug strom? und schau dir
mal genau die jumpersettings an! außerdem hab ich mit
high-voltage-programming so manchen fehler bereits beheben können!
probier einfach ein bischen herum! viel spass noch!

Autor: Michael Borrmann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
danke fuer die guten ratschlaege...

lg,
Michael

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.