www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik MMC an Mega16 Geht nicht


Autor: Simon (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo.
Ich experimentiere z.Z. mit einer MMC karte. (normale MMC,
funktionsfähig, was bei meinem nokia handy dabei, 16MB)
Dazu hab ich mir einen Pegelwandler gebaut (Transistorbasierend, siehe
seite von Ulrich Radig). Dann hab ich dei Library von Urlich Radig
genommen und versucht die karten anzusteuern...die signale DI, CLK, CS
kommen an der karten an...nur antwortet die karten nicht !?
an dem anschluss DO der MMC kommt kein signal.

Mein Mega16 läuft mit 1 Mhz (habs auch schon mit 8 Versucht), die
spannungsversorgung der MMC bringt 3,29 V (LM317 Spannungsregler).
Als transistor hab ich den BCY59 (NPN) verwendet. Als widerstände hab
ich hauptsächlich 10 K und 2,2 K verwendet.

Ich hab schon eineiges versucht, aber die Karte bringt einfach nichts
heraus.
Kann mir jemand helfen ?

Schonmal vielen Dank !
MfG Simon

Autor: Mike (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bezeichnung der Karte (Hersteller)?

Autor: Simon (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Karte ist aus meinem Nokia Handy (16Mb). es steht nur drauf, Made in
Taiwan. Also wahrscheinlich n noname produkt. Langsam hab ich keine idee
mehr an was es liegen könnte...ich versuchs jetzt schon seit 3 Tagen,
aber nix geht !

Autor: john (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
war das nicht so das die nokia handy karten mit 1,8v laufen ?

Autor: Simon (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@john: Super, der erste plausieble hinweis seit tagen !
Ob die nokia Karten mit 1,8 V laufen weiss ich net (wenn ich mich recht
erinnere nur die rs typen und des is keine rs)...aber daran kanns
natürlich liegen. fragt sich nur, woher mein kartenleser weiss mit was
für ner karte ers zu tun hat, weil er kann ja mit der falschen
betriebsspannung die Register nicht auslesen. oder versucht er die
spannungen durch und fängt bei 1,8 V an ?
MfG

Autor: Simon (Gast)
Datum:
Angehängte Dateien:
  • preview image for 1.JPG
    1.JPG
    2,35 KB, 93 Downloads

Bewertung
0 lesenswert
nicht lesenswert
Hi...ich hab des ganze grad mal mit ner SD karte versucht...gleiches
ergebniss ! Ich werd noch verrückt.
das einzige was mir aufgefallen ist, ist der spannungsverlauf am
ausgang (DO) der karte aufm oszi...der macht nen kleinen knick. (siehe
anhang). könnte das was zu sagen haben ?
An den kabellängen kann es ja nicht liegen (ca. 15 cm bis zur
Pegelwandler-Platine und dann ca. 5cm bis zur karten)
dann ist mir noch aufgefallen, dass an dem 3,3 V Pegelwandler (LM317)
eine leicht wellige spannung rauskommt...das hält sich aber im bereich
von ca. 10 mV.
Um auf die 3,3V zu kommen hab ich vor dem pagelwandler überhaupt kein
widerstand (kommen genau 3,295 V raus). den widerstand hab ich
weggelassen weil ich davor nur 4,8 V hab und sonst nicht auf 3,3
sondern nur niedriger komm.

MfG

Autor: Simon (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Weiss keiner mehr was ?

Autor: Simon (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
kann es veilleicht an den Transistoren liegen (ich benutze den BCY 59)
oder an den Widerständen des Pegelwandlers ich benutze
R6,9,12,15 = 10K
R5,8,11,14 = 2,2 K
R4,7,10 = 10K
R13 = 2,2K
(siehe
http://www.ulrichradig.de/site/atmel/avr_mmcsd/gfx...)

MfG

Autor: Dirk Milewski (avr-nix)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Und wo ran lag es jetzt?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.