www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik auch bug in avrosp


Autor: marcel (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
also,

wer das forum aufmerksam ließt, wird schon festgestellt haben, dass in
AVRISP ein bug ist, der selbe bug ist auch in AVROSP.
Und zwar folgendes: Bei einigen Chips (speziell die AT90 und einige
ATTiny) liegen die Fuses und lock bits zusammen. AVROSP nimmt nun an,
das die fuses und lock bits auseinander liegen (wie bei Megas) und
nimmt die falschen Kommandos. folge ist, das beim schreiben der fuses
und/oder lock bits alle gesetzt werden.

anbei eine liste mit einer übersicht (nicht vollständig und keine
garantie auf richtigkeit)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.