www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Verzweiflung mit AT89S8252


Autor: Markus Bode (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
ich verzweifel immer mehr mit meinem AT89S8252. Ich habe jetzt
sämtliche ISP's von diesen Seiten ausprobiert:
http://rumil.de/hardware/avrisp.html
http://s-huehn.de/elektronik/avr-prog/avr-prog.htm (parallel und
seriel)

Aber ich bekomme in Ponyprog immer die Fehlermeldung beim löschen so
wie beim schreiben "Device Not Responding". (Habe es auch mit der
Einstellung "invertierter Reset" probiert.

Welche ISP's  benutzt ihr denn so (vielleicht könnt ihr mir auch die
Quelle sagen wo ich den zum nachbauen finde) für diesen µC.
Bitte sagt mir auch eure Kabellängen weil das ja auch wieder was
ausmacht. Ansonsten habe ich die Schaltung aufgebaut wie hier im
Tutorial beschrieben.
Irgend wo habe ich gelesen das man den EA/Vpp auf High setzen muss, und
PSEN auf low, was gibt es dazu zu sagen? Habe auch das Datenblatt
durchkämmt, aber nicht wirklich verstanden was da zu machen ist.

Mein Serieller ISP funktioniert wunderbar mit dem Atmega8, nur nicht
mit dem AT89S8252 :-(

Hoffentlich kann mir jemand helfen?

Gruß
Markus

Autor: Sascha Schulz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich benutze das Flashboard von Elektor. Funktioniert einwandfrei und man
kann direkt alles auf dem Board testen, da die Ports über Steckverbinder
rausgeführt sind.

Autor: Markus Bode (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich habe mir jetzt den Parallelen Programmer auf folgender e-bay seite
gekauft. dürft eigentlich der gleiche sein der auch hier im tutorial
stet also der von rumil oder so.
http://cgi.ebay.de/ws/eBayISAPI.dll?ViewItem&categ...
den hab ich mir zwar schon gebaut aber vielleicht hab ich den IC beim
löten zu heiß gemacht und es klappt deswegen nicht.
ich hoffe es geht mit diesem.
naja aber danke

Autor: Thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
etwas ähnliches kann ich auch berichten. Ich benutze auch PonyProg und
den o.a. Parallelport Programmierer. Merkwürdig ist (89S8252) daß ich
manchmal sofort den Fehler bekomme, dann erst nach 20%, manchmal nach
80% und irgendwann funktioniert es. Am besten dabei: Wenn ich 10 mal
den Fehler hatte geht es irgendwann immer. Und das passiert immer wenn
ich meinen PC einschalte und loslege. Wenn ich eine Weile programmiert
habe mit den geschilderten Problemen klappt es prima bis zur nächsten
Sitzung. Der µC wird dabei nicht ausgeschaltet.
Hab schon den µC gewechselt, drei ICs zeigen den selben Effekt. Hat
jemand so etwas auch schon mal gesehen?

Thomas

Autor: Läubi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
http://www.rowalt.de/mc/avr/progd.htm

Kann ich nur empfehlen, 2 Wiederstände und gut ist, hab ein ca. 30cm
langes Kabel, die dazugehoerige Software braucht nur ein HEX file (z.b.
von AVR studio) udn ab geht die post, der Programmer hat bei mir
aufanhib funktioniert udn das Programm selber macht genau das was man
will und braucht.

Autor: buz11 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Habe auch das Flashboard von Elektor.
Funktioniert einwandfrei und sehr zuverlässig .
Nur wenn das Prog im µC bestimmte Ports heftig klappern lässt ,
( P1.5 bis P1.7 ? ) wird die Verbindung von PC - µC etwas gestört .

Autor: Markus Bode (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
so,
ich habe des rätsels Lösung. Es lag am Ponyprog 2000
mit der 1.7 funktioniert es wunderbar :-)
thx für eure Hilfe

Autor: Birger* (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hab's mit AVRPROG 1.40 aus dem AVR Studio 4.11SP3 versucht. Ging
auch einige male ganz gut. Doch nun scheint er kaputt zu sein, denn er
läßt sich nicht mehr programmieren. Kann es sein, dass eine Ausgabe von
P1 über einen ULN2003 den Controller umgebracht hat? Finde ich
jedenfalls sehr kopfschüttel.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.