www.mikrocontroller.net

Forum: FPGA, VHDL & Co. IN PORT mit default value??


Autor: Emir (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hab bei der einem Programm folgende Fehlermeldung herausbekommen:

"Line 71. IN mode Formal reset of com_conv with no default value must
be associated with an actual value."

Ich versteh einfach nicht was diese Fehlermelung soll. Sie ist gekommen
nachdem ich ein "integer range" geändert hab, was eigentlich nicht
damit zu tun haben dürfte.

Und wieso sollte ein "in port" ein default value haben???
Den Wert erhält das reset erste wenn ich ein Taste betätige...

Ich hoffe ihr könnt mir weiterhelfen und Danke schon mal im voraus!!

mfg Emir

Autor: Tobias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
an welcher Stelle tritt die Fehlermeldung auf, beim simulieren?

stell doch mal angegebene Zeile 71 hier rein

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [vhdl]VHDL-Code[/vhdl]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.