www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Ist mein SPI defekt ?


Autor: Chris (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Leute

ich habe ein Problem mit meinem ATMega8 und zwar hat er ganz plötzlich
(direkt nach einem erneuten Flashen) die angeschlossene Schaltung über
SPI nicht mehr angesteuert. ISP funktioniert jedoch tadellos.

Sowohl SS als auch CLK hingen an jeweils 2 Schieberegistern (1x74HC165
& 1x74HC595)

Ist die Belastung für den Controller vielleicht zu hoch gewesen ?

Die angeschlossene Platine zeigt auch, abgesehen davon dass das
Programm nicht mehr läuft, keinerlei ungewöhnliches Verhalten. Bei
abgestöpselten SPI-Bus flacken die LEDs herum bzw laufen durch, während
dem flashen leuchten Sie auf und springen dann auf 0 - also alles wie
auch zu dem Zeitpunkt, als es noch funktionierte.

Weiss wer Rat, was eher defekt sein könnte.

Grüße

Chris

Autor: Chris (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Tut mir leid das war Speicherplatzverschwendung - ich suche seit 40
Minuten nach dem Fehler und kurz nachdem ich gepostet habe finde ich
ihn

Sorry nochmal

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.