www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Relaisansteuerung


Autor: Jens (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo
Ich steuere mit dem 90S8535 über mehrere 74HCT25(kombi nierter 1x8 Demux 
und Latch) mehrere Relais an. Um an den geschalteten Relais verschiedene 
Spannungen einzustellen, habe ich eine Verstärkerstufe davorgebaut, die 
ich mit einem Schalter zu- oder wegschalten kann. Dieser Schalter 
schaltet insgesamt 4 Relais zwischen denen die Verstärkerstufe hängt. 
Ich habe jetzt das Problem, wenn ich den Schalter betätige zerschießt es 
machmal die an den HCT259 eingestellten Relaisstellungen. Haz jemand 
eine Idee was das sein könnte?

Autor: Mike (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
sind Freilaufdieoden parallel zu den Relaisspulen?

Mike

Autor: Jens (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja, bei den Relais, die vom Controller angesteuert werden hat jedes eine 
eigene und die 4 Relais, die an dem Schalter hängen haben eine zusammen.

Autor: Johannes (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Welche lasten schalten Deine Relais? Bricht evtl. die Versorgung 
zusammen?


mfg johannes

Autor: Jens (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hab ich überprüft, Versorgung macht keine Probleme.

Autor: Denis (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich hab zwar keine Ahnung aber das hört sich für mich nach EMV Problemen 
an die durch die Relais (Abreißfunken) verursacht werden. versuch mal 
die relais ohne irgendwelche Lasten zu Betreiben. vieleicht läst sich so 
ja das Problem eingrenzen.

Autor: Jens (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Eine Last hängt an den Relais noch nicht dran. Das Problem ist schon 
beim reinen umschalten aufgetreten.

Autor: Peter Dannegger (peda)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jedes Relais braucht die Diode !
Eine für vier reicht nicht.


Peter

Autor: Michael (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Eine saubere Masse und gut abgeblockte Versorgungsspannung schadet auch 
nicht !
Michael

Autor: Mike (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

stimmt, unbedigt Versorgungsspannung entkoppeln, ordendliches C in die 
Leitung zu den Relais, evtl. mit Oszi mal die +5V am Prozessor messen.

Mike

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.