www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik denkfehler in schaltung?


Autor: stoffl (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

Also ich habe mich entschlossen ein wenig mit einem AVR herumzuspielen
und da ich noch relativ neu in der Materie bin habe ich im vollgedem
noch ein paar Fragen:

Ich habe mir mit Hilfe dieser Seite ein Entwicklungsboard
zusammengabaut, doch leider Funktioniert es nicht.
Könntet ihr euch bitte einmal meine Schaltung ansehen ob ich irgendwo
einen denkfehler eingabaut habe? (sieh anhang)

Wie man erkennen kann möchte ich alles auf einer Platine unterrbringen.
Also Spannungsversorgung, Microcontroler und ISP Programmer.

Der ISP adapter ist von dieser Seite:
http://rumil.de/hardware/avrisp.html#avrprog6
Die Schatlung mit dem AVR habe ich aus dem AVR - Tutorial, ebenso wie
die Spannungsversorgung.

mfg stoffl

Autor: Gerhard Gunzelmann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

ich komme aus dem PIC-Lager, da wird der Quarz anders angeschlossen
??!

Gerhard

Autor: Sascha (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So, kann das mit dem Quarz nicht funktionieren!

Autor: dds5 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das untere Ende des Quarzes scheint über ein Label mit dem oberen Pin
der Leiste verbunden zu sein.
Dann würde es funzen.

Dieter

Autor: stoffl (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
dieter:

kannst du mal bitte eine skizze posten weis nicht genau was du meinst.

Autor: Sascha (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
So sollte es aussehen

Mfg Sascha

Autor: D. W. (dave) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Anfangs is ja beim m8 (is das einer? sonst alles streichen) der interne
RC aktiv.
Der Quarz wird da ja garnich benutzt.

Aussehen tut die Schaltung sonst schon gut, das mit dem ISP musste
selbst mit dem auf der Seite überprüfen, ich denke da eher an nen
Lötfehler..

Autor: stoffl (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hab das nach dem AVR tutorial gemacht und da wird geschrieben das man
nen 4 MHz Quarzoszilator oder 4 MHz Quarz verwenden soll.

Dann muss man ja irgendwie,  ich galube man sagt fussi bits oder so
einstellen das der Quarz als taktgeber verwendet wird.

Autor: Sascha (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Heißen Fuse-Bits. Und mach da keinen Fehler, kenne ich aus eigener
Erfahrung :)

Mfg Sascha

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.