www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik LCD Pixelfehler


Autor: Eckhard (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Servus,
ich hab endlich erfolgreich ein 2x20 LCD (KS0076B Controller) ans
Laufen gebracht.
Nun ist mir aber aufgefallen das in den ersten 10 Zeichen beider
Zeilen Pixelfehler auftretet, einige Pixel sind nur zu erahnen, andere
haben vollen Kontrast.
Kann ich davon ausgehen, das ich das Teil zwar nicht gekillt aber
zumindest schwer verwundet habe?

Vielen Dank schonmal,
Eckhard

Autor: Freak5 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dazu kann ich nichts sagen. Bei meinem Toshiba Grafikdisplay von Pollin
kamen aber ähnliche Fehler.

Hast du die Spannung eigentlich stabilisiert?

Autor: Eckhard (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Naja, ich versorge das Display halt aus dem gleichen Spannungswandler
wie den Mikrocontroller. Komisch ist halt, das der Fehler wirklich nur
in der ersten Hälfte des Displays auftritt.

Autor: matthes (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich hab in meinem 16X2 auch zwei spalten kaputt. Bei mir lag es daran
das die hintergrundbeleuchtung  zu warm geworden ist (vorwiederstand
falsch gewählt).

Autor: Eckhard (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Isch 'abe garkeine Hintergrundbeleuchtung...
Mich würde halt interessieren ob ich mit dem Fehler alleine bin oder ob
den irgendjemand kennt. Das LCD ist übrigens von Reichelt.

Autor: Horst-Otto (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Da das LCD als eine Matrix aufgebaut ist, müßten eigentlich alle Fehler,
die nicht das LCD selbst betreffen (Kontaktschwierigkeiten, defektes
Ansteuerungs-IC), sich immer auf eine komplette Spalte oder Zeile
auswirken.

Also wird der Fehler im LCD selbst sein. Was hast Du denn damit
angestellt?

Autor: Eckhard (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was ich damit angestellt hab?
Stundenlang versucht das verdammte Teil anzuschliesen und anzusteuern.
Wahrscheinlich hat es dabei wirklich nen Schlag abgekriegt.
Noch was lustiges ist mir eben aufgefallen: Wenn ich in die erste Zeile
Text schreibe und anschließend den Cursor in die zweite Zeile setze,
blinkt der Buchstabe über dem Cursor leicht mit. Allerdings auch nur
wieder in der ersten Hälfte des Displays... Ich deklariere es jetzt
einfach mal als defekt. Aber solange ich noch was drauf erkennen kann
ist es für den Moment ja erstmal ok so.
Vielen Dank für die schnellen Antworten euch allen & gute Nacht!

Autor: ERDI - Soft (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kann es sein, dass deine Versorgungsspannung ungepuffert oder zu schwach
ist?

Autor: Freak5 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jo das hat mir einer bei der Uni bei meinem Display auch gesagt. Das
muss ich echt mal ausprobieren. Benutzt du sowas die den 7805?
Ich habe den vorher noch nicht benutzt. Das Display muss ich damit mal
testen.

Autor: flintstone (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Eckhard!

Ich kenne dieses Problem auch. Es ist begleitet von Schlieren, die über
die Zeichenfläche hinaus gehen.
Bei mir lag es an offenen Leitungen. Ich hatte alle Leitungen, die ich
nicht benutzt hatte in der Luft hängen lassen. Nachdem ich diese
Leitungen mit Pullup- bzw. Pulldownwiderständen versehen habe, ist das
Bild klar und der Kontrast wesentlich besser.

Gruß
Guido

Autor: ERDI - Soft (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja, 7805 oder LM2940 sind bei mir im Dauereinsatz.
Evtl. könnte es aber auch schon helfen (sofern es denn überhaupt an der
Spannung liegt), nen 10µF Kondensator parallel zur Versorgungsspannung
zum Display zu hängen (so nah wie möglich am Display).
Damit kannst du kurzzeitigen Spannungseinbrücen entgegenwirken.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.