www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Seltsames Verhalten Koax-Opto-Konverter


Autor: Ithamar Garbe (antimon)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe mir heute einen Konverter gebastelt, der digitale Signale der
HiFi-Anlage von Koax auf optische Leiter wandeln soll.

Allerdings zeigt dieser (siehe Anhang) ein seltsames Verhalten: Bei
normaler Betriebsspannung (7805 liefert 5V) funktioniert er nicht, erst
wenn ich die Betriebsspannung so weit runterdrehe, dass ungefähr noch
3,3V am Ausgang des 7805 anliegen, wird das Eingangssignal einwandfrei
gewandelt. Sonst erkennt die Anlage keinen PCM- oder
DolbyDigital-Datenstrom.

Ich habe schon versucht, mit dem Oszi die Signale zu prüfen, aber
nichts aussergewöhnliches feststellen können - suche ich auf der
falschen Frequenz? Normalerweise ist die Samplingfrequenz doch 96 kHz
oder?

Hat jemand ne Ahnung was das Problem sein könnte? Falsch dimensionierte
Bauteile? Ist der IC zu langsam? Hab echt keine Ahnung was das sein
könnte...

Autor: Jadeclaw (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der IC ist nicht zu langsam, aber es muss ein HC sein,
HCT geht eher schlecht.
Ansonsten 100Ohm in Serie zu C5 schalten und evtl. C5 auf 10nF
verkleinern.
Und wenn das nicht hilft, R3 durch ein 47k-Trimmer ersetzen
und auf optimale Funktion abgleichen.

Gruss
Jadeclaw.

Autor: Ithamar Garbe (antimon)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hmm okay das werde ich mal ausprobieren.

Aber was ist der Unterschied zwischen HC und HCT? Aus den Datenblättern
bin ich nicht schlau geworden.

Eigentlich sollte das ein HCU sein, der wäre noch besser oder? Leider
hab ich den bei Reichelt nicht auftreiben können...

Autor: Jadeclaw (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Unterschied ist der, dass HCT pegelmässig auf TTL abgestimmt ist.
Und dass scheint bei dieser 'Quasi-Analog'-Beschaltung Probleme zu
bereiten.
Ich habe das schon öfters in dieser Art gesehen und jeder hatte HC
drin.

Gruss
Jadeclaw.

Autor: Ithamar Garbe (antimon)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ah okay... dann wurde ich falsch informiert als es hiess, der HCT ginge
auch...
Macht es dann Sinn mit einem Spannungsteiler das Eingangssignal auf den
Pegel zu heben, die Eingangsspannung zu senken oder irgendwas anderes
abzustimmen?
Oder ist es das Beste und Einfachste, das nächste Mal nen HC
mitzubestellen?

Autor: Jadeclaw (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
HC einsetzen,mit Widerständen kann man dann immer noch experimentieren.
In meinem Konverter ist das Gleiche drin mit einem HC.

Gruss
Jadeclaw.

Autor: Sssssss (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi!

Ermuntert durch diesen Post hab ich meinen Wandler mal wieder
hervorgekramt.
Ich dachte er funzt nicht weil ich den Ausgang irgendwie nicht
aktiviert bekomme (Via Epia MB).

Meine Schaltung irgendwo ausm Netz hatte aber einen 10K Poti am ersten
Inverter.
So funktionierte er nicht. Habe dann mal die 10K wie oben eingelötet
und aufeinmal höre
ich Musik :D Klasse !

Also bei mir ist auch ein 74HCT04 drauf.
Versorgungsspannung ist 5V ausm USB Port (ungefiltert g)
Nur am TOTX sitzen 4,7uF und 100nF zwischen Vcc und GND.
Eingangs C ist nur 22nF statt 100nF (C5), den 75 Ohm R habe ich auch
nicht drin (sind nur 20cm Cinch).

Funzt aber super...

Autor: Ithamar Garbe (antimon)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hey, freut mich dass mein Post noch nen praktischen Nebeneffekt hatte
;)

Mein Bausatz lag auch rum auf ner Lochrasterplatine, weils ned gefunzt
hat. Heute dachte ich mir, ich könnte ja mal ne gescheite Platine
ätzen, wenn ich eh schon dabei bin, und siehe da, es hat gefunzt. Nur
leider ned lang...

Und dadurch bin ich auf die Probleme gestossen. Teste doch mal, wie
lang deiner im Dauerbetrieb läuft.

Meiner läuft jetzt schon seit n paar Stunden einwandfrei, halt mit
3,3V, was vermutlich nicht optimal ist.
Deswegen werd ich mir nen HC mitbestellen, dank Sockel ist der ja
schnell getauscht ;)

Autor: TravelRec. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielleicht macht´s auch Sinn, den 10k R durch einen 47k oder 100k zu
ersetzen, denn der Eingang vom coaxialen Signal liefert nur 0.5V ss und
das reicht eventuell nicht, um den ersten Inverter auf den jeweils
entsprechenden Pegel zu zwingen. Macht man den Eingang also
hochohmiger, sollte die Empfindlichkeit steigen. Insgesamt gesehen ist
diese "Gurken-Lösung" aber doch recht anfällig gegen
Betriebsspannungs-, Temperatur- und Bauelementetoleranzen. Ein
schneller Rail-To-Rail OP-Amp im Eingang brächte die Pegel sicher
besser und störungsärmer auf TTL-Level und man könnte auch noch eine
gewisse Filtercharakteristik mit einbauen...

Autor: Ithamar Garbe (antimon)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ah okay... hmm Op-Amp wär ne Idee - aber da ist das wieder so ne Sache
mit der Spannungsversorgung...

Jetzt noch ne Frage zur Platine (siehe Anhang): Vom Eingang zum Ausgang
ist eine Masse-Leiterbahn vorhanden, die neben den Signalleiterbahnen
verläuft - hat es größere Auswirkungen wenn man die entfernt?
Die Schaltung ist vom großen C, den Bausatz gibts aber nicht mehr und
die Platine ist der Bedienungsanleitung nachempfunden, also nicht auf
meinem Mist gewachsen. Jetzt würde ich die Platine aber gerne
optimieren, da die nicht gerade platzsparend geroutet ist. Also alle
Bauteile ein wenig näher zusammenrücken und die Leiterbahnen optimiert
verlegen.

Muss da die Massebahn (zur Abschirmung?) mitgeführt werden? Muss ich
auf andere Sachen achten (z.B. keine Leiterschleifen, die störende
Signale auffangen könnten), oder ist die Schaltung mit dem HC dann
störunanfälliger?

Autor: Alex Drei (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

U heißt ungepuffert. Ein ungepufferter Baustein an dieser Stelle in der
Schaltung macht Sinn. Er wirkt ähnlich wie ein analoger Verstärker.

Mit einem gepufferten IC hatte ich in einer ähnlichen Anwendung mal
Probleme, dieses erzeugte während des Flankenübergangs (fast)
unsichtbare Schlenker. Der darauf folgende schnelle Zähler hat diese
aber mitgezählt. Nur mit einem sehr teueren Oszi war es auch zu sehen.
Nach dem Einsatz eines U-Typs funktioniert die Schaltung wie geplant
und die Schlenker waren weg.

Grüße
Alex

Autor: Sssssss (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi!

So, habe jetzt nochmal meine Schaltung bissl aufgeräumt:
- restlichen offenen Eingaenge nach gnd gelegt (fehlte ne Brücke)
- 100k poti durch 22K ersetzt.

Danach ging sie nicht mehr :-X

Drauf rumgedrückt ... Musik ... still ... Musik
Wenn mein Finger den ersten Inverter und den 22K R berührte gings.
Hab jetzt parallel zum 22K R nen 15pF C eingelötet und nun
gehts
viel fehlerfreier als gestern :D
Rumgewackle an der gesamten Schaltung macht nichts mehr aus.

Komisch das ich jetzt nen C brauche. Selbst mit festem 10K R gings
nicht.

Das einzige was mir noch auffällt:
Wenn kein Signal anliegt erkennt mein MD trotzdem ab und an nen
Signal. Werde mal die Schaltung isolieren und mit Alu umwickeln 8)
Mal schaun...

"Langzeittest" läuft jetzt seit 15min ohne Probleme

Autor: Sssssss (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
meinte 10K Poti statt 100k ...

Autor: Sssssss (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ok selbst mit Abschirmung erkennt mein MD keine
Pausen/neue Tracks mehr...
Auf der Ansteuerungsseite sehe ich immer nen -12dB Pegel :-X
Werd wohl das ganze noch mal mit nem HC aufbauen ::)

Oder es liegt an dem Output meines Epia Boards ?!
Klang ist super, kein klicken oder aussetzer. Nur Pause gibts nicht
wirklich ....
Hmm evtl steuern die den Output anders an.
Bei meiner SB Live Player erkannte der MD Recorder die Trackwechsel
automatisch.

Autor: Sssssss (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So, hat mir keine Ruhe gelassen g
Bei voll aufgedrehtem Amp und keinem Signal hoerte man leises
klacken...

Hatte nur noch nen SMD 74HC04. Hab dem die nutzlosen output Pins
von den Invertern abgeschnibbelt und alles auf
ne Lochrasterplatine draufgeschmissen.
Hab dann gleich alles in smd draufgepackt, liess sich erstaunlich gut
löten ...
Jedenfalls hängt jetzt ne 2cm x 1cm Platine am totx und alles
funzt soweit.

Bauteile:
IC: 74HC04 smd
R4: hatte keine 75 ohm -> weggelassen
C5: 100nF
R3: 10K
R2: 0ohm
R1: 10K Poti, ka worauf der eingestellt ist, eher richtung 8K
L: hab grad keine gefunden

Stromversorgung: gnd und 5V aus nem usb port geklaut
Entstörung: 100n am 74hc04, 100n am totx, 3,3u am 74hc04, 33uF am totx
Spule fehlt.

Scheint endlich robust zu funzen. Jedenfalls kann ich jetzt die
Platine
berühren wo ich will und keine aussetzer :D
Auch das klacken bei keinem Signal und lautem Amp ist weg.

Danke für den Thread ;)

Autor: Ithamar Garbe (antimon)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hmm hört sich gut an - ich werd weitertesten wenn ich meinen HC habe...
bis dahin heisst meine Aufgabe "Wie baue ich mir aus einer
7-EUR-Funkklingel eine 3-Kanal Fernsteuerung" ;)
Funzt sehr gut, muss ich sagen ;)

Eine Spannungsversorgung für den Konverter muss ich mir auch noch
überlegen, USB finde ich unpraktisch, da geht wieder ne Buchse verloren
- Kabel rausziehen ausm PC is auch dumm... mal gucken, vielleicht fällt
mir noch was geniales ein ;)

Autor: Sssssss (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mach dir einfach nen Y-Kabel.
USB Stecker <---- kabel ------ [koaxopto]---- kabel -----> usbbuchse am
kabel.
Kauf bei reichelt einfach 1m USB Buchse->USB Stecker Kabel und schneids
durch ;)
Der Optowandler zieht nur 20mA, sollte also keine Probs geben.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.