www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik ATMega8 mit STK200 programmieren


Autor: Philipp (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

warscheinlich eine ziemlich blöde Frage. Ich habe hier einen STK200
Clone (meine ich zumindest) da habe ich bisher immer mit dem 2313
gearbeitet und ihn mit Atmel AVR ISP 2.4 programmiert.

Nun wollte ich auf den Mega8 umsteigen und als ich das Programm flashen
wollte fiel mir auf das er in der Liste es ISP nicht drin ist. Dann habe
ich eben die aktuellste Version des ISP runtergeladen (gefällt mir gar
nicht) und da finde ich den auch nicht. Was mache ich falsch? Wie kann
ich nun mein Programm in den Mega8 bekommen?

Vielen Dank schonmal
Gruß Philipp

Autor: Philipp (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
irgendjemand hier muss doch auch den Mega8 programmieren. Gibt es sonst
ne andere Lösung die man schnell nachbauen kann?

Gruß Philipp

Autor: Andy (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,ich machs schon seit einiger Zeit mit diesem stecker,hatte noch
nie Probleme.Einfach Ponyprog 2000 installieren und los gehts.
Ist sehr schnell gemacht.
gruss
andy

Autor: Alexander Sewergin (agentbsik)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Versuch doch mal PonyProg zum Flashen. Wenn du einen Dongle für den
STK200 hast, dann müsste Ponyprog den Dongle anerkennen.

Google halt mal nach Ponyprog im Netz

Autor: Philipp (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielen Dank, allerdings habe ich PonyProg gerade mal installiert (1.17h)
und dort kann man auch keinen Mega8 auswählen. Kann ich sonst einfach
einen anderen auswählen? Verwendet ein AVR das exakt gleiche Protokoll
und hat gleichen Flash?

Gruß Philipp

Autor: wgoedde (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hier nochmal die Pinbelegungen
http://instruct1.cit.cornell.edu/courses/ee476/Atm...

Beim Atmega8 brauchst du
Pin
1  Reset
17 Mosi
18 Miso
19 Sck

Im Pony unter Device->ATmicro->ATmega8 auswählen
und
unter Setup->InterfaceSetup  "parallel" und "AVR ISP I/O"
Ein "probe" sollte OK liefern

Autor: Philipp (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielen Dank. Es lag an meiner Version von PonyProg. Hatte erst 1.17h
jetzt habe ich 2.06e und dort ist auch der Mega8 drin. Vielen Dank an
alle

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.