www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik STK500 Com-Port


Autor: guenter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

Auf dem STK500 ist ein ATMEGA163 montiert.
Als Software habe ich ein einfaches BASCOM-Programm
geladen

$crystal = 3686400
$baud = 9600

Config Portb = Output

Do
  Portb = &HFF
  Print "1111";
  Waitms 100
  Portb = &H00
  Print "AAAA";
  Waitms 100
  Portb = 255
  Print "3333";
  Waitms 500
Loop
Ich möchte also über die auf dem STK-Board befindliche 
2.Com-Schnittstelle mit dem
Print-Kommando Daten auf einen PC ausgeben.

Zu diesem Zweck habe ich

1.
Portd.0 (RxD) und
Portd.1 (TxD) mit dem 2-poligen Stecker (RS232-Spare)
verbunden

2.
die Com-Schnittstelle (RS232 Spare) über ein Kabel mit der 
COM2-Schnittstelle eines PC's verbunden.

Pin-Belegung:

STK-500   PC

 2 ------  2
 3 ------  3
 5 ------  5

restl. Pins sind frei !! ??

Das Programm läuft --> die LED's 0 - 7 blinken im
richtigen Zeitabstand.

ABER....
--------

auf dem PC (WIN 95) kommen verstümmelte Zeichen an

ich verwende dort das Programm
HYPERTERMINAL

ich habe schon eine Vielzahl von Einstellvarianten
(u.a. 9600-8-N-1 usw. usw.)
versucht, ... aber es will mir nicht gelingen.

Frage:

welche Einstellungen sind eigentlich erforderlich und
korrekt (für HYPERTERMINAL ) ??

gibt's eine Alternative zu dem Programm HYPERTERMINAL

Wer kann mir weiterhelfen ?
Besten Dank im Voraus

Günter

ps: ein entsprechendes Ass-Programm habe ich auch schon probiert -- das 
gleiche Ergebnis;

es scheint also an den Einstellungen für das Terminal-Programm zu 
liegen...?????

Autor: Oliver K. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Guenter,
ich habe zwar keine Ahnung von Bascom, aber Deine Probleme habe ich auch 
hin und wieder.

Hast Du auf Deinem Mega die Anzahl Startbits und Parität gesetzt? Sie 
muessen mit den Einstellungen von Hyperterminal korrespondieren.

Sitzt der richtige Quarz auf Deinem STK? Läuft Dein Prozessor mit der 
vorgeschriebenen Taktrate?


Prüfe das bitte mal.

Grüße Oliver

Autor: Gerhard Paulus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo guenter,

stell mal im Programm die Takfrequenz auf 1 MHz ein.

Wenn ich das Datenblatt des Mega163 (clock options) richtig verstanden 
habe, dann taktet das Teil standardmäßig nur mit dem internen 
Oszillator.

Ansonsten probier erst mal ein einfacheres Teil aus (4433 etc.).

Gerhard

Autor: guenter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

Vielen Dank für die Antworten

mit einem 8515 funktioniert es;

der M163 weigert sich immernoch
(auch bei 1 MHz)

gruß

Günter

Autor: mikki merten (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Falls dein Mega 163 noch mit dem internen 1 MHz RC-Oszillator arbeitet, 
sind doch 9600 Baud auf der seriellen Schnittstelle nicht möglich. 
Ändere doch einfach mit dem STK500 und AVR Studio die Fuse-Bits beim 
Mega 163 entsprechend auf externen Oszillator.

Autor: guenter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Mikki

Der Hinweis war 'goldrichtig'

Es funktioniert jetzt

Besten Dank

Günter

Autor: Matthias Greiner-Petter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo, Allerseits...
wer kann mir sagen WIE die Fusebits beim ATMega163 gestzt werden müssen
, um den externen Quarz zu aktivieren...bzw. die CLKbits um mit 8Mhz
extern zu takten
Matthias

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.