www.mikrocontroller.net

Forum: FPGA, VHDL & Co. FPGA- Programmierung


Autor: Emina Dzambo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Ich progrmmiere gerade einen FPGA von Xilinx, oder besser gesagt ich
versuche es... Ich habe seit 3 Wochen, das gleiche Problem und ich habe
gesehen, dass sich hier viele damit auskennen, habe aber keinen Beitrag
gefunden, welcher mir helfen könnte:

Ich benutze XC2C256 TQ144 und das Programm von Xilinx 5.2i, ich habe 2
Schaltungen in einem schematic-file und verbinde sie indem ich die Nets
gleich benenne. Das funktioniert eigentlich und die Schaltung ist ganz
sicher 100% richtig, aber nachdem ein Warning kommt, wenn ich es
programmieren will, weigert sich das Programm die Überprüfung
fortzusetzen (und erstellt kein *.jed - file). Ohne die Verbindungen
der einen Schaltung zur anderen funktioniert es. Außer die Verbindung
reset, die funktioniert immer. Ist das Programm schuld? Hatte jemand
dieselben Probleme?

Danke im Voraus.
Ganz liebe Grüße
Emi

Autor: FPGA-User (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

gib doch mal die genaue Fehler-Message an, sonst
wirds schwierig.

Autor: Emina Dzambo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo, erstmal danke für die antwort

ich habe den verdacht, dass mit der schaltung alles stimmt und dass
programm einfach nur müll ist. wenn ich versuche den fpga zu
programmieren gibt das programm diese fehlermeldung aus:

das programm verursachte einen fehler, bitte starten sie es neu!

und dann steht alles, es wird das programmierfenster geöffnet, doch es
wurde kein file (*.jed) erstellt.

danke im voraus emi
lg

Autor: FPGA-User (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
die Fehlermeldung ist natürlich nichtssagend ...
Sorry, da fällt mir auch nichts ein

Autor: Emina Dzambo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Tja, jetzt weißt du wie es mir geht... :-) gg

Autor: Sven Johannes (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Moin...

- 100%ig richtig? Die Aussage ist immer kritisch. Selbst bei 5.1i sitzt
der Grund der Fehler zu 90% auf dem Stuhl vor der Tastatur.
- Schematic kannst du in die Tonne hauen. ALLE Versionen. Meine
Meinung, zumindestens solange die es nicht hinbekommen da etwas
lesbares zu generieren.
- Zwei Schaltungen durch umbennen der Netze zu verbinden ist
zumindestens grenzwertig. Instanziiere doch beide Schaltungen in einer
übergeordneten Hierachie und verbinde die Komponenten dort.
- In deinem ersten Posting hast du von einer Warning gesprochen, was
meckert er da an?

--
 Sven Johannes

Autor: Emina Dzambo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Ja, zu 100% ich habe die Schaltung schon ein paar mal aufgezeichnet.
der fehler liegt wirklich am Programm. Dem Programm sind Warnings egal.
Gestern habe ich gemerkt, dass es einmal geht einmal nicht. Also ist
wirklich das Programm ein Problem... ich suche jetzt nach einem neuen
Programm :-)!

Danke für deine Antwort!

Ganz liebe Grüße
Emina!

Autor: AxelMeineke (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also wenn ihr in ein anderes Produkt investieren wollt, probiert mal
http://www.synplicity.com/
Wär nett wenn du dann mal von deinen Erfahrungen berichten könntest.
Ich habe es mal angetestet und war recht zufrieden.

Autor: Emina Dzambo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ok, gerne, mach ich dann.. Danke nochmal!

L.G.Emina

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [vhdl]VHDL-Code[/vhdl]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.