www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Probleme mit der AVR Entwicklungsplatine (ATmega16)


Autor: Urs Hanselmann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi!

Ich hab mir hier im Shop die AVR Entwicklungsplatine (ATmega16) oder
wie sie wirklich heißt Olimex AVR-P40B-8535 und dazu einen ATmega16
gekauft.

Serielles Kabel hatte ich noch eins und ein 12V Netzteil hab ich auch
noch Zuhause gefunden (Ausgang: 12V Gleichstrom bei 200mA 2.4VA, Plus
ist in der Mitte, Masse ausen)´. Allerdings da schon mein erstes
Problem: Wenn ich das jetzt anschließe leuchtet die LED nicht. Das hat
mich aber dann noch nicht abgeschreckt. Ich hab also wieder Stecker
gezogen ATmega16 rein, Stecker rein, serielles Kabel an COM1, PonyProg
heruntergeladen, im Setup auf COM1 gestellt auf Test und "Failed".
Mit COM2 hab ichs auch probiert.

Was mach ich da falsch?

PS: Das Netzteil ist nicht futsch. Das hab ich mit nem Spannungsmesser
gemessen. Kommen 15V oder so raus.

Autor: A.K. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die LED hat einen Jumper. Ohne den leuchtet nix.

Laut Schaltbild ist der COM-Port erstmal mir garnichts verbunden.
Insbesondere nicht als ISP-Programmer. Serielle Programmierung per Pony
braucht einen entsprechenden Dongle, dessen Ende im ISP-Connector
landet, nicht im COM-Connector. Kann man auch auf das Board drauf
bauen, ist dann aber nicht wiederverwendbar.

Autor: Urs Hanselmann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Heißt das jezt ich brauch noch einen ISP-Programmer? Und der LED Jumper
ist drinnen.

Autor: A.K. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja, Du brauchst einen ISP-Programmer.

Die LED ist keine Power-LED sondern ist mit einem Portbit verbunden.
Ohne passendes Programm leuchtet da auch nix,

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.