www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik CNY17 an HEF4067


Autor: Matthias Gratl (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe eine Schaltung mit 16 dig. Eingängen. Diese Eingänge(24V)
sollen Galvanisch getrennt werden und auf 5V gebracht werden.
Hierzu verwende ich den Optokoppler CNY17.
Der Vorwiderstand ist 2,7kOhm, Pull-UP auf Vcc.
Danach auf den Multiplexer. Hier beginnen die Probleme:
Wenn der Multiplexer angeschlossen ist, ist der Pegel am Collector
konst. egal was am Eingang des OK passiert. Wenn Multiplexer nicht
angeschlossen ist funktioniert der OK tadellos.
Komisch ist, dass an den Eingängen des Multiplexers immer eine Spannung
von ca. 1,2 Volt anliegt.
Verstehe ich das Datenblatt des Multiplexers nicht?
Kann mir irgendwer vl. einen anderen 16-1 Multiplexer empfehlen?

Danke im Voraus
Mfg
Matthias

Autor: Christoph Kessler (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der 4067 ist ein Analogschalter, den gibts auch als 74HC4067. Digital
entspricht dem soweit ich noch weiß der 74xx154. Das Verhalten ist mir
auch nicht erklärlich, der 4067 sollte keine Belastung darstellen, wenn
der gemeinsame Ausgang nicht belastet ist. Ich tippe auf
Schaltungsfehler, Masse fehlt oder Kurzschluß irgendwo.

Autor: Matthias Gratl (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kann mir nicht gut vorstellen, dass ich einen Schaltungsfehler habe, da
beides für sich funktioniert. Lasse mich aber trotzdem vom Gegenteil
überzeugen. Denke eher, dass hinter dem ganzen ein Denkfehler steckt

Mfg
Matthias

Autor: Thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was hast du auf dem gemeinsamen Anschluß vom 4067 angeschlossen ?

Gruß Thomas

Autor: Hubert.G (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Poste mal die Schaltung, dann sieht man eher ob da nicht ein
Gedankenfehler drinnen ist.

Autor: Matthias Gratl (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Dies wäre die Schaltung.
Der Vorwiderstand für Test bei 5V dimensioniert.

Mfg

Autor: alfsch (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
teste mal so:
nur ein pullup, am in-out , an den 16in nur ok nach masse.
da der mux analog is, funktioniert er ja in beide richtungen...

Autor: Matthias Gratl (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Habe das nun so gemacht.
Messe am in-out 3,2V wenn Optokoppler nicht leitet und 3,1V wenn
Optokoppler leitet.

Autor: alfsch (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hmmm,
1. was hängt am in-out, is nicht mehr im bild
2. leg mal par zum gewählten ok 1kohm, bei 10k pullup 5v sollte max
0,5v am in-out erscheinen
und?

Autor: Matthias Gratl (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
am in-out hängt jetzt zum testen nur der Pull-up.
wenn das ganze dann funktioniert kommt er auf einen
mikrocontroller-eingang
mfg
Matthias

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.