www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik UART0 und ISP gleichzeitig am MEGA128 verwenden


Autor: moin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
wie kann ich an einem ATMEGA128 ISP und UART0 gleichzeitig verwenden?
Sie benötigen die gleichen Pins. Als ISP verwende ich einen
nachgebauten 910er- oder STK500-Programmieradapter. Am UART0 soll ein
FT232BM (USB-Adapter) hängen, der mit bis zu 1Mbaud betrieben werden
soll.

Würdet ihr euch für Widerstände (z.B.1KOhm) oder für Jumper
entscheiden?  Habt ihr vielleicht noch eine andere Idee?

Euer moin

PS: Mit der 'neuen' Suchmaschine habe ich nichts im Forum gefunden.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.