www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Einfache Frage zu TTL->RS232


Autor: Peter Mairhofer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Ich will meinen PC einfach einschalten können. Am besten geeignet 
scheint mir dafür im BIOS das "Wake On Ring" einzustellen und dann die 
Maus über meine Schaltung schleifen (an COM1 angeschlossen) wobei die 
Leitung "Ring Indication" (Pin22 bei 25Pin Stecker) abgezweigt wird. 
Wenn der PC eingeschaltet werden soll, wird diese Leitung einfach auf 
-12Volt (also HIGH in RS232) gelegt.

Von meiner Schaltung kommt ein TTL Signal, dass normal 0 Volt hat und 
bei einem Anruf ca. 5 Volt.

Wie kann ich das ganz einfach bewerkstelligen, diese Umwandlung?

Meint ihr, geht das oben beschriebene? Sollte schon.

Aber ich will nicht für sowas einfaches einen MAX232 verwenden...meint 
ihr, reicht ein simpler Inverter?? Oder gibts vielleicht sogar NOCH was 
einfacheres/schnelleres?

Vielen dank!

*pte

Autor: Mark Hämmerling (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Salut,

also ich kann Wake-On-LAN zum Einschalten empfehlen. Also den 3pol. 
Header. Macht sich ganz gut. Als Beispiel hier mal meine kleine 
Schaltung zum Einschalten per Fernbedienung:

http://markh.de/wakeonlirc/

Ein Freund meint, daß der IR-Empfang während der Rechner ausgeschaltet 
ist, nicht optimal ist. Ich kann das allerdings nicht bestätigen. Evtl. 
kann man D2 durch ne Schottky-Diode ersetzen. Das könnte helfen.

Viele Grüße,
Mark

Autor: Matthias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

was spricht den gegen die Verwendung des normalen Tasters der den PC 
einschaltet? Den ensprechenden Pin auf dem MB kurz nach Masse ziehen und 
schon spring der PC an.

Matthias

Autor: Andreas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>was spricht den gegen die Verwendung des normalen Tasters
>der den PC einschaltet? Den ensprechenden Pin auf dem MB
>kurz nach Masse ziehen und schon spring der PC an.


Diese Frage stellt sich mir auch, aber wieso einfach, wenn es auch 
umständlich geht...

Autor: Mark Hämmerling (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Salut,

na ich nehme an, daß er den PC nur ein-, nicht auch ausschalten will. 
Wie gesagt, mit WOL ist das problemlos möglich, indem man einen 
150ms-Hi-Puls an das Mainboard schickt. Wenn er bereits an ist, macht 
ihm das nix aus.

Das ganze mit dem Power-Button zu koppeln mißfiel mir auch von Anfang 
an, daher meine Lösung am Wake-On-LAN header. Sicher kann man durch ne 
Erkennung ob der PC eingeschaltet ist (z.B. 5V an I/O) das Ausschalten 
unterbinden, aber das is dann auch wieder etwas umständlich und m.E. 
"dirty". Und bei WOL muß man sich um externe Spannungsversorgung auch 
nicht kümmern. Die 5V liegen ja permanent an (Strom lt. ATX-Specs. bis 
800 od. 850mA). Damit entfällt auch das umständliche Anzapfen der 
Dauer-5V-Leitung vom ATX-Netzteil.

Gibt sicher etliche Lösungen für das Problem... aber das bleibt mein 
Tip. :)

Mark

Autor: Matthias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

WOL hat aber nicht jedes MB. AFAIK geht das bei modernen MB direkt über 
den PCI-Slot und den beaknnten 3-Pin Anschluß gibt es nicht mehr. 
Ich(tm) würde den normalen Einschaltpin nutzen und gegen versehentliches 
Ausschalten über Abfragen der 5V schützen. Versorgung erfolgt über 5Vsb. 
Sollte eine Schaltung mit 2 oder drei Transistoren werden.

Matthias

Autor: Peter Mairhofer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
WICHTIG!!!

1.) WakeOnLan allgemein wäre sicher mehr oder weniger der Traum. Aber 
dafür brauche ich wieder einen kompletten Mikrocontroller mit TCP/IP 
Stack uvm. Dann könnte ich sogar den PC von überall im Haus fernsteuern 
(denn das Netzwerkkabel führt praktisch überall hin). Das ist mir aber 
LEIDER zu teuer und daher auch zu aufwendig.
Einfach den WOL Connector am Mainboard zu verwenden bringt sich für mich 
nicht. Wieso dann nicht gleich über RS232? Und das Timing für WOL ist 
sicher auch nicht ganz einfach!

2.) Das habe ich bereits, doch es gibt Probleme, siehe 3.)

3.) Konkret möchte ich meinen PC per Handy einschalten. Ein altes 
Ericcson Handy gibt beim Anruf ein 5 Volt Signal. Scheint nahezu 
perfekt. Doch in meiner jetzigen Schaltung erzeugt auch ein Einschalten 
des Lichtes zum Beispiel ein kurzes 5 Volt Signal das sich auch durch 
keinen Kondensator ausbessern ließ. Mit ein paar Logik-TTLs frage ich 
auch die Power-LED ab, ob der PC schon an ist. Nützt aber nichts, das 
bleibt alles in allem ein umständliches Unterfangen.

4.) Wieso nicht EINFACH das 5 volt Signal nach -12 Volt RS232 
konvertieren und auf "Ring Indication" legen? Damit bräuchte man auch im 
PC nix verändern und ein Gerät wie zB die Maus könnte man problemlos 
durchschleifen.

Also hat nach jetziger Beschreibung immer noch wer was gegen WakeOnRing?

Oder hat wer eine Idee wie ich das "Störsignal" das immer entsteht 
eliminieren kann? Mit einem fetten Kondensator gings wie gesagt nicht.

thxx, *ptr

Autor: Mark Hämmerling (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Salut Peter,

das "Timing" bei WOL ist denkbar einfach und tolerant: Das Wake-Signal 
besteht aus einem einzelnen Hi-Puls, der wie erwähnt ca. 150ms lang sein 
sollte. Anfänglich hatte ich intuitiv 50ms gewählt, weil ich nichts zur 
Pulslänge im Netz finden konnte. Und das klappte ausgezeichnet. In den 
Specs zum RTL8139 fand ich dann 150ms... so wie ich das sehe, schaltet 
das MB ohnehin bei einer steigenden Flanke ein und ignoriert alle 
folgenden Signale. Und der Puls hat "logisch"erweise 5V, somit entfällt 
die Konvertierung. :) Hmm, also ich würd's einfach mal probieren, das 
Handy direkt dranzuhängen, über einen Widerstand. Einfacher geht's wohl 
kaum. Was meinst Du?

Die RS232-Methode hat sicherlich was, ist aber mit etwas mehr Aufwand 
verbunden - und Kosten. Wenn es allerdings Voraussetzung ist, daß der PC 
nicht geöffnet wird, dann wirst Du ohnehin nicht dran vorbeikommen.

Viel Erfolg!
Mark

Autor: Andreas Wander (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also das ttl signal in eine -12V signal umzuwandeln ist glaube ich 
komplizierter als das mit den powerschalter. es sei denn die -12V 
leitung die netzteile ja auch haben ist an wenn das netzteil aus ist :)

wegen dein problem mit den kurzen 5V signal, hast du den Kondensator 
einfach parallel angeschloßen? oder hast du davor auch ein widerstand 
geschalten? dieser widerstand würde dann ein schnelles aufladen 
verhindern, auch bei kleineren (ca.10µ)kondensatoren.

ich weiss leider nicht wieviel strom man bei den powerschalter schalten 
muss, wenn aber dieser strom nicht sehr hoch ist. würde diese schaltung 
hier gehen.

dein signal    o----
                    |
                   | |
                   | |
                    |
eingeschaltet +5V --
                    |
                   | |
                   | |
                    |
den pin der auf  o--
masse gezogen werden soll.

und wenn jetzt die signalleitung auf masse geht und der rechner noch 
nicht eingeschaltet ist dann geht der rechner an, bedingung ist 
natürlich auch das die +5V leitung im ausgeschalteten modus hochohmig 
ist. müsste man alles ausprobieren. und die schaltschwellen wären 
interesant dann könnte man die wiederstände berechnen. oder man nimmt 
noch 2 transistoren einen zum negieren und den anderen zum schalten. das 
ganze könnte man sehr einfach ohne schaltkreise aufbauen. mit wenigen 
wiederständen und transistoren. leider kenne ich nicht alle 
randbedingungen.

Autor: thomas b (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

so lange Dein Handy nicht mit dem PC Verbnden ist, haben die 5V kein 
Potential (+ oder -). Wenn Du den +5V Ausgang(vom Handy) mit der 
PC-Masse verbindest hat deine Handymasse für den PC eine Spannung von 
-5V. Das sollte die RS232 locker erkennen.

Also einfach das Handy verpolt anschliesen :-)

cu tb

Autor: Peter Mairhofer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo nochmal!

1.) @thomas b: Bist du dir sicher???!!!! Das hört sich nach äußerstem 
Kaputtmachen an! Masse vom LPT1 auf 5 Volt des Handys, Masse von Handy 
auf Pin 22 (Ring Indication)?? Hört sich nicht ganz gesund an, wär aber 
cool wenns gehn tät!!

2.) Ich hab das mit WOL probiert, hat natürlich nicht funktioniert. 
Wieso? Scheint was mit dem hoch/nieder-ohmig an sich zu haben?!
Jedenfalls hab ich zwischen dem einen Pin am Handy(*) und der Handy-GND 
einen 10uF Elko angeschlossen (also parallel). Danach (nach dem 
Kondensator) einen Widerstand von 10kOhm auf dem Handy-Pin. Wenn ich da 
jetzt Strom messe geht es perfekt, und zwar auch ordentlicher als vorher 
(is ja klar). Also schöne 0 Volt standard; bei Anruf +5Volt.
Dann hab ich den Handy-Pin an WOL +5 angeschlossen und die Handy Masse 
an WOL-GND. Probiert. PC schaltet sich nicht ein. Dann messe ich die 
Spannung vor dem WOL wenn alles angesteckt ist: 0,15 Volt bei Anruf; 0 
normal.
Auch mit Entfernen des Widerstands nur ca 1 Volt.
Was ist da los? Que faire?

Thxx,

*ptr


* Für alle dies noch nicht wissen: Dieser Pin schaltet sich auf +5Volt 
(HIGH) wenn ein Anruf kommt

Autor: Mark Hämmerling (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Salut,

also das verwundert mich doch jetzt sehr. Sorry für die Frage, aber bist 
Du ganz sicher, daß Du die Pins nicht verwechselt hast? Der 
Signal-Eingang am Mainboard kann das Spannungslevel unmöglich auf 1V 
herunterziehen. Sollte ziemlich hochohmig sein, daher kann ich mir das 
nicht vorstellen. Hast Du denn mal versucht, die 5Vsb vom Board an den 
Signal-Eingang anzulegen? Mit ner kleinen Drahtbrücke. Aber Vorsicht, 
falls Du bzgl. der Belegung nicht ganz sicher bist. Das Netzteil liefert 
dort wie gesagt >800mA Strom.

WOL header:
1 - Vsb
2 - GND
3 - Signal

Thomas' Idee hat was, das muß ich zugeben. Aber der Gedanke, daß das 
Handy in irgendeiner Weise anderweitig mit dem PC verbunden werden 
könnte und was dann passieren würde, würde mich doch beunruhigen. Masse 
ist nunmal Masse. Und daran was zu ändern würde alles sehr 
unübersichtlich machen... meine Meinung dazu.

Probier Dich doch nochmal an der WOL-Sache. Und meld Dich wieder, wenn 
Dein Erfahrungsschatz gewachsen ist (im positiven Sinne). :))

Viel Erfolg!
Mark

Autor: Peter Mairhofer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
WOOOOW! Ich hab es geschafft mein Mainboard NICHT kaputt zu machen!!

1.) Bist du dir sicher, dass ich den gleichen WOL Anschluss habe wie 
duh? Hab' ein P2B Asus Mainboard und das Manual sagt zu WOL:
The WOL_CON connector powers up the system when a wakeup packet or 
signal is received from the network through the ASUS PCI-L101 LAN card 
(see section VII. ASUS LAN Card).
IMPORTANT: This feature requires that the WAKE On LAN Power Up Control 
is set to Enabled (see "Power Management Setup" under IV. BIOS SOFTWARE) 
and that your system has an ATX power supply with at least 720mA +5V 
standby power.
Jetzt wirds aber spannend: Mein WOL scheint nur 2 Pins belegt zu haben:

Pin1: +5VSB
Pin2: Ground
Pin3: (No Connection)

obwohl der Stecker 3 Pins hat. Laut dir müsste der dritte Pin "Signal" 
sein. Also ich dachte, dass ich in +5VSB meine 5 Volt pumpen muss. Das 
würde sofort erklären, dass das Multimeter verrückt gespielt hat und was 
mit 0,60Volt daher gefaselt hat. Glück für mich dass das Mainboard noch 
geht!
jedenfalls miss ich jetzt den Saft zwischen des zwei Steckern und siehe 
da: Es sing genau 5 Volt.
Also scheinen die ersten Pins Versorgung zu sein?! Aber wie powere ich 
das Ding dann ein? Ist womöglich der 3. Pin doch belegt?
Meinst du in deinem vorigen Post, ich solle diese 2 Pins verbinden (also 
1. und 3.?)

Bezgüglich Thomas-Idee: Mir wird schlecht wenn ich dran denk dass diese 
Masse mit absolut allem verbunden ist, HDDs, Peripherie (bis auf MIDI 
:-), etc etc. Also so gut das auch klingt, scheint mir ein wenig "too 
risky".

UND: Ich nehme jetzt an, der 3. Pin wäre "connected", der erste würde 
einfach nur Spannung liefern und der zweite wäre GND. Dann würde ich in 
meinem Fall die Spannung ja gar nicht brauchen, da ich sowieso 5 Volt 
vom Handy hab?!
Also würde das deiner Meinung dann so passen?

Masse Handy <--> Masse-WOL
Handy Pin <--> Signal-WOL, verbunden über 10kOhm Widerstand
Zwischen Masse und Signal-WOL, aber nach dem Widerstand ein 10uF 
Kondensator.

Vielen Dank für deine Hilfe!!!

*ptr

Autor: Peter Mairhofer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

muss dir noch was sagen. Jetzt weiss ich nicht mehr weiter und warte auf 
deine Antwort ;)

Ich habe jetzt das so angeschlossen wie oben beschrieben: Handy-Pin --> 
3. Pin
Handy-GND --> 2. Pin (WOL-Ground)
Dazwischen ein 10uF Elko und vorm 3. Pin ein 10k Widerstand.

Der PC schaltet sich noch immer nicht ein :´-(
Aber wenn ich jetzt messe habe ich ~2,5 Volt. Wenn ich die Verbindung 
zum Mainboard trenne, habe ich wieder die vollen 5. Also muss der Pin 
schon einmal mit irgendwas verbunden sein; gehe ich da richtig in der 
Annahme?

Aber wie weiter? Muss ich den ersten Pin in den dritten leiten? Wie wärs 
dann mit einem Transistor, der vom ersten zum dritten geht und als Basis 
mit Vorwiderstand den Handy Pin? Danke schonmal

gute nacht

*ptr

Autor: Mark Hämmerling (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Salut,

nun, daß Asus Dir ans Herz legt, eine NIC von ihnen zu kaufen ist wohl 
ein nett gemeinter Hinweis. Oder sie halten Ihre Kunden für blöd. Aber 
sie schreiben selbst, daß die NIC an diesen Connector kommt und daß es 
besagten Puls gibt. Außerdem ist der WOL-Header genau spezifiziert, s. 
oben. Und wo bitte soll laut Asus der Puls sonst anliegen, wenn außer 5V 
und GND nur dieser eine "N/C"-Pin übrig ist? Die sind lustig. Also ja, 
dieser Pin 3 ("N/C") ist der Signal-Eingang. Jede normale NIC wird den 
Puls an Pin 3 schicken... egal was Asus dazu sagt.

Die Spannung von Vsb brauchst Du freilich nicht. Wichtig ist nur das 
Potential von 5V relativ zu GND am Signal-Eingang auf dem Mainboard.

Also:
(Handy)  N/C               1 Vsb   (WOL)
         GND ------------- 2 GND
        Ring ----[10k]---- 3 Signal

Den C kannst Du bei Bedarf mit reinsetzen. Einfach probieren.
So, jetzt will ich aber hören, daß es klappt. :)))

Grüße, Mark

Autor: Mark Hämmerling (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Salut,

haben wir wohl gleichzeitig geschrieben... ;)
Grafik ist auch etwas verkrüppelt angekommen ;(
Nun denn, wo liegen jetzt 2.5V? Zwischen Signal und Masse? Was das denn? 
Versuch mal nen kleineren Vorwiderstand. Aber nich weniger als 500 Ohm 
(10mA).

Mark

Autor: Peter Mairhofer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Abend nochmal,

Hilfe, hilfe!
Da gibts anscheinend ein größeres Problem.
Ich hab' jetzt - wie du gesagt hast - VSB mit Signal mit einer 
Drahtbrücke überbrückt. Der PC macht keinen Mucks.
Also am Handy und der Schaltung kanns jetzt nicht liegen
1.) Ich hab' ein altes Audio-Kabel (4Pin) genommen, den Plastiksockel 
entfernt und das reingesteckt. Funktioniert gut. Kann es sein dass ich 
da keine Verbindung hab? Überprüfen kann ichs ja nicht. Jedenfalls sind 
zwischen GND und VSB die 5 Volt die sollen, beim Signal kann ich nix 
kontrollieren. (is a rhetorische frage:-)
2.) Kann es sein, dass mein Netzteil keine 720mA Standby-Strom liefert? 
Gibt's das in der Praxis überhaupt? Wie könnte ich das am besten messen? 
(das Netzteil muss ja irgendwie belastet sein)
3.) Ist mein Stecker vielleicht doch anders und kein Standard? Also so 
ein extra Asus schei**?
4.) Hab ich das ganze vielleicht schon zerstört durch meine 
Herumprobiererei? Aber die 5 Volt werden ja noch immer brav geliefert 
zwischen VSB und GND...
5.) Ist der Impuls vielleicht viel zu lang, wenn ich VSB und GND 
verbinde? Ich verwende wie gesagt ein Audiokabel, am anderen Ende hab 
ich jeweils 2 aufgebogene Büroklammern in die Löcher gesteckt. Die lasse 
ich jetzt einfach zusammenstossen.

Bez. Handy: Auf dem Multimeter erscheint kurz 1,xx Volt, dann irgendwie 
5 Volt, bei einem Anruf. Und das obwohl es ein träges Multimeter ist und 
nichtmal ein Oszi. Das sieht danach aus als ob die Spannung nicht sofort 
schön da wäre. Kann es auch sein, dass das keine saubere Flanke 
generiert? Wie mache ich das dann am besten? Sollte ja eigentlich der 
Kondensator machen, aber da ändert sich nix?! Oder einfach nur 
Ungenauigkeit des (Digital-) Multimeters?

Also vielen Dank nochmal 4 help, vielleicht funktionierts ja doch noch 
irgendwann!

*ptr

Autor: Mark Hämmerling (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Salut,

zu 2.) Die 720mA spielen nur dann ne Rolle, wenn die NIC soviel braucht. 
Wie gesagt, Du brauchst Vsb selbst ja nicht.

zu 3.) Der Stecker ist ein 3pin WOL-Header. Also nehme ich an, daß er 
auf ne steigende Flanke (oder eben 150ms high-pulse) reagieren wird wie 
jedes andere Board auch.

zu 4.) Solange die 5V da sind, ist doch alles in Butter. Der 
Signal-Eingang sollte(!) hochohmig sein. Solange da nix wesentlich 
höheres als 5V oder niedrigeres als 0V anliegt, passiert da auch nix.

Was die flache Flanke angeht, da wird der C nicht viel helfen. Der kann 
nur hochfrequente Störungen beseitigen. Wenn das so langsam steigt, daß 
Du sogar aufm DMM was von 1.xx V lesen kannst (steht das da länger als 
eine Meßtorzeit?), dann wird der C ohnehin mitgeladen, ohne große 
Auswirkung auf das Ausgangssignal. Und wenn Du die 5V von Vsb direkt 
anschließt, dann sollte die Flanke steil genug sein. Die Länge des 
Pulses spielt wie gesagt keine wirkliche Rolle. Zumindest mein 
Enmic-Board springt so gut wie sofort an. Ich schätze, es reagiert auf 
die Flanke. Auf jeden Fall reichen ihm auch 50ms aus.

Mal ne andere Frage: Im CMOS-Setup alles enabled für Wake-On-LAN?

Mark

Autor: Peter Mairhofer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Danke für deine Hilfe aber der schei** will einfach nicht! Keine Ahnung 
was ich falsch mach, vielleicht schaut das bei Asus echt anders aus. Zum 
Schluss war ich schon überzeugt von deiner Idee, da diese ja wirklich 
sehr einfach ist! Im BIOS habe ich natürlich WOL eingeschaltet.
Bleibt mir echt nur Wake-On-Ring.

*ptr

Autor: Mark Hämmerling (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Salut,

nochwas, falls Du keine Erfahrung mit WOL hast: Das Board muß per 
Software oder durch Betätigen des Ein-/Austasters abgeschaltet worden 
sein. Und das möglichst, nachdem das BIOS vollständig gestartet ist 
(d.h. bis zum Bootloader).
WOL funktioniert nicht, wenn das Netzteil (durch Schalter oder 
Anschließden des Kaltgerätesteckers) eingeschaltet wurde, ohne daß der 
PC schon an war. Auch dann nicht, wenn der PC während der 
BIOS-Initroutine abgeschaltet wird (zumindest bei AWARD ist das so).

Also: PC einschalten, bis zum Bootloader warten, bzw. OS komplett hoch- 
und runterfahren. Per Software oder (langes) Drücken des Tasters 
abschalten und dann am WOL-Header basteln.

Sorry, daß ich das erst jetzt erwähne... fällt mir auch erst jetzt ein, 
daß es das sein könnte, weil Du sagst, daß das Board überhaupt nicht 
reagiert.

Probier das bitte nochmal. Wäre zu schade, wenn's an so ner Kleinigkeit 
scheitern würde.

Viel Erfolg!
Mark

Autor: Peter Mairhofer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!!

Vielen Dank für den Tipp! Hab zwar vorher auch schon daran gedacht, weil 
ich das in einer Newsgroup gelesen hab, hab aber offensithlich nicht 
genug probiert.
Also ein *Teil*erfolg scheint sich eingestellt zu haben.
Es scheint nur zu gehen, wenn der PC im "Suspend"Mode und NICHT im 
"Soft-Off" Mode ist. Das wird ein Problem!! (siehe unten).
Jedenfalls habe ich im BIOS den Power-Button auf "Suspend" und nicht auf 
"Soft-Off" gestellt. Wenn ich jetzt die Power Taste mehr als 4 Sekunden 
drücke, schaltet sich der PC aus. Wenn ich dann ein WOL Signal 
schicke, geht der PC an und NUR dann.
Das ist ein grosses Problem, denn ich verwende Linux auf diesem PC und 
das halt des Linux scheint den PC in den Soft-Off Modus zu schalten, 
denn wenn ich per Linux den PC runterfahre und dann WOL betätige, geht 
es nicht.
Schaut sehr blöd aus. Bei Wake-On-Ring scheint das nicht so zu sein, 
denn da gehts so wie bisher.
Also grundsätzlich scheint es jetzt zu gehen, aber nur im "Suspend" 
Mode.
Hast du eine Idee wieso? Was ist der Unterschied zwischen den beiden? 
Zieht der Suspend vielleicht mehr Strom als der Soft-Off?

Ich hoffe ich find' ne Lösung dafür, das WOL wäre echt perfekt!

Danke nochmal

*ptr

Autor: Mark Hämmerling (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Salut,

schön, daß es erstmal ansatzweise funktioniert. Wie's jetzt aussieht mit 
dem Aufwachen ausm Soft-Off-Modus, da mußte mal bei Asus nachsehen, oder 
kucken, ob Du im CMOS-Setup nicht doch noch was findest (kein Jumper 
oder sowas dafür nötig?). Weil an diesem Punkt wirds dann 
boardspezifisch. Und da hab ich keine Erfahrung mit Asus. Wie gesagt, 
ich hab hier Enmic/Epox laufen, übrigens nur mit Linux. Und hier 
klappt's ausgezeichnet.

Hoffe, Du bekommst es hin. Ich kann mir jedenfalls nicht vorstellen, daß 
es nicht geht.

Mark

Autor: Peter Mairhofer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Ich gibs auf und denke, du musst deine Vorstellungskraft erweitern ;)
Es geht einfach nicht. Das schas Mainboard hat was, mit dem es sicher 
irgendwie anders geht. Es GIBTS nicht anders.
Ich hab' ALLES probiert, BIOS Update, Asus FAQs alle BIOS 
Einstellungen durchporbiert/kontrolliert, ALLES was auf dem Mainboard 
für Jumper oben sind, Asus support (geschlossen) und stundenlange Suche 
in groups.google.com und www.google.at.
Es funktioniert einfach überall (halt mit Netzwerkkarte). Offensichtlich 
MUSS einfach eine WOL Karte drinnen stecken. Auf irgendeiner Seite hab' 
ich auch glesen dass nur EtherExpress und Intel LanLink unterstützt 
werden, aber das muss ja nicht sein.

Ich seh jedenfalls nicht mehr die geringste Lösung.

Danke trotzdem für deine Hilfe.

Zum Abschluss noch meine Frage (da ich es ja doch über RS232 machen 
muss):
Gibt es jetzt eine einfache Möglichkeit (so komisch es klingt) einen 
Inverter+MAX232 ohne Aufwand zu basteln? Also der MAX232 hat ja schon 
einen Inverter eingebaut, aber offensichtlich muss Ring-Indication 
standardmässig auf HIGH(in RS232) und bei Anruf auf LOW.
Denn der PC schaltet sich sofort ein, lässt sich auch nicht ausschalten, 
wenn ich das Handy über einen MAX232 an R.I. angeschlossen habe, nur 
während ich am Handy klingle, lässt sich der PC abschalten. Also brauche 
ich vorm MAX232 noch einen Inverter. geht das einfacher als über einen 
Transistor und MAX232? (ich hoff' ich weiss was ich meine)


thxx *ptr

Autor: Mark Hämmerling (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Salut,

schade, daß es nicht klappt. Echt unklar eigentlich. Weil eine 
EtherExpress höchstwahrscheinlich auch nix anderes sendet als einen ca. 
50ms langen Hi-Puls (lasse mich gern korrigieren).
Nun, wenn es denn sein muß, würd ich's einfach mit nem NAND-Gatter 
versuchen. Siehe www.reichelt.de

Gruß,
Mark

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.