www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik LCD=>Kontrast=>Probleme!


Autor: Nils B. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!!

Habe folgendes Problem:

Habe ein LCD (HD44780), ist angeschlossen wie im Tutorial beschrieben,
jedoch kein 10k-Poti sondern ein 47k-Poti.
Hintergrundbeleuchtung funktioniert, ich kann jedoch keinen Kontrast
einstellen, beim drehen am Poti ergibt sich kein Unterschied.

Woran könnte das liegen? Ist der Widerstand des Potis zu hoch?
Aber das ist ja eigentlich nur ein Potential was an Vee anstehen soll,
da fließt ja kein Strom, oder?!?!

Autor: Nils B. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hab gerade festgestellt, das der eine schwarze "Nubbel", der hinten
auf dem Display ist, SEHR SEHR heiß wird...?!?!

Das wird ja irgendwie zusammenhängen, aber wo könnte der Fehler liegen?

Autor: Volker (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
na ja, dann ist es wohl schon kaputt, wahrscheinlich Spannungsversorgung
falsch angeschlossen.

Volker

Autor: Sven (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Heiß darf da auf keinen Fall was werden, die Dinger haben einen extrem
geringen Stromverbrauch (außer halt die Hintergrundbeleuchtung).
Es gibt auch LCDs die eine negative Spannung für die
Kontrasteinstellung brauchen! (HT-Typen, erweiterter Temperaturbereich,
soweit ich weiß. Hatte ich auch schon, kann man aber mit einem ICLxxxx
nen kleinen Wandler bauen).
Datenblatt sollte über Anschluß und Spannungen Aufschluß geben.....

Sven

Autor: Nils B. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Also, ich hatte das Display ja vorher schon angeschlossen, hatte nur
Probleme (wohl wegen zu langer Zuleitung), habe es jetzt alles neu
angeschlossen, und seitdem die Probleme...

Ich werde nochmals alle Anschlüsse kontrollieren, es kann ja dann nur
ein Verdrahtungsfehler sein.

also ein 47k-Poti ist zur Kontrasteinstellung genau so geeignet wie ein
10k-Poti, richtig?

Autor: Nils B. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Thema kann geschlossen werden, Volker hatte recht, Display ist defekt,
das andere was ich hier rumliegen hab funktioniert an der gleichen
Schaltung!!

Sch...ade...

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.