www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Resetproblem mit Motortreiber


Autor: Sebastian --- (dark_flash01)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Guten Morgen,
sagt mal hattet ihr schon einmal das Problem, dass
sich der Mega32 ab und zu mal resetet?
Ich glaube es tritt dann auf, wenn der Motortreiber L298N
die Motoren umpolt. Ich hab schon einmal versucht
2 Spannungsquellen zu nutzen, aber da waren dann die beiden
Massen (nur ein Massepin am Motortreiber) verbunden und
als der ein paar Mal umgepolt hatte, resetete er sich wieder.
Kann ich den µC irgendwie davor schützen oder den Strom für den Motor
begrenzen?

Grüße Basti.

Autor: Hubert.G (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Poste mal deine Schaltung, vieleicht ist dann das Problem leichter zu
sehen. Wenn es ein SW-Problem ist müsste der Reset auch ohne
angeschlossene Motoren kommen.

Hubert

Autor: Roland Praml (pram)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wichtig ist auch ein sauberer Aufbau.

Abblock C's möglichst nahe am AVR, sternförmige Stromverteilung,
insbesondere die Masse.
Entstörung des Motors.

Gruß
Roland

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.