www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Probleme beim DCF77 Empfang


Autor: Martin (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Leute!
Ich möchte einen µC an eine DCF77 Empfängerplatine anschließen, um die 
genaue Uhrzeit ermitteln zu können. Es handelt sich um jene 
Empfängerplatine, die es bei Conrad zu kaufen gibt (Best.Nr. 641138-41). 
Dieser Artikel ist im Internet plötzlich nicht mehr anschaubar.
Zu Beginn habe ich diese Platine an das Oszi angeschlossen, damit man 
mal ein Signal sehen kann.
Das ist jedoch mein Problem: Ich sehe kein Signal. Das einzige Signal, 
welches ich sehe ist 0V.
Ich habe das Ganze so angeschlossen wie es im Datenblatt steht oder wie 
ich glaub es zu verstehen.
Pin 1 Masse
Pin 2 1,5-15V   (Ich habe 5V angehängt.)
Pin 3 nicht invertierender Ausgang (Pull up mit 10K.)
Pin 4 invertierender Ausgang (Nicht angeschlossen.)

Ich habe auch schon versucht, den invertierenden Ausgang zu messen, was 
zum selben Ergebnis führte, nur mit dem Unterschied, dass dieser nicht 
0V, sondern 5V lieferte. Kann es sein, dass ich keinen Empfang habe? 
Wenn man die Antenne berührt, dann kommt es gelegentlich zu einem Signal 
am Ausgang.
Martin
PS: Ich habe euch das Datenblatt hineingestellt.

Autor: Peter Dannegger (peda)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Fernseher oder PC-Monitor in der Nähe ?
Dann diese abschalten.

Wände aus Stahlbeton ?
Dann aus dem Fenster halten.


Peter

Autor: Uwe (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi!
Wenn du irgendwo im Keller oder so sitzt, wo schlechter Empfang.ist, 
hast du keine Erfolge. Die C...Antenne taugt leider nicht viel.Versuche 
es an anderer Stelle, zur Not mit einem Stück Drat als Hilfsantenne.
Gruss Uwe

Autor: Matthias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Martin,

soweit ich das DCF77-Modul verstanden habe, schalten da  Transistoren 
den Signalpin (3 und 4) lediglich gegen Masse. Da Dort aber noch das 
Bezugspotential "+5V" fehlt, kannst Du da dann auch lediglich "0Volt" 
messen. Wie in dem Datenblatt zum DCF77 Empfängerbaustein auf Blatt 1 zu 
sehen ist, mußt Du zwischen den Klemmen 2und3 (2und4) je einen 
Pullup-Wiederstand anlegen, um den logischen Signalwechsel zwischen 0 
und 5Volt Messen zu können. Ein 10K Ohm Wiederstand sollte da gute 
Dienste leisten.

Kannst ja mal berichten, was Deine Erfolge mit dem Modul machen.

MfG
Matthias Topel

Autor: Martin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für eure Tipps.
Leider hatte ich noch keinen Erfolg.
Ich versuche einmal einen ganz anderen Ort. Vielleicht klappt es ja 
dann.

Martin

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.