www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Lärmampel


Autor: Tim (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich bin dabei eine sogenannte Lärmampel zu bauen.
Damit kann man zunehmenden oder störenden Lärm signalisieren.
Man kann sowas z.B. hier für 400€ kaufen:
http://www.onlineverwaltung.de/scripts/content.php...

Mein Aufbau ist folgender:
Electret Mikrofonkapsel -> Vorverstärker -> LM3915 Dot/Bargraph Anzeige
-> LEDs

Soweit funktioniert das ganz auch schon. Nur bin ich mit der LED
Anzeige nicht zufrieden. Durch die hohe Dynamik des Mirkofons bzw. der
Spannung die der Vorverstärker ausgibt, gibt es bei den LEDs keine
festen EIN/AUS Zustände. Die LEDs flackern aufgrund der sich ständig
ändernden Spannung immer. Ich stelle mir das aber so vor, das sich die
LEDs wie eine normale Ampel verhalten. Also bei akzeptabler Lautstärke
-> grüne LED an. Bei zunehmen Lautstärke -> grün aus, gelb an. Bei zu
hoher Lautstärke -> grün aus, gelb aus, rot an.
Wie könnte man dieses Verhalten erreichen?
Vielleicht hilft es vor den LM3915 einen OPV als Integrator zu
schalten?


MfG Tim

Autor: Rahul (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Meinst du sowas wie die Peak-Anzeige bei Audioanzeigen, dass der höchste
Wert für eine gewisse Zeit angezeigt wird?

Dann wirst du etwas haben müssen, das dir die Anzeige zwischen
speichert und nach einer gewissen Zeit oder bei einem höheren Pegel die
Anzeige verändert.

Ich stelle mir ein paar Komparatoren vor, die (retriggerbare) Monoflops
triggern, wobei der für die rote LED den für die gelbe und grüne
resetet, und der für die gelbe den für die grüne resetet.
Das erfordert noch ein paar Dioden zur Entkopplung...
Eigentlich braucht die grüne gar kein Monoflop, die wird einfach nur
ausgeschaltet, wenn eine der beiden anderen an ist...

Autor: Rahul (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Audiosignal sollte noch gleichgerichtet werden...

Autor: Tim (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja sowas wie ein Peak Anzeige ist wohl das richtige. Das ganze müsste
aber auch schnelle genug reagieren. Sobald es wieder leiser wird sollte
die rote LED wieder ausgehen.

@ Rahul
Das mit dem Gleichrichter steht auch im Datenblatt zum LM3915. Ich
hatte mal zum Test einen  Brückengleichrichter verwendet, aber keinen
Unterschied festgestellt.

Autor: Rahul (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Reaktionszeit könnte man ja bei den Monoflops einstellen...

Autor: Tim (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
...ja stimmt.. RC..

Die Komperatoren könnten ja mit dem LM3915 realisiert werden.
Welche Monoflops wären für sowas geeignt?

Autor: Rahul (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
74xx123 oder so. mal bei Philips oder so auf der Seite gucken.

Autor: tubbu (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sowas mit Komperaroren ist doch viel zu umständlich.
Lieber gleichrichten und dann nen Tiefpass dahinter.

Autor: Ecki Bär (ecki)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
abo

Autor: walifogel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Setze in deine Versterkerlinie einen Kondensator ein, der vom Signal mal
mer, mal weniger, aufgeladen wird, die nachvolge Schaltung reagiert
entsprechend träge.
wf

Autor: tubbu (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
das wäre dann ein tiefpass

Autor: AxelR. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
integrator eben, wie in der Beschreibung angegeben.
Oder?#
Integriertes Laustärke-Messgerät
Integrierendes Lautstärke-Messgerät
Hmm..
Mikro->Amp->Gleichrichter->Integrator mit:
einstellbarer "Anschwellzeit" (langsam)
einstellbarer "Abschwellzeit" (schnell)
gaanz hinten drann den LM3915 zur Visualisierung.

Geht auch in Software mitm Mega8 oä. muss aber nicht g

Gruß
AxelR.

Autor: Tim (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe jetzt parallel zum Ausgang des Vorverstärkers einen Elko
(22µF) und einen Widerstand (50Ohm) geschaltet. Die Anzeige reagiert
jetzt schon fast so wie ich mir das vorstelle. Sie ist jetzt ziemlich
träge. Was mich jetzt aber wieder stört ist, dass der angezeigte Pegel
viel geringer ist. Es leuchten nicht mehr soviele LEDs auf. Die Anzeige
ist also nicht mehr so empfincdlich wie vorher.
Wahrscheinlich muss ich die Werte vom R und C nochmal ändern?!?!

MfG Tim

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.