www.mikrocontroller.net

Forum: Platinen EAGLE (Druckbereich festlegen)?


Autor: Mike (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Bin gerade dabei meine erste Platine fertig zustellen. Hat auch ganz
gut geklappt. Jetzt wollte ich mein Layout mal probehalber ausdrücken
(ob alles Passt). Mein Problem ist nur dass er 50 Seiten drücken will
obwohl meine Platine bisschen kleiner als EURO ist. Setze ich jetzt den
Page Limit auf 1 ist meine Platine Sogross wie ne Briefmarke. Kann man
dem irgendwie sagen (z.B.: einen Rahmen um das Layout ziehen) und sagen
"hier ist mein Layout, bitte nur das drucken!!"

Dank im Voraus! Mike

Autor: EZ81__ (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Eagle scheint die Größe des zu druckenden Bereichs nicht von allem
angezeigten abhängig zu machen, sondern von den Elementen, die
tatsächlich intern 'da' sind. Beispiel 10*10mm^2 Platine, 2m^2
GND-Polygon drumherum ziehen, Ratsnest, Polygon nur im Bereich der
Platine sichtbar, Eagle will trotzdem 2m^2 ausdrucken. Dafür, dass
Bauteile manchmal sehr weit in irgenwelche Ecken ragen zu scheinen,
obwohl sie auf der Platine sind, gibt es eine bestimmte Erklärung...
Vielleicht war ja auch nur eine Bauteilbibliothek verseucht...



Grüße
;Matthias

Autor: Ralf (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja, das passiert gern, wenn man eine eigene Bibliothek verwendet, die
nicht sauber erstellt ist.

Blende mal ALLE Layer ein, und klick auf FIT (Alt + F2).
Wenn sich dann deine Platine z.B. rechts oben befindet, dann muss das,
was falsch in einer Bibliotheken ist, links unten sein.

Dann musst du versuchen, herauszufinden, zu welchem Bauteil der Fehler
gehört, und die entsprechende Lib nachbearbeiten...

Ralf

Autor: Mike (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für eure Antworten. Hab es mal ausprobiert damit alle Layer
anzuschalten und dann Fit zu drücken. Leider zentriert er mein Layout
(in Briefmarkengröße) und ich kann keine Rückschlüsse auf das unsaubere
Bauteil machen. Was könnte man denn in der Bibliothek falsch machen das
dieser Fehler auftaucht? Sind glaube ich nur zwei die ich dann
kontrollieren müsste.


Gruß Mike

Autor: Dominik T. (dom) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mir ist da heute auch etwas Dummes passiert. Habe nen zweiseitiges
Layout ausgedruckt, geätzt, gebohrt, ... Dann wollte ich nen IC-Sockel
bestücken und habe bemerkt, das der Raster nicht passt.
Ich hatte beim Drucken noch einen Rand von 30mm drin, dadurch wurde das
Layout um 5 % verkleinert, das sieht man ja so auf Anhieb nicht. :-/

Autor: Mike (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Servus,

ich hab jetzt mal meine Bibliotheken durchgesehen und bei einer die ich
selbst erstellt habe einen Fehler gefunden. Ich weiß jedoch nicht was
ich bei dem Bauteil EADIP204-4 falsch gemacht haben könnte.
Vielleicht hat ja jemand kurz zeit mal drüber zu schauen. Wäre nett,
weiß nämlich nicht mehr weiter.

Gruß Mike

Autor: hmmm (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Mike

hmmm   bei mir load error 290    bei deiner datei

 eagle 4.16 hier

Autor: Mike (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
@hmmm

Ich hab sie nochmal reingestellt. Bei mir funzt sie (EAGLE 4.11).
Habe aber gemerkt das, wenn ich die Datei nochmal aus den Netz zieh,
eine Art Schreibschutz aktiviert wird (Steht bei mir unter
Eigenschaften der Datei: "Die Datei stammt von einen anderen Computer.
Der Zugriff wird aus Sicherheitsgründen geblockt."). Vielleicht liegt
es daran?


Gruß Mike

Autor: Mike (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Servus,

ich habe im Großen und Ganzen das Problem lösen können.
Hab mein Schaltplan gespeichert und dann nach und nach die einzelnen
Bauteile gelöscht bis das Layout normale Größe hatte.
Der Fehler lag in meiner LCD.lib.

Hab das Bauteil EADIP204-4 noch mal editiert. Wenn ich jetzt aber das
Bauteil benutze hab ich dasselbe Problem wieder und die Bibliothek ist
dann auch futsch. Kommt EAGLE mit der 2mm Rasterung nicht klar oder
weiß jemand was ich falsch gemacht habe? Weiß nicht mehr weiter. Bin
seit Tagen an diesem Problem dran.

Wäre nett wenn jemand mal drüber schaut.

Gruß Mike

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.