www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik AVR UART Problem


Autor: Christian Sander (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Liebe Newsgroup,

ich betreibe einen ATmega162 auf der seriellen Schnittstelle 0 über
eine RS-485 Baustein.
Die Datenübertragung zum nächsten Teilnehmer wird dann auf LWL
umgesetzt und auf der anderen
Seite befindet sich dann die gleiche Beschaltung. Beim LWL sind die TX
und die RX Leitungen
kurzgeschlossen, dass heist ich habe eine Halbduplex-Übertragung.

Jetzt habe ich das Problem dasin dem Moment wenn keine Daten empfangen
werden die RX
Leitung low ist. (Da sie vom LWL getrieben wird).
Laut Datenblatt muss diese Leitung aber nach dem Empfang, im
Ruhezustand, auch wieder
auf high stehen.

Kann ich den Controller an der Stelle irgendwie überlisten?


Grüße aus München,

Christian

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.