www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik AVRisp Update => nichts geht mehr


Autor: Pit (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

habe gestern das neue Service-Pack 4 für AVR-Studio installiert. Als
ich heute meinen AVRisp angeschlossen (serielle, Com1) habe, kam die
Meldung dass es eine neue Firmware für den AVRisp gibt. Also das Update
ohne Fehlermeldung durchgeführt,  aber dann....
AVRisp vom Programmierboard abgesteckt und wieder angesteckt die LED
leuchtet rot, dann orange, dann grün und dann geht sie aus und mein
AVRisp wird nicht mehr erkannt.
Ist das einem von euch schon mal passiert und wer kann mir da
vielleicht weiterhelfen.

Bin für jeden Hinweis dankbar!

Vielen Dank im voraus,

Pit

P.S. das war nicht mein erstes Update des AVRisp und bisher hat es
noch nie Probleme damit gegeben

Autor: Thomas O. (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Downgrade auf eine ältere Version geht wie folgt.
AVRProg.exe aus der neusten AVR-Studio Version nehmen und damit die
ältere STK500.EBN Datei aufspielen. Nehme mal an du weißt wie man den
AVRISP in den BOOTLOADER-Modus schickt (Gehäuse öffnen und Brücke
setzen). Hab dir mal die das EBN-File mit der AVRISP Version 1.1e
(letze AVR-Studio 3 Version) mitgeschickt um den AVRISP downzugraden.
Diese Version funktioniertsowohl mit den 3er AVR-Studioversionen als
auch mit der aktuellesten AVR-Studioversion, dort kommt dann auch die
Abfrage ob man upgraden will. Wenn man das macht dann ist er nicht mehr
kompatibel zu den älteren 3er Versionen wie ich sie z.b. an einem
schwächerem Laptop betreibe. Aber bei mir funktioniert auch alles ohne
das Update deswegen überspringe ich es.

Ich denke das der 1200er eh gegen beschreiben geschützt ist, damit man
das Teil nicht killen kann und das eigentliche Programm dann im 8515er
landet.

Autor: Pit (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Thomas,

vielen Dank für die schnelle Antwort.

Leider weiss ich nicht wo ich die Brücke zu setzen habe, vielleicht
kannst du mir da noch schnell weiterhelfen.

Pit

Autor: Thomas O. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
geh mal ins AVR-Studio dann auf Help->AVR Tools User Guide->AVRISP
User's Guide->Getting Started->AVRISP User's Guide: Maual Firmware
upgrade, da sind die Bilder wo die Steckbrücke gesetzt werden muss und
die genaue Schrittfolge die du beachten musst. Aber vielleicht kannste
auch gleich die neue ebn-Datei verwenden um nicht erst downgraden zu
müssen. Ich würde aber downgraden und das update wird dann aus dem
AVR-Studio eh von alleine vorgeschlagen. AVRPROG befindet sich in einem
extra Verzeichniss im AVRStudio-Verzeichniss.

Autor: Pit (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Thomas, danke nochmals.

Die Hilfe im AVR-Studio hatte ich auch schon bemüht, aber nichts
gefunden.


Pit

Autor: Pit (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also das mit dem manuellen upgrade hat super funktioniert.

Verwendet habe ich die von Thomas angehängte Datei. Als ich danach
erneut ein Upgrade über das AVR-Studio durchgeführt habe, trat der
Fehler erneut auf. ABER: Danach habe ich probeweise ein manuelles
Upgrade mit der neuen stk500.ebn probiert und das hat funktioniert.
Mein AVRisp wird jetzt wieder erkannt und hat auch die neueste
Firmware.

Fazit:

=> automatisches Upgrade über AVR-Studio ist bei mir fehlgeschlagen

=> manuelles Upgrade wie in der AVR-Studio Hilfe beschrieben,mit
der stk500.ebn aus dem AVR-Studio 4.12 SP4 war erfolgreich

Vielleicht hilft's jemanden bei dem dasselbe Probleme auch auftritt.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.