www.mikrocontroller.net

Forum: Compiler & IDEs device type not defined


Autor: Selma (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Gude!

Ich bin hier grad am ausflippen! Habe auf die neuste WinAVR umgestellt
und wollte mein Projekt kompilieren. Makefile ist mit dem neuen MFile
erstellt, CPU ist korrekt definiert.

Beim Versuch zu kompilieren erscheint folgende Meldung:

#warning "device type not defined"

Kann mir jemand helfen? Ich habe keine Idee mehr, was ich noch machen
kann.

Selma

Autor: Selma (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wohl gemerkt, ich habe das MFile benutzt, welches mit dem neuen WinAVR
kommt. Es kann doch wohl nicht sein, dass ich da nochwas ändern muß,
oder?

Hab da was gelesen CFLAGS und ALLCFLAGS, ich versteh nur
Bushaltestelle.

Autor: Selma (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schade, kann mir wohl niemand helfen. Egal, dann schmeiß ich den Müll
wieder runter und nehme die alte Version.

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielleicht erzählst du ja mal mehr?

- welche CPU?
- wie sieht die Kommandozeile genau aus?

Autor: Selma (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Jörg,

die CPU ist ein ATmega8. Im Anhang ist das Makefile sowie der beim
Aufruf erzeugte Output angehängt.

Der Kommandozeile ist zu entnehmen, dass keine Angabe zur CPU vorhanden
ist. Aber warum, muß ich das manuell ergänzen? Bei der alten
WinAVR-Version klappte das problemlos. Ich hoffe, du kannst mir
helfen.

Vielen dank schon mal.

Selma

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du hast "ddsgen" an zu vielen Stellen und falsch eingetragen.
Das hatte mehrere putzige Effekte, u. a. war die Linkreihenfolge
falsch (-lm vor dem eigentlichen Code), und ddsgen.c wurde mit
dem Listing überschrieben...

Normalerweise genügt es für eine einzelne Quelldatei, dass man
TARGET setzt und SRC auf dem Default belässt (``$(TARGET).c'').
CPPSRC lässt du dann ganz frei, schließlich kannst du nicht
zugleich eine C- und eine C++-Quelldatei gleichen Basisnamens
haben.  Überhaupt war dein wesentliches Problem, dass du bei
SRC den Dateinamenssuffix (.c) vergessen hattest.

Autor: Selma (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke Jörg, jetzt funktioniert es. Eine Frage hätte ich noch bezüglich
drei Warnungen, die beim ompilieren auftreten.

"Warning: file C:/DOCUME~1/EWEDDI~1/LOCALS~1/Temp/ccaseaaa.s not found
in symbol table, ignoring"

"Warning: ignoring function __vectors() outside any compilation
unit"

"Warning: ignoring function __bad_interrupt() outside any compilation
unit"

Wo kommen die her?

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Wo kommen die her?

Vom AVR-COFF-Konverter, die darfst du ignorieren.

Ich weiß nicht, ob du COFF überhaupt wirklich brauchst oder
nicht.  Braucht man mittlerweile eigentlich nur noch, wenn man
entweder VMlab für die Simulation benutzen will oder bei AVR
Studio mehr als 64 KiB an Code hat.  Ansonsten ist AVR Studio
mit ELF + DWARF-2 als Debuginformation besser bedient.

Autor: Selma (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielen Dank!

Autor: Philemon Nomo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Alle,

Ich versuche seit fast zwei Wochen das compilerprogramm für ATMEL
Processor zur installieren. Und habe bis jetzt noch nich geschaft.Ich
habe genau die Anweisungen unter die internetseite:
"http://www.roboternetz.de/wissen/index.php/Avr-gcc...
e_installieren" gefolgt. Folgende Fehlermeldung bekomme ich wenn die
Konfiguration gelaufen ist:

../configure --target=avr --prefix=/usr/local/avr --disable-nls

(...)
Checking for avr-ar... no
Checking for avr-as... no
Checking for avr-dlltool... no
Checking for avr-nm... no


ich versuche avr-gcc unter QNX-Betriebsystem zur installieren.

Danke für eure Hilfe

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bitte mache für eine völlig unabhängige Frage auch einen neuen
Thread auf.

Du versuchst, den AVR-GCC zu compilieren, ohne bereits die
avr-binutils compiliert und installiert zu haben, das funktioniert
nicht.  Die binutils sind Voraussetzung.

Bitte compiliere alle drei Teile (binutils, GCC, avr-libc) mit
den gleichen --prefix-Einstellungen beim ./configure.

Autor: Hanno (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich danke auch für die Hilfe, ich hatte das gleiche Problem wie Selma.

Die automatische makefile-Erstellung hat mir
cppsrc= main.cpp
mit hineingeschrieben. Nachdem ich das entfernt hatte, ging es wieder.

Hanno

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.