www.mikrocontroller.net

Forum: Offtopic Komme nicht auf meinem Webserver von extern


Autor: Thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo,
ich habe einen webserver (atmega128 und ethernutOS).

intern (im LAN) komme ich mit 192.168.0.101 wunderbar auf die html
oberfläche!

trotz der portweiterleitung in meiner fritzbox 7170 (port 80 an
192.168.0.101)komme ich nicht auf meinen webserver.

egal ob über dyndns.org oder über die direkte ip adresse
(wieistmeineip.de) es kommt die übliche fehlermeldung wenn eine seite
nicht erreichbar ist (netzwerk-Zeitüberschreitung).
Ich habe es bekannte von ausserhalb testen lassen, man kommt nicht
drauf.

hänge ich einen hdd-webserver (ipdrive) drann (mit exakt den gleichen
einstellungen IP:192.168.0.101  SUB:255.255.255.0 GW:192.168.0.30)
dann komm ich auf die oberfläche auch von außerhalb.
(selbstverständlich steck ich das andere gerät dann ab!)

Eins setz ich noch oben drauf!!!:
im schulnetz eingebunden mit eigener ip und deren gateway und
subnetmask, kommt man auch von außen auf meinen webserver, zb über
dyndns.org.

Zum verzweifeln ist das! WEIS IRGENDJEMAND WAS/WO hier der FEHLER
STECKT???

Autor: Kommentar (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schon mal die Einstellungen fürs Gateway gechecked ?

Autor: Mutmaßungen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Überprüf mal ob die MTU-Werte in beiden Geräten (Router und Webserver)
identisch sind. - Könnte auch ein timeout sein, weil der Webserver zu
langsam antwortet. Probier mal einen traceroute ob du überhaupt hinter
den Router kommst.

PS: Kenn mich nicht mit den ethernut selber aus.

Bitte melde dich an um einen Beitrag zu schreiben. Anmeldung ist kostenlos und dauert nur eine Minute.
Bestehender Account
Schon ein Account bei Google/GoogleMail, Yahoo oder Facebook? Keine Anmeldung erforderlich!
Mit Google-Account einloggen | Mit Yahoo-Account einloggen | Mit Facebook-Account einloggen
Noch kein Account? Hier anmelden.